Best "modern" way to play old Infocom games?

I’m not a veteran IF player, but I’ve played a few games. I thought I’d finally work my way through some classics, starting with the Zork games (and other Infocom games).

So I bought the Zork Anthology on Steam. However, as a newbie accustomed to more modern games (Anchorhead 2018 being the most prominent), the experience is a bit lacking. The Steam version runs in DOSbox (I assume it’s just the original interpreter), and has some Quality of Life issues, like:

  • Common, modern abbreviations (like “X”) don’t work
  • I can’t use the arrow keys! No moving to the left and right in what I’m writing, and, perhaps more importantly, I can’t scroll through the command history
  • I can’t copy/paste any of the text in the terminal
  • The “SCRIPT” command crashes the entire game; judging by the stdout.txt written by DOSbox (“Exit to error: DOS:Unhandled call 05”), DOS is unable to create a transcript file

And probably other stuff too.

If there are any ways to fix these issues in DOSbox, that’d be nice, but it’d be even nicer to get some recommendations on alternate interpreters/clients that provide a better user experience for these old games.

Someone mentioned Frotz elsewhere, so I’ll check that out, but any other tips would be nice!

1 Like

You should be able to extract the storyfiles out of the Steam folders (or just download them from The Obsessively Complete Infocom Catalog).

Then get a modern interpreter. The ones we typically recommend include:

Playing them online is another option. Just add the URL to the end of https://iplayif.com/?story=, like so:

2 Likes

Thanks a lot! Looks like Lectrote is the one bundled with Anchorhead 2018, so that one’s familiar and nice.

I wasn’t able to open the ZORK1.DAT file in Gargoyle though. Edit: Nevermind

I don’t think this is handled by the interpreter in Z-machine games, but by the game’s parser. A more modern interpreter can absolutely make some things more user-friendly but the old games will always ‘feel a bit lacking’ compared to modern ones, in my experience :slightly_frowning_face: Some are still worth it though!

1 Like

If you’re playing with Frotz in a terminal, it has a command-line switch -x that claims to expand g, x, and z to their expected modern equivalents. I’ve never noticed it actually working, though, when I’ve tried it (Frotz 2.44 under x64 Linux), but maybe it works under other setups.

2 Likes

The mod I did of Zork I a few weeks ago have X implemented. It’s very easy to add new synonyms to other games if you wish.

There’s more suggestions for modernizations over in this thread.

3 Likes

Frotz 2.44 is rather old. It’s at 2.52 now with 2.53 coming any day now.

1 Like

I just tested -x in 2.52. It worked in Zork 1 Release 15, but not in HHGG Release 31.

EDIT: Ah, but it does work in HHGG Release 59. Weird.

OMG x also works out of the box in HHGG Release 59 in Gargoyle and Spatterlight?! I had no idea!

But it doesn’t work in Lectrote? (Or Quixe or iplayif in general…?)

Thanks for pointing that out. It looks like Frotz 2.52 is only packaged for the absolute most recent Ubuntu releases, though (at least, in the downloads at pkgs.org). I’ll download and compile a newer version soon, but if 2.53 is about to be released, I’ll wait for that.

Dan’s comment got me wondering, and I tried x [something immediately visible] on my whole catalog of Infocom games on my hard drive. In case it’s helpful, here’s a quick list of where x doesn’t seem to map effectively on to examine under Frotz 2.44 with frotz -x on my machine:

  • A Mind Forever Voyaging (release 77)
  • Arthur: The Quest for Excalibur (release 74)
  • Beyond Zork (release 57)
  • Border Zone (release 9)
  • Bureaucracy (release 116, .z4)
  • Dungeon (Release 12 / Serial number 990623 / Inform v6.14 Library 6/7; .z5)
  • Leather Goddesses of Phobos (release 4, .z5, but release 59, .z3, doe work)
  • Nord and Bert Couldn’t Make Head or Tail of It (release 19, .z4)
  • Planetfall (release 10; .z5)
  • Sherlock (release 26, .z5, and release 21, .z5)
  • Trinity (release 12, .z4)

Here’s a quick list of where it does work:

  • Ballyhoo (release 97)
  • Cutthroats (release 23, .z3)
  • Deadline (release 22, .z3, and release 27, .z3)
  • Enchanter (release 29; .z3)
  • Hitchhiker’s Guide (release 59; .z3)
  • Hollywood Hijinx (release 37; .z3)
  • Infidel (release 22; .z3)
  • Leather Goddesses of Phobos (release 59, .z3, but release 4, .z5, doesn’t work)
  • Mini-Zork (release 34, .z3)
  • Moonmist (release 9, .z3)
  • Seastalker (revision 86, .z3, and revision 15, .z3)
  • Sorcerer (release 15, .z3)
  • Spellbreaker (release 87, .z3)
  • Starcross (release 17, .z3)
  • Stationfall (release 107, .z3)
  • Suspect (release 14, .z3)
  • Suspended (release 8, .z3)
  • The Lurking Horror (release 203, .z3)
  • The Witness (release 22, .z3)
  • Wishbringer (release 68, .z3)
  • Zork I (release 88, .z3)
  • Zork II (release 68, .z3)
  • Zork III (release 17, .z3)

I couldn’t figure out how to get a prompt up for Journey: The Legend Begins (.z6) and didn’t take the time to learn the unusual controls for a game I’ve never gotten around to playing. I couldn’t get Return to Zork running in Frotz, but then, I don’t think it’s a Z-code game? I also couldn’t get to a prompt in Zork Zero (but then, the manpage explicitly says that .z6 is semi-supported, and I wouldn’t really want to run it in a terminal anyway).

In any case, it looks like it works much more often than not! It turns out it’s just that the Infocom games I’ve played in a terminal with Frotz happen to be disproportionately selected from the “doesn’t work” list.

OMG x also works out of the box in HHGG Release 59 in Gargoyle and Spatterlight?! I had no idea!

Bocfel (the default Gargoyle interpreter, and I think for Spatterlight, too) expands x, g, z, and o for old Infocom games (versions 1-4). It does this by default, although it can be disabled.

I used the old Infocom Fact Sheet to determine which games are versions 1-4. Notably this doesn’t include all games on Zarf’s Obsessively Complete Infocom Catalog, so there will be some older games where the abbreviations don’t work.

I’ve thought about updating the list of games using Zarf’s catalog, which would be trivial since a JSON version of the catalog is provided.

A list of games which don’t support abbreviations would be best, of course, but it’d be a lot of work to gather that, so using versions 1-4 as a proxy is decent, I think.

I’d like to get some stuff finished with the X11 interface before releasing 2.53. It’ll probably be a week or so. In the meantime, it shouldn’t be much trouble to simply do a pull and recompile when the 2.53 is ready.

1 Like

No worries! The simple truth is that this week is going to be busy, and I’m unlikely to have much time to really sink into a work of IF anyway, so holding off until the new version is out isn’t a sacrifice, large or small.

Thank you for frotz!

I was wondering about that, I’m playing Zork at the moment in Gargoyle and was surprised that “x” worked. Happy to understand why that is!

I too bought the Zork Anthology recently, from GOG.com. It actually came packaged with six games, one of which was Planetfall… :flushed: Anyways, obviously I didn’t complain about it. :sweat_smile:

I have multiple copies of the games already, I suspect I actually have most if not all of the major revisions of every Infocom game. To that end if you (or anyone) is wanting to try one then let me know and I’m happy to share. I think the reason I wanted to buy an official set of at least some of the games was just part curiosity, would it come packaged differently etc same as yourself it came via DosBox which to be honest was a bit ho-hum.

I think the best “modern” way to try and answer your question doesn’t actually exist yet. To my mind it would be updating every Infocom game to allow the shortcuts ie X for EXAMINE but also provide a nice looking interface like this one for example.

I mean no disrespect to any existing terp but the BBC HHGTTG interface is really nice. :slightly_smiling_face::+1:

Adam

1 Like

Blast from the past! This version of H2G2 was the first time ever I set eyes on a text adventure. (Well, not the anniversary version, but the one without the keyboard below.) I thought the interface was pretty nifty, I doubt I would have given it more than a glance if it had been just a white-on-black screen of text. Of course, I got lost and frustrated within the first ten moves (I had not read the books yet so I sure wasn’t going to think of lying down in front of a bulldozer!), but I remember retrying many times. Not long after that I found The IF Archive. The rest is, as they say, history.

I still have to play H2G2 to the end though…

1 Like

I’m trying to get clear on the current status of Infocom games. I see there’s a “Zork Anthology” for sale consisting of the Zork games and (for some reason) Planetfall:

Am I right in thinking all the other Infocom games can be safely considered abandonware at this point?

I guess so, but it’s worth noting that the Infocom library has been rescued from “abandonware” before. For example, in 2012, Activision published “The Lost Treasures of Infocom” as an iOS app. Sadly, it was a 32-bit iOS app; iOS 11 and up don’t support 32-bit apps. AFAIK, you can no longer download this app from Apple, even on an iOS 10 device.

So, it is safe to say “no company legally publishes A Mind Forever Voyaging.” But I would bet against you if you said “no company will ever publish AMFV ever again.”

3 Likes

This happened with my (at the time) legally obtained copy of Broken Sword; Shadow of the Templars. After my motherboard crashed I went searching to redownload my lost game collection and found that it (and a few others) had changed status from abandonware to published. Darn smartphone remakes!

1 Like

With caveats:

  • Abandonware isn’t actually “safe”, legally speaking.
  • But Activision has never objected to the games floating around. Or the source code, now, either.
  • A lot of people say that Zork 1/2/3 are freeware because Activision posted the games for free download, for promotional reasons, on the ZGI web site. (Or RtZ? I think it was ZGI.) This is, I believe, wishful thinking; that web site is long gone.
  • But, again, see above. It’s been easy to find Zork 1/2/3 downloads for decades.
  • As far as we know, HHGG is now owned by the estate of Douglas Adams, not Activision. I say that because Adams had it on his personal web site when he was alive, and then licensed it to the BBC.
  • As far as we know (again), Shogun is now owned by the estate of James Clavell. I say that because they seem to have buried it as far down in a gravel pit as they could manage. :) Shogun was never reprinted after the 1992 LTOI2 CD-ROM collection.
4 Likes