Batman 66: An Action-Packed Interactive Episode, now on the IFDB!

With the Dynamic Duo nowhere to be found and super-criminals running amok, it’s up to you, citizen, to be Batman for a day and serve justice to those unscrupulous fiends. Explore key locations in Gotham City, match wits with Batman’s fearsome rogues’ gallery, figure out the villains’ clues, all the while trying to unravel the mystery of who you are and why you’ve apparently been tasked with saving the day.
Can you cheat death with naught but your wits?
Can you evade devious traps?
Can you save the Dynamic Duo before it’s too late??
Answers in one minute! But here’s a clue: the worst is yet to come…

Bringing Batman to the small(er) screen is the new Batman 66 interactive adventure! Prepare yourself, citizen, because this homage to the iconic TV series features the return of Gotham City, its Caped Crusaders, and their infamous rogues gallery, all in one electronic game! Explore Gotham from the Batcave to the infamous headquarters of the United Underworld, and brave the devious machinations and contraptions of the city’s foulest villains! For long-time fans and newcomers alike, this game is sure to return you to that colorful, absurd and wonderful world of Batman!

Try it out! Have fun! And if you’d like, leave a comment about your experience in Gotham or even about your memories of the TV series-- or any Batman property! Who’s your favorite villain? Which show/movie/book introduced you to the world of Batman? Feel free to share and celebrate these characters as we celebrate the release of the upcoming feature film, The Batman!

Play it here: Batman 66 - Details


(Illustration by Martin Ansin)

13 Likes

Fantastic cover picture. Sounds great, Is there a link?

1 Like

Thanks for the correction, the link to the IFDB has now been added!

I’ll play this properly later. A couple of things i found already;

You cannot go bat poles I was most disappointed!

The bat poles were revealed already when entering the Study, but i could also press the red switch which told me the bookcase reveals the poles.

Looking forward to saying “turbines to speed” later :slight_smile:

1 Like

We played Batman 66 at the Bay Area IF Meetup today and we really struggled with it. We were unable to complete it, even after completely cheating on hints.

Here are issues we found:

  1. ask about business fails when talking to Bruce in the first scene. “You can’t see any such thing.”
  2. If you go northwest from the starting room, you automatically faint, and miss the scene with Bruce. Instead, the game should stop you from leaving, suggesting that you wait here for Wayne.
  3. tell bruce about note “This provokes no reaction.” Throughout the game, you should be able to tell about instead of give or show.
  4. The game sometimes blocks getting things in ways that mock the player. For example, when taking the pen in the study, “What would you do with a pen? Honestly, be a little creative here.” Uhh I was being creative.
  5. The fire poles appear when you look immediately after answering the phone, but before you’ve found the switch in the bust.
    To reproduce:
    z. z. ask bruce about business
    give note to bruce. nw. u. w. get phone. yes. look
    
  6. You can’t flip switch on the switch in the bust.
  7. The scene in Commissioner Gordon’s Office was extremely confusing for us. We thought that we needed to go to the art institute, where the newspaper said that the Hopper painting was being exhibited. If you consult directory about art institute, it gives an address, and it seems like a reasonable lead to follow up, but there’s no way to communicate to the game that I’d like to go to the art institute, or even that I’m wrong about wanting to go to the art institute. ask chief about art institute says, “That’s right, they’re showing that Hopper, aren’t they? I wonder if that’s got anything to do with the riddles…” That indicated to us that visiting the art institute was on the right track, but it wasn’t what the game wanted us to do.
  8. In Commissioner Gordon’s Office, the Chief should have a lot more ask/tell topics. I suggest, at a minimum, he should respond to ask/tell about Commissioner Gordon, Bruce Wayne, Batman, Dick Greyson, Robin, Batcave, Mayor Linseed (and “Mayor” and “Linseed”), all of the featured villains (Riddler, Penguin, Joker, Catwoman, Sandman, Siren, Killer Croc), Newspaper. Anything I can show to Chief I should also be able to tell him about.
  9. If you do anything except ask chief about crisis when you walk in, he says, “In that case, I’ll take your silence as a sign that you don’t know what I’m talking about.”
    He even says that if you ask/tell him about anything else, even questions he can answer, like ask chief about chief, in which case it’s buggy, because I wasn’t silent.
  10. In Commissioner Gordon’s Office, “shelf” should be a synonym for “bookshelf.”
  11. This game has a couple multiple-choice puzzles like this, where the game offers a small number of options, and if you pick the wrong one, you immediately die. There’s the one here where you have to choose the right address, and there’s the one where you’re unmasking False Face. These puzzles aren’t great, because players can just undo and try again. (That’s what we did with False Face.)
  12. In the GOON Building Foyer, “the area behind [the desk] seems conspicuously empty,” but that’s a total red herring. The trapdoor is under the rug and the key is under the armchair.
  13. search armchair fails with a generic message, which prevented us from realizing that we had to look under armchair to find the key. We had to use the hints for this puzzle. I think none of the puzzles in this game require searching, so I think the game should reject searching and instead say, “In this game, instead of searching, you can examine an object, LOOK BEHIND the object or LOOK UNDER the object.”
  14. look under rug “You find nothing of interest.” That’s a really bad message here; it should have solved the puzzle.
  15. push rug move rug “That isn’t something you can switch.” For one thing, pushing and switching should not be synonyms. But for another, it was another false indicator that we couldn’t interact with the rug.
  16. get rug “It’s far too heavy and large to carry.” That indicated us that we couldn’t mess around with the rug. It should say something like, “It’s too bulky to take it with you, but perhaps you could push it or pull it.”
  17. In Underground Landing, you can take the rusty ladder with take all; I don’t think you intended that.
  18. light lamp gives a weird message if you haven’t yet noticed that the chief has matches. It should say something like, “you’ll need a match,” requiring the player to

    >light lamp
    (with the match)
    (first taking and lighting the match)
    That seems to belong to the silent Chief O’Hara.

  19. The Killer Croc puzzle in Far East Sewer Tunnel is a total red herring (the only winning move is to leave Far East Sewer Tunnel right away, and ignore it completely). This is misleadingly cruel, because I think most people will fail to find the key under the armchair at first, and so it falsely appears that you have to solve a puzzle in Far East Sewer Tunnel in order to progress, but in fact, you can’t progress here at all. If Far East Sewer Tunnel hadn’t existed, it would have forced us back into the Foyer to search for the key to the door at the Far West Sewer Tunnel; instead, we wasted a huge amount of time there, in a non-fun way.
  20. x captive chief “You can’t see any such thing.” x captive “You can’t see any such thing.” x captive ohara “You can’t see any such thing.” x silent “You can’t see any such thing.” x silent o'hara you can’t see any such thing.
  21. In Joker’s Lair, listen does nothing at all; there’s no response. listen to conversation fails. We falsely thought that we had to somehow get closer to the conversation in order to hear it. Indeed, since we’ve already heard half the conversation already, I think this puzzle should be cut; the game should just play the whole conversation when we walk in.
  22. If you don’t bring the rope into the Joker’s Lair, you can’t go northeast back out of the room to get it; the game is unwinnable at that point.
  23. tie rope to crank “You can’t move without a decent plan.” That makes it sound like tying the rope to the crank isn’t a decent plan, which is misleading. To solve the puzzle, you have to first tie rope (to nothing) and then tie rope to crank, but it’s not clear enough that you need to do that.
  24. throw rope at crank “Futile.”
  25. wear noose “You can’t wear that!” But the conversation seemed to indicate that the rope is some maharajah’s headgear. You can wear a noose. As far as I can tell, wearing the rope is as good a solution as the “actual” solution, because you don’t even get as far as tying the rope to the crank; you just start to, and then the Mad Hatter sees the rope and slips on the banana peel.
  26. open chest “You can’t see any such thing.” open green “You can’t see any such thing.” open brown “You can’t see any such thing.”
  27. “Two sharply-dressed goon lie” should be “goons”
  28. x goons “You can’t see any such thing.”
  29. After defeating Mad Hatter, turn crank “Nothing obvious happens.” That should do something!
  30. Joker’s Lair doesn’t mention that you can exit northeast to return to Intersection Sewer Tunnel. Similarly, Catwoman’s Lair doesn’t mention that you can exit northwest.
  31. In Catwoman’s Lair, it says, “on which is a coffee jug (full) (empty)”
  32. open shabby door “It isn’t something you can open.”
  33. push chair to shabby door “You can’t see any such thing.”
  34. We all completely failed to solve Catwoman’s lair, even after reading the hints.
    • Knocking on the cat door wasn’t obvious to us, though I guess it was not totally unfair. We had to check the hints for it.
    • Once Miney shows up, you can’t ask/tell miney about anything at all
    • Instead, you have to say miney, open the door, which isn’t even mentioned in talk to miney.
    • We failed to find the things we have to wear in order to satisfy Miney. Nothing we wore (lipstick, glasses, trick insult hat, elegant top hat) seems to have any effect on Miney. It seemed like we needed to wear the lipstick with the coat in this room, but we can’t pick that up. Failing that, we had to give up on the game completely.

I found a bunch of bugs in another Inform game this week, in Raygun Diplomacy, but in that case, the author made the Inform source available to read. That was helpful, because it allowed me to read the source to find solutions to bugs. I recommend publishing the source code with Inform’s “release website” feature.

1 Like

I got stuck as well, a little farther on. Specifically, I couldn’t figure out what I needed to bring through the curtain in the Joker’s lair. (And I was unable to interact with some stuff in that room, like the chests, so wasn’t sure if I wasn’t thinking of something or if I was missing something I should have had.)

Batman 66 is a great setting for a game… the world is zany enough that IF-type puzzles fit right in, and the humour translates really well. (I particularly enjoyed the joke on how Batman must live in Bruce Wayne’s basement.) Watched a lot of Batman reruns growing up, so I’ve got a soft spot for the show… look forward to playing through a future release!

1 Like

In the Joker’s Lair, you have to drop the rubber chicken and wear the Groucho glasses when you go west through the curtain.

Were you able to solve Catwoman’s lair? Even reading all of the in-game hints, I couldn’t solve get through the cat door.

1 Like

Thanks!

Were you able to solve Catwoman’s lair?

Yes! You’re disguising yourself as the joker - put on the lipstick (acquired earlier) and the sleep powder (drink the coffee twice first) and the catnip (under a cushion on the chair)

Thanks. With that, I was able to “win” the game, but not fairly.

In the Acid Chamber, you can just get out of the glass box and go east with no need to think. That’s lucky, because I couldn’t figure out any way to use surfing skills or a way to solve the Riddler’s riddle about getting down from the mountain peak without equipment.

1 Like

I am going to play this and I am very curious if >look at joker’s moustache works! :slight_smile:

1 Like

I beta-tested this game, or rather, I tried to beta-test this game, but I got stuck in Commissioner Gordon’s Office and was unable to progress any further. I did ask the author for a walkthrough, but I never received one, and now the game has been released — oh well!

I’d like to review the game, because the opening shows so much promise, but I’m still stuck in Commissioner Gordon’s Office. I assumed that I needed to ask the Chief the about the Art Institute and then tell him the solution to the riddle, which I’d worked out, but I couldn’t find a way to communicate it to him. I don’t know what else to consult the directory about or tell the Chief about.

Can somebody please put me out of my misery? :face_with_raised_eyebrow:

1 Like

intfiction.org!

For all your public playtesting needs!

Stately Wayne Manor

examine red book

examine comfortable chair

ask bruce about business

give note to bruce

northwest

up

west

answer phone

yes

examine bust

open it

push switch

down

The Batcave

get newspaper

read it

ride bike

east

north

dismount

east

Commissioner Gordon’s Office

ask chief about crisis

examine desk

open drawer

read letter

show it to chief

examine bookshelf

examine directory

consult directory about grand order of occidental nighthawks

show addresses to chief

show letter to chief [again!]

tell chief about 1942 Hopper Drive W

G.O.O.N. HQ

north

look under armchair

pull rug

open trapdoor

down

Sewer Tunnels

examine chief

ask chief for match

chief, give me a match

get lamp

light it

down

west

west

unlock door with key

south

Underground Meeting Room

unmask silent chief

get lipstick

south

get rope

south

pull ladder

climb it

southeast

Catwoman’s Lair

block shabby door with chair

knock on cat door

miney, open cat door

examine chair

get cushion

get catnip

examine it

examine coat

get vial

open it

examine dust

wear lipstick

wear catnip

drink coffee

again

wear dust

miney, open cat door

south

laugh

north

northwest

southwest

Joker’s Lair

listen to hatter

again

again

examine jack-in-the-box

tie rope

tie rope to crank

open brown chest

wear glasses

get chicken [no need for the chicken]

west

east

northeast

climb ladder

ask penguin about penguin

Acid Chamber

examine floor

examine hinge

examine wire

think

wait (up to seven times, until the floor opens)

slide down wire

east

northwest

south

Tiger Pit

put plank on pit

shoot riddler with gun

hit him

yes [your choice, alternate ending]

open box

throw batrope at robin

southeast

yes [your choice, alternate ending]

3 Likes

Sorry I’ve been absent for a while! I’d like to thank everyone for their interest in the game, and also apologize for any inconveniences-- as for the acid chamber, the way out is to examine the floor, examine the hinge, examine the wire, think, wait until the floor opens then slide down the wire. I hope that helps and I will begin work on improving the game soon!

2 Likes

Now knowing how to win the game, I have more feedback.

  1. I guess I was supposed to realize that I can wear the sleep dust from the clue you get when examining the dust, where the game says that the sleep dust “looks like that powdery makeup stuff.” But dust is not normally wearable without some other makeup as foundation. Maybe include some other foundation makeup in the game or something…?
  2. In the Acid Chamber, you have to start with examine floor. I think that’s not a very fair puzzle because the “floor” wasn’t mentioned as an examinable object; examine floor doesn’t work in any other room of the game, even though they all have floors.
  3. slide down wire is a very non-standard verb, and should accept alternatives, including climb wire, grab wire, hold wire, ride wire, jump to wire. I tried a few of those when trying to solve the puzzle fairly, then assumed I had the “wrong idea” and gave up.
  4. Even knowing the full solution to this puzzle, I don’t understand how surfing skills are relevant to the wire. Sliding down a wire is nothing like surfing. And what does this has to do with the “high mountain peak” hint from the Riddler? (Are we to imagine the man used a ski lift? But if a ski lift is here, it’s hardly correct to say that he has nothing.)
  5. In the Tiger Pit, you can’t throw batrope to robin, or give batrope to robin you have to throw batrope at robin.
2 Likes