My sci-fi game Aurora is ready for beta-testing. I’ve combed it pretty thoroughly for bugs, so just enjoy (and give me copious feedback, since it’s my first game). It’s Glulx.

You can email me, but I’ll be gone this week for Thanksgiving. The latest version should be up on IFDB now or soon, though.

My main testing questions are below.

Dr Liang doesn’t contribute much to the plot. Should I take her out?
The Tell function is used far less than the Ask function; a character may respond to 30 Ask topics but only 3 Tell topics. Should I take it out?
How is the artwork? Should there be more/less/different/none of it?
Since I’m mainly a traditional-fiction author, I could use help with my IF writing style.
Better title ideas are also gratefully accepted.

So, what’s the status on this? I’ve got a couple of versions in my hard drive - I’m just waiting for the final version before I start playing.

Sorry about the initial proliferation of versions; the version on IFDB now (release 4) is the “final” one. EDIT: There were a couple of minor but really annoying bugs in that version, so I put up a version 4.1 (which is why there was no download link for the moment; should be up now/soon).

But nobody (except me and my husband) has played through very far; absolutely nobody has gotten through the dream sequence, so there could still be problems after that, which is why it’s still beta for now. I am certainly still soliciting playtesters.

(If anyone has utterly given up on the dream sequence, I can post the solution.)

That would be for the lazy, although I don’t see any download for it on the IFDB.

If the 4.1 version is the one that just went up on the archive, it seems to have gotten corrupted during upload - I get the following error:

Git Fatal Error

Can’t read the Blorb file because it seems to be corrupted.


I downloaded the file again to make sure it wasn’t a problem with my download. Same error.

…Huh. It downloads and fine for me. This is the second time someone’s reported a version of this game being corrupted, but I’ve never been able to replicate the problem. Anyone know why this is happening?

(I’m using Windows Glulxe 0.4.6, if that’s any help, but I imagine everyone is.)

What with Git, Gargoyle, Quixe and Filfre, I wouldn’t make that assumption automatically.

Incidently, I re-downloaded, just to make sure. Same error. I’m downloading from the feed of the archive. The file is 2.17Mbs. I also tried it with Windows Glulxe, and same error:


This Blorb file seems to be invalid.


It works just fine for me. (It’s a 2.2 MB file, by the way, slightly larger than your corrupted copy.) Have you tried downloading it from a different mirror of the IF Archive? How about clearing your web browser’s cache, or using a different browser to download it?

Works fine here (Gargoyle/Linux).

MD5 of the file is: 0ea8ce47e6dfc836cbb204f8efef318a
2.281.852 bytes.

If you get the same MD5 with your downloaded file, then the download is OK and something else is going on.

Strange. I re-downloaded from the IFDB link, which links to the archive. Again, a corrupted copy.

But then I downloaded through a mirror (, and NOW it works.

Just so it’s all clear and sorted out, where have you guys been downloading from? The main archive or a mirror? … ora.gblorb

I guess it might be a good idea to inform whoever runs the mirror you downloaded from that he has corrupt files.

Edit: Oops, you said you downloaded directly from the archive. I just tried to test that right now ( … ora.gblorb) and the file is fine from there too.

Then the only theory I have is that, for some reason, downloading different files all named “aurora.gblorb” from the feed of the main archive as they became available (and renaming them as I downloaded them to aurora_.gblorb, aurora__.gblorb and stuff) got my browser screwy.

Nevertheless, I now have the current version. And if it can be considered out of beta for the moment, then I’m finally going to play it. :slight_smile:

Version 401 seems to be pretty much broken, when compared to Version 4. The MD5 matches what RealNC posted above, so I assume this is a noncorrupted file.

The normal look-upon-entering-a-new-room is disabled; all you get is a > prompt. I didn’t even know I had left the first room. Most of the standard feedback messages are gone, too (“Taken”, “Opened”, etc.). “Check time” doesn’t function at all. The alarm coming from Aleksey’s cryo chamber doesn’t exist. Is anyone else seeing this?

I’ve downloaded multiple copies of 401 from the main archive and the mirrors, and played on both Mac and Windows, using both Git and Glulxe (included with Gargoyle), and I get this behavior every time.

Also – if the dream sequence is the bit with the Mist, yes, a solution would be very helpful. I made it as far as Fire, but have no idea what to do now.

Thanks very much.

Sigh…no idea how that happened; I’ve uploaded a new copy (4.2) to IFDB, so it should be up in a few days. Thanks for your patience.

I finally gave this one a go. I have very strong feelings about it, the sort I would usually express in a review - but I ended up playing very little of it, so a review would be very much out of place. However, since this thread’s been around, I might as well express my feelings here.

BTW, first things first, I did find a typo, or something. There’s something which I assume is the player’s wedding band in the jewelry box… which is only described as “your”. Always just as “your”.

I’ll hide my impressions with a “rant” tag, because although this isn’t 100% private, it’s not exactly meant for the general public either.

[rant]I really wanted to like this game, and for a while, I did. I liked it when I saw how things were developing - the slow build-up to an unknown situtation, the alarm ringing off and finding a dead crewmember, the relief of finding Gail safe - and knowing that it’d be 8 hours before she thawed. I also liked it when I saw that there was some care for details, especially on those displays next to the pods. I liked the room descriptions, sparse as they were. The writing, especially on the introduction, seemed a bit forced sometimes, but that might have been just me.

But mapping an environment which the game is the first to acknowledge as “big” in regular grid paper (using Trizbort, actually) and always having to remind myself which is fore and which is aft, which is port and which is starboard… I mean, I made a game effort, but eventually I just couldn’t stand it anymore. Please consider allowing NSEW movement.

Then I got to the crew quarters. Suddenly I was flooded with lots of information about the other crew members, when the only ones I knew so far were me, Gail and Aleksey. Which was not so bad… if, when I opened the wardrobe and the jewelry box, I wasn’t confronted with “X’s things, Y’s things, XY’s things, XYZ’s things, Z’s things and ZY’s things”. I’m afraid it’s often underestimated how overwhelming this sort of thing is for a player. Especially one who’s already having to constantly sort out directions.

Then I went into the computer room. After trying to “wear goggles”, I remembered the “about” text talking about “use”. I sighed inwardly, because I’m not too fond of that sort of thing, and proceeded to “use” the computer. Which has a cumbersome and confusing interface, to be blunt. It was the final turn-off.

This is my opinion, and you can take it for what it’s worth - namely, not much. But it was my experience with Aurora, and I thought you might be interested.[/rant]

Thanks, this is good feedback. I’ve fixed the “your” error and made “wear goggles” work.

Do you think that the cast is simply too large, or is there just too much information in the crew quarters? Dr. Liang is pretty much on the cutting room floor already; there are other possible reductions, but the other characters all have important or important-ish roles in the gameplay.

The idea with the jewelry box is that I’m playing with indirect characterization: How can we find out what these people are like when they’re all asleep? We get some dry statistics from the cryo displays, but you find out more about them from things like what files they have on the computer or what their avatar looks like. Anyway, that’s the intent; whether it works or not is up to the player.

What I can definitely do is to rename the jewelry so it doesn’t say whose it is (unless it’s yours); that way you can still get the explanation if you examine it, but won’t get immediately hit with all those names. Or I could just remove it entirely if it’s just not working.

Another way to reduce the amount of information in the crew quarters would be to have different characters give different descriptions of the stuff there; so maybe all Jake will say about the game board is that he doesn’t know how to play.

I think I gave you the impression that I think there’s too much stuff in the game. That wasn’t my intention. Let me try again: I feel that I was overwhelmed by the following, happening all at once:

1 - No compass movement on a large environment (this was the biggest “offender”)
2 - Suddenly finding myself on a location (Crew Quarters) where I found mention of a lot of people, and their little characteristics that make them human. Understand that there were a lot of things to be examined in that room and that I didn’t examine them because I didn’t want to be bombarded with the little characteristics of people I had no idea existed yet.
3 - In a room, finding a description with lots of objects, and then a white line, and then “You can see a wardrobe” (surely you can find some better formatting). Then opening the wardrobe and seeing a box. Then opening a box and being bombarded with all those names, diferentiating small things in the box. Then, whenever I "look"ed, I would see “You can see a wardrobe (in which is a jewelry box (in which is X’s things, Y’s things, XY’s things, etc))” in the description.
4 - Having to navigate an unwieldy computer interface in the IF prompt.

Of these:

1 - I think you should really consider allowing NSEW movement. Maybe make it toggleable. Maybe optional. Maybe integrate it somewhere, I don’t know. But it’s a huge drain on my mind, when I’d rather be focusing on the game, story and characters.

2 - You don’t have to change this, of course. It’s the crew’s quarters - it’s the best place to do exactly that. Maybe if I’d gone south instead of north when I started the game, I’d have seen the other cryo pods, and checked them out, and got little background information. In fact, if it weren’t for the non-compass movement, I’m sure I would have explored a bit more.

3 - Formatting needs a bit more work. As it is, the wardrobe stands out in such a way that it feels like it’s the only object you implemented. Considering it’s competing with a lot of scenery you can interact with (even if it is just examining), that’s unfortunate. And getting all those jewelry descriptions on the “look” description is also overwhelming. This is all just formatting. Maybe if these little things were taken care of, I wouldn’t mind all that jewelry so much, although my reaction might have remained the same: “Oh damn. Now I have to examine all of these.” I would suggest spreading them out a bit more, not having all that in a single location… but that’s only my suggestion, and of all of the suggestions I’m giving it’s the least important.

4 - It’s sometimes unclear how to use computers. For instance, it was a while before I realised that I could interact with the displays next to the cryo pods, looking up information in them. And it was still a while after THAT that I realised I could initiate procedures. Now, after all that, I’m already a bit thrown and not as receptive as I was when I first started the game. Then you throw at me a computer in which you bunch together lots of files, in a way that makes them as confusing as the jewelry box, and I don’t even know whether I should “click” the files’ name, “touch” them… “reading” the unlocked file in the computer gave me the same response as “examining” it, which was, in fact, the last straw before I stopped playing. I also think I had some difficulty accessing the “Shared” folder, but maybe that was just because I didn’t know the verb. There are many ways to walk around this problem, and I would suggest two - but there are more, naturally.

a) Seriously consider using menus for the computer interface.

b) If you want to make a VR environment, consider making it more VR. If you want the player to use the IF prompt and this feel as though he’s in an alternate reality, then have him walk around. One room for documents, for instance, another room for whatever.

The thing is, at the moment you have a strange mixture of “VR” and “desktop”. It doesn’t really work.

Other than that, you can go wild, if you like, with, say, graphical representations and use of mouse… Glulx certainly allows that. There are many ways around this one.

To wrap it up, I don’t think there’s too much stuff in the game, and I’m not sure I’d like you to remove details and characterization. I just suggest you rethink some things, especially the formatting. I wasn’t overwhelmed by the quantity of information, I was overwhelmed by it coming at me all at once. Formatting is an unsung hero.

EDIT - I had a thought, which you may or may not agree with, but here goes - if you want to encourage a playing stile where “use” is more important than the other verbs, why not consider adding a keyword system? Doesn’t have to be entirely keyword-based, but if you want to empashize that objects can be “examined” or “used” and little else, a keyword system is your friend. For starters, it clearly guides the player towards the right frame of mind. Otherwise - trust me on this - most IF players will start “wearing” the goggles you meant for them to “use”, for instance.

Any chance that you can provide a solution to the dream sequence? Thanks.

I’m actually going to post version 5 in a little bit, and it doesn’t have the third dream puzzle. It’s the worst puzzle ever and I hate it with a passion. (But the flow of the dream sequence feels wrong without it, so there you have it.)

It will also have optional compass directions and generally be cleaner and nicer looking (and, alas, poor Dr Liang is gone).

You know, I don’t even know what puzzle you’re talking about, but I’m already sorry that you have to sacrifice the flow of a sequence because of a puzzle. Before scratching the puzzle, did you try hinting often and heavily? If you don’t like a puzzle but feel it’s good for the flow of the thing, you can always dampen its effect as a puzzle by clueing and clueing, even if it looks like the puzzle is solving itself. It’s a compromise.

As for the rest, glad to hear that compass movement is coming in. :slight_smile: And glad to know that the game is generally nicer. I’m generally waiting for it so I can generally sink my teeth into it.