Arclight_Dynamo's IFComp 2019 Reviews

The House on Sycamore Lane by Paul Michael Winters

I found this to be a fairly solid but fairly uninteresting game, with a number of implementation issues that really soured me on it.

“Solid” because it’s a good setup: you’re trapped in a house that happens to be haunted, and you need to get out. Along the way, you need to deal with the hauntings to do so. Fine and good for a starting concept, strong setting, and a house always makes for a logical map.

“Uninteresting” because, after setting up a sturdy, but honestly bog-standard, setting and concept, the game doesn’t really do anything interesting with it. It doesn’t seem to be trying to say anything, the story is extremely straightforward (and the “deal with the hauntings” element isn’t well-integrated with the “escape” element), and the puzzles are very much “find object, rub object on other object.”

Unfortunately, the thing that really struck me were the implementation problems. I spent the first ten minutes of the game trying to guess the verb to open the bike lock. I had the code. I knew what to do. But I had to try action after action until it worked. There was more guess-the-verb with the telescope eyepiece and with burning the totems (i.e. “burn X” doesn’t work, but “put X into fire” does).

There were also a number of description errors (e.g. “In the cask of wine are some wine”) and misleading descriptions (e.g. the crib still having the description of the colouring book in it after you have taken the book, or Suzie still having the original description despite having been cut apart).

To conclude, I didn’t hate this game. I even enjoyed playing it, despite its problems. I just wish that it had done something interesting with its premise, and I really wish that it were implemented better. To be entirely honest, the guess-the-verb and description problems were so bad, they knocked a full point off of the score I gave the game.

1 Like

Very Vile Fairy File by Billy Boling

Hooo-lee wow! I love this game. I love that the gameplay centres on wordplay, I love the writing, I love how well-implemented it is. This game, I love. It is utterly delightful, and I would be shocked if it doesn’t do well in this year’s comp.

I should point up right at the start that I’ve not yet finished the game. I rated it and am now writing this review at the two-hour mark. But, boy, am I ever going to go back and finish it.

This game takes a very simple concept (Make puns!) that is very hard to implement, and puts it right at the centre of its gameplay. Essentially the way it works is, if there’s a DOG in your way, you type FOG and the troublesome beast evaporates and you can continue along your merry way.

It’s very reminiscent of the machine that lops the last letter off of a word, so that putting a rabbit into it gets you a rabbi out the other end (I can’t remember if that’s a game or Discworld, but it’s brilliant).

This is not an easy thing to do or to build a game around. At first, I thought that the structure was going to be “You enter a room. You solve the pun. You go to another room” with no ability to walk around the map. That was a bit disappointing, but understandable; it’s hard to do this, and doing it in an open world is harder. I had already fallen in love by that point anyway.

Then the map opened up.

What I thought was the game was a tutorial to teach me how to solve the puzzles, before getting to the meat of the game. Needless to say, that the author did the hard thing was deeply appreciated, and resulted in the game I was wishing for.

This is especially difficult to pull off since the author seems to speak a different dialect of English from me, where pronunciations are not the same (for example, in my Canadian English dialect, “meet mourner” does not rhyme with “leet learner” - it ryhmes with “meet morn-er”)… but the game still works.

The implementation is also butter smooth. The automated hint system is not intrusive and is actively helpful, even when not seeking hints; it drops useful and welcome information organically as you play. The descriptions in the game - even descriptions of failed guesses, which I think is especially smart - point you toward the correct solutions so that you’re not just guessing random words.

The THINK command is also quite welcome (Remembering correct answers that I can’t use yet, but will later? Very friendly, thank you) as is the game prompting me when a remembered song would be useful.

There’s also a level of polish here that I appreciate. There are so many responses to incorrect rhymes included that it never feels like I’m just trying to guess the right answer. All of those rhymes are valid, if incorrect, and a lot of them point to the right solution. More than that, though, some of these “incorrect” responses will earn the player optional bonus points, which I think is a nice way to encourage the player to explore language and the gamespace.

Honestly, this game is just good. It had me laugh out loud at puns a few times, and I appreciate that the author is clearly a deep nerd (Filking? Yes, please. An answer literally being “GET GOOD”? You’re talking my language), and that, plus the wordplay, brought Spider Robinson to mind, which is never a bad thing.

Now, a few possible bugs for the author to look at:

  • I believe one entry in the notes is backwards. “GET GOOD to WET WOOD” should be reversed to “WET WOOD to GET GOOD”
  • Listening to the music in the Mystery Mall returns “and that’s not all bad, because what replaced it is even worse.” I think it wants to be “and that’s not all bad, because what it replaced is even worse.”
  • At LAKE LAP, “x snake” results in “The HA HALF button lights up on your Leet Learner.” “LL snake” and simply “snake” do as well. I suspect that’s not intended, but I see why it’s like that.
  • I “Make Map” at Lake Lap, but there is no map anywhere. Again, that might not be unintended - not finished the game yet.
  • After figuring out the YORE YONDER puzzle in the History Hall, it tells me I can go IN. But I cannot; I can go OUT. The description is incorrect.
  • When guessing rhymes, HOLD HARD returns “You already have that.” I have the hard hat. This makes sense but is confusing.
  • “WORK WELL” always prompts the “putting the gel in the tube” response. I don’t know if this is intended after the puzzle is solved.
  • “WHOA WHAPPIN” and “WOAH WHAPPIN” should return the same thing, but do not. At least in my opinion. I’ve seen woah/whoa spelled both ways.


Another thing that is definitely a bug:

After getting the Here Hip Queer Quip, I am listed as having the backed binder in my inventory. I did not yet have it. I can still obtain it from the Paper Pile later, but the inventory description is incorrect.

Edit 2:

And another:

When I use the Leet Learner on the Gear Gull, I am told there’s no such object there.

Edit 3:

And another:

The text for Loft Land reads “You can go all four directions here, and west is the Gear Gull, who could help with your gold guard.”

The gull is actually to the EAST not the WEST.


Winter Break at Hogwarts by Brian Davies

I’m afraid I didn’t care for this game at all.

It was solidly built and the descriptions were well-written. Those are plusses. The problem is that this game is sprawling and nearly empty of content.

Now, I’m not the biggest fan of huge dungeons to map in the first place, but I can be brought around. Start me in a small area and unlock other portions of the map and put interesting things in the map. This game doesn’t do those things. I spent the entire two hours mapping things, and didn’t even get the entire castle mapped. I found the first puzzle 52 minutes after starting the game. A lot of the rooms are literally devoid of anything at all; they just serve to make the map bigger, or to make the representation of Hogwarts more accurate. They also make the game worse, I’m sorry to say.

Other things, in combination with the need to map out a huge world, also make the game less fun. A hunger mechanic wasn’t my favourite, and the Grand Staircase was just frustrating. I get it’s a thing from the books and films, but it made for a bad experience.

There are also certain implementation issues that were irritating (e.g. the description for the Long Gallery North End saying there were stairs down, but with no actual exit down; or the exit from the Training Grounds to the Main Grounds not being mentioned in the description at all) and certain map design features (exit north out of one room, and end up entering from the east into another) that compounded the mapping woes.

Now, here’s the really irksome thing. A lot of this could have been avoided had I not downloaded the game to play in an interpreter, which is my preference. If you play the game online, there’s a map included. If you download it, though, there’s no map. I wish there had been an indication anywhere saying “Hey, play this online or load up the .html file. Don’t run it in an interpreter.”

Even with a map, though, the castle is still sprawling and very empty.

So, no, I can’t say I enjoyed the game, or that I would have enjoyed it had I had a map. That said, overall, it is a well-implemented game with good writing. I hope that the author continues to submit games to comps - though perhaps ones smaller in scope.

Edit: I hate how harsh this review sounds. The game itself really is put together well. Had it taken place on a map 1/3 the size, there might have been something solid, there.

The Untold Story by Michael Pavano

(Before the review, note that this game has been uploaded to the IFComp website incorrectly. This has not been corrected as of my writing this. There are ways to obtain the game, and StJohnLimbo has provided a working version of the game file here: Cannot Download "The Untold Story" )

I liked this game! It’s not without its flaws, but I liked it.

It’s a nice, light puzzler with clear goals that can be achieved in non-linear order. It even touches on some deep themes (pacifism or violence) and, I think allows you to solve puzzles with either a peaceful or violent option. Juxtaposing a warrior brother with a religious brother (I have a few quibbles there, but I get the point), and allowing the player to define themselves by their actions, worked pretty well for me.

That said, it is kind of a light game. I wish there had been more to both the puzzles and to the story. The writing gets the job done, but isn’t spectacular; too many adjectives, too much tell over show. And there are some issues with polish - its/it’s and they’re/there/their confusion, inconsistent descriptions (after removing an item, the description still implies it is there), item confusion (examining the flowers in the meadow, for example, does not work properly if you are holding the special flower from the tree), and odd results of actions (trying to place a chess piece on the chess board results in being told that, no, I should only put chess pieces there).

All that said, this was an enjoyable time. I had fun with it. I just hope the author is able to correct the problem with the upload, so that others can easily play the game.

1 Like