Anssi's IFComp 2020 Reviews


The blurb of the game leaves the reader a bit baffled, of course intentionally. But with sentences in it like “Clouds out here were apparently one of the thirty million newly unemployed”, what actually is going on? Ok, reading the blurb further, the game seems to be about a missing woman, and I am playing as a private detective. But why the stutter? Well, let’s start playing the game and finding out what this is all about. The player’s curiosity has been successfully raised.

The starting location, a petting zoo, might not be the most typical one for a private detective to meet with his client, adding to the mysterious flavour at this point. The style of the narrative, from the start, shows the detective as hard-boiled, someone who knows what he is doing, in the style of numerous ‘noir’ type mystery stories. Rather soon, however, we learn the true state of affairs - the main character is still rather young and inexperienced, doesn’t have an official detective’s licence, and lives/is forced to live in some kind of storage pod, sleeping in a sleeping bag. In a funny reference back to the blurb, he doesn’t possess any of the high-tech equipment that is advertised in the blurb, and solving anything is indeed not any walk in the park for him. To underline his greenness and uncertainty about himself, he stutters when he speaks. To use a computer and make a simple Google search, he has to go to the library, for example. So, what initially felt like a hard-boiled noir story quickly acquires a funny undertone. Anyway, he has managed to attract a client and takes on a quest of finding a missing woman. This quest has many funny and surprising turns, even some fantasy elements thrown in. It all takes just about two hours, so length-wise this game is just right. The story is interesting and moves along in a good pace. Besides the narrative, some location names are funny, as well (“Jay Schilling in a taxi” being one example). The parser is very understanding and picks up readily the player’s suggestions and experiments with various objects. There is a helpful hint system available. A nice feature were the images thrown in, for example when examining yourself, and at some other points. There were maybe only a few cases where the player had to really think about how a puzzle would be solved (for example in Winstone’s first house); in relatively many cases, the player was nudged forward by the NPCs, or there were direct suggestions by the game “You could ask about (some object or incident), or try small talk”, or something to that extent. This was actually helpful, as it showed what the parser would be able to understand, and what things were essential to talk about. If I observed correctly, the main character’s stutter seemed to disappear towards the end, maybe signalling that he had gained self-confidence cracking the case at hand (but I don’t know if this was the authors’ intention or not).

Because of the fantasy element in the plot, the story was something that was not even meant to be 100% “real-world” plausible, but it was fun and kept the player entertained. In general, the games this year (at least so far) seem to have a high degree of polish, and this one is no exception.All in all, a fun and polished story that turned out different from what it first seemed. It’s a strong 9.



The premise itself sounds fun here (you are going to explore the empty house of a neighbor who has passed away and loot it of anything valuable before the city comes and takes away everything.) This game, however, is too underimplemented to enjoy much. The first problem is with directions in the front yard (it says the backyard is to the northwest, but it is actually to the northeast). ‘x me’ yields the default message, your sidekick hardly ever says anything when you try to ask her something. (“There is no reply.” happens as a rule.) “About”, “help” or “credits” are not recognized commands. You manage to get into the house, and explore around, but there are no clues as to what you should be doing there to progress in the game. After you have explored all the rooms, and nothing much has happened, you can’t do much else than look at the walkthrough. And looking at it, you realize that you wouldn’t have come up with the needed things to do in a million years by yourself. For example, you are supposed to push a piece of furniture from the basement up to the second floor , and this was not hinted at in any way whatsoever in the game. Another thing in the walkthrough: “Search the dresser until you find a silver key, which will automatically be taken.” I searched, and no silver key turned up. It was clear very soon that it was no use going on playing this, so I quit. For the problems in the implementation, and for the lack of guidance as to what to do within the game, this game unfortunately doesn’t deserve more than: 3.



This adventure starts pleasantly enough. An old man, presumably a wizard, visits the hero of the story in the middle of the night, and after this visit the hero is not sure if he was awake or dreaming. But when he wakes up in the morning, he is in different surroundings from his usual one. He has been transported to a magical kingdom. When the wizard appeared to him earlier, he asked him to save the kingdom from an evil queen, so that is obviously the quest he must embark on. The wizard we encountered in the beginning helps us along the way. Playing was often not that smooth: there were some places where the walkthrough had to be consulted because of guess-the-verb issues (for example only ‘remove’ is accepted as a solution in one puzzle; ‘take’ does not work). Sometimes, even the walkthrough does not work properly. For example in the forest we hear voices coming from the east, and the solution, according to the walkthrough, is to listen - fair and simple enough. But listening at that location does not bring the game forward, we have to go round to the south of the said location, where no voices are described as being heard, and then listening there triggers the plot forward. There was no clear reason for this. There was also an incongruity with the magic rope: you build a raft using the rope, but suddenly you again have the rope later, when it is needed in another puzzle, even if it was not in your inventory in the meantime . There were some language-related puzzles which were not readily intuitional: for example, you have to repair a clock by inserting a sprig of thyme in it. Why? Oh, “time” sounds a bit like “thyme” . There were also some linguistic errors here and there, mainly with the 3rd person -s appearing or not appearing in the wrong places. I stopped playing when I had been caught in a prison cell (with math books), and even if managing to find an escape tunnel, I came to a dead end and could not proceed, and the walkthrough didn’t offer any help here, either (!) . For some reason, going “in” in the prison cell is possible, and when looking , the room description is “nothing special”. You have to come out again to be back in the cell. Going up in the prison cell, I’m suddenly “Inside the snake” (!) which was not at all referred to previously, and going down again I am back at the prison cell. This snake is not also referred to in the walkthrough at all, as far as I can understand, it seemed like a leftover code that was not intended to be in the final game. The puzzles in the game were mostly fair, and the story charming enough, but due to the various rough spots, guess-the-verb issues and incongruities, the gameplay was not as ideal as it could have been. 6

1 Like


You’re playing a magician’s assistant and your task in the game is to find him after he is captured by a rival/enemy. You go around the mansion where the magician and you live together (in separate bedrooms; it is merely a professional relationship), solving puzzles to bring you closer to finding your boss. The mansion is rather big - it even has an observatory on the roof, and three floors, and hired staff that you can interact with. There is even a robot servant! The puzzles are quite inventive and original - many of them deal with the magician’s stage equipment which, unexpectedly, behaves like they are real magical objects, not just props - you can for example pull a rabbit from a top hat, endlessly. There were some problems with the implementation - some spelling errors, some verbs or commands that you expected to work didn’t, some room descriptions had the description of an adjacent room after them, etc. Anyway, none of this disturbed the gameplay too much. This game took almost the full two hours to play, so it was considerably longer than the one-hour estimate mentioned in the blurb. It was a fun experience, a good-mood story that you felt happy after having played through, and, yes, I really was positively impressed with the puzzles. Even if some words like “pharoah” were misspelled, I cannot fault a game too much that anyway contains the excellently funny term “sphinxling”. Enjoyable, entertaining. 8


Thanks for playing my game! Glad you enjoyed it :slight_smile:



In a short sequel to “Alias ‘The Magpie’”, we play again as the notorious master thief, this time trying to snatch a ruby from a millionaire while we are in the same train car with her. There are several people in the carriage that we can interact with, and a central element we can avail of is the suitcase that contains various outfits. The repeated plot device of the train plunging into a tunnel every now and then also helps us in attaining our goal. This game is a perfect example of how the player, through trial and error, and through experimenting with the various possibilities that the setting offers, learns more and more about the environment and finally arrives at the goal. Even if this is just one scene, taking place basically in one location only, it is enough of a game due to the careful implementation and the multitude of things you can try. The humor is good - for example the ways in which the Magpie, in the different outfits, compliments the millionaire, cracked me up. The conversation system is original and simple to use. There is a good hint system which I had to use twice, and never until the explicit answer. I caught only one small problem with the verb “show”: ‘show (object) to (person)’ yields “The object pays no heed to the person.” (rather than the other way around). That is just nitpicking, though. All in all, this piece of IF, as to its pacing, humor, and level of implementation, is quite a jewel in itself. 10



In this game you have arrived at your girlfriend’s apartment to meet her, but she is not there. She is an archaeologist, on a mission somewhere, and seems like she is in trouble. This game was programmed with a custom system, and while that is something that the author has to be complimented for - there are some nice features like pop-up windows showing images of examined objects, for using a cell phone in-game, messages about what is happening with your girlfriend elsewhere, etc., - but anyway the parser is not often up to par with those of established IF systems. Some common verbs are not understood, and some verbs seem to work with certain objects but not with others. There were some spelling errors here and there, too - even as noticeable as “enviromet”. Anyway, I liked the humor of some of the messages. For example, trying to go in a direction not listed for a room, you might get “Anssi, someone put a wall there.” (The game asked you to enter your name in the beginning of the story.), and others. There was also a built-in help system. One drawback was that there was a time limit to solving the game, and I couldn’t make it on time. So, the game ended before I managed to reach the end, and as I hadn’t saved (I didn’t see any warnings about there being a timer), I didn’t bother playing again from the beginning, as I had already played for quite a while. There was a certain horror element present in the game and it was effectively used, so it was a pity that the game decided that enough time was already used. The time limit seemed a bit unnecessary, particularly as there were not sufficient warnings about it - why not just let the player reach the end? Because, to use the time optimally, it might not be enough with a saved game, but you have to start and play optimally from the start. 6 1/2.



The background to the story is already explained in the blurb of the game, so you can start playing without necessarily reading the introduction - quite handy. Knowledge of the background story is not needed during the gameplay anyway; it is there mainly to connect this game to the universe of some earlier games by the same author, making this one a sort of sequel (the blurb mentions an earlier game in the series, “The Spectre of Castle Coris”). You start at the mouth of the tunnel you are supposed to explore, and once you are in, you have to solve a series of puzzles to proceed, and that is basically what this game is about. From the very start, you have to pay close attention to everything around you, or you might miss some crucial objects needed to proceed. You will probably get stuck very early on, and have to resort to the walkthrough. I had to quickly resort to playing with the walkthrough open on the screen simultaneously, which was not a good sign. There were some things you wouldn’t come to think of doing by yourself at all - for example, at one point you encounter something in the tunnel, and you have to both move and search it to discover a couple of objects. You are supposed to throw an object into a shaft, and this was not hinted at in any way, etc. So, in effect, the solutions to the puzzles were such guesswork that most of the progress was just thanks to typing what the walkthrough instructed. After some time of playing like this, I was attacked and died, and didn’t bother to play forward. Shame, as there obviously was a lot more to the game.The puzzles are inventive enough in themselves, but they were not sufficiently clued, and there were also many guess-the-verb issues, and I just didn’t want to bother trying to read the author’s mind as to what the next move should be. 6

1 Like

First of all THANK YOU for the time you dedicated to Radicofani.
The choice to create a timed game was made for consistency with the plot.
The plot tells about a space-time gap which by its very nature has a …time ;-))
Radicofani must be resolved in 400 cycles but this value can easily be increased.
It would be very important for me to know which verbs you used that were not understood by the parser and which verbs only worked on some objects and not on others.
The game dictionary can be easily enriched.
In this way I could make Radicofani a better game.
For some mysterious reason no player who has tested the game has ever saved at least once. (WHY?)
In future versions I will insert automatic saves in some critical points of the game.
I apologize for the grammatical errors.
I am not a native english speaker and I have not had time to have the text revised but I will do it in the next versions.
Someone complained about the lack of the UNDO function.
The fact is that, as I said, I tried to recreate the style of the 80’s adventures and in those hard times certain “comforts” did not exist.
Latest curiosities:

  • Where were you when the gate closed?
    It would be useful to know It in order to optimize the time limit.
  • In one location of the apartment I “hid” a little secret.
    Did you find it?
    Maybe I should make it easier to see in the next versions.
    Thanks again for your valuable comments.

Hello Rob and thanks for your response! First of all, I did enjoy the story as far as I was able to play it, and I appreciate that you had implemented it using a custom system of your own. I had managed to proceed until the library/church area when I ran out of time (I was not able to get out of the church). I didn’t manage to find the little secret hidden in the apartment :-). Even if this is a horror-themed game, I appreciated the humor thrown in here and there. Here, per your request, I list some things that I found problematic:
1 - in the beginning there is a strange noise in the apartment, but “listen” does not work. Ok, “listen to noise” works, but “listen to” does not work with any other objects (“Listen to tv”, or some other things, yields "Er… in what sense?"or “I just didn’t get this.”)
2 - “open” works but “close” doesn’t (“Er… in what sense?”) , at least with the dishwasher
3 - The description of the studio doesn’t mention the objects that are in the room. I only became aware of their existence through the “help” command.
4 - “search” is another verb that only works with some objects, for example you can search the frippery in the bathroom, but searching the clothes in the bedroom results in “I can’t follow you…”
5 - In the corridor “You can see a voice mail.” (can you actually see a voice mail?) (And to examine it, you have to type “x voice mail” in full, “x mail” is not enough.)
6 - Having exited the apartment, I am described as driving out of town, then, next, “You are in the parking.” (better : “parking lot”), I tried “get out of car”, “out” and “exit” but turned out I was no longer in the car anyway, maybe this could be made clearer
7 - I see a saucer, and trying to take it, the response is “It doesn’t seem the case.” Why can’t I take it?
8 - In some of the pop-up windows, the font (that aims to resemble handwriting) is a bit difficult to read, maybe that could be tweaked a bit?
9 - in the hostel reception, the customer register on the desk becomes visible only after examining the chair
Here were some things I noticed, I hope these comments were helpful :-).


Thank you for your review of Return To Castle Coris. You tell players that they “can start playing without without necessarily reading the introduction”. Does this extend to not reading the playing instructions as well, which I advise players to do? You say there were “many guess the verb issues”. Did you use the VOCAB command which is available? I would be very interested to know which “verbs you had to guess”?

1 Like

( @Lazzah - I replied through a private message.)

Your comments are more than helpful.
They are precious!
Any issues you have reported to me will be fixed in the future version of the game.
Regarding the premature end of your gaming session…
The aggression of the demon in church is controlled by a variable that has nothing to do with the primary time variable.
After passing this point you still have plenty of time to reach the fortress.
If you ever want to play again, take a look at the walkthrough.
You will thus be able to see the Radicofani tower.
Thanks again.
Ps: if you go back to the apartment have a shower! :wink:

1 Like

Thanks, I will :smile:.

And knowing now that there will be more time to use, I will try to play further in the game!

1 Like

Thanks a lot. I wish you the best.



The title is not immediately clear as to its meaning - is it some kind of less common English expression that I, as a non-native speaker, am not familiar with, something in the manner of “a murder of crows”, or the like? Googling that phrase, this very game comes at the top, and there are only some other occurrences of that phrase. Anyway - let’s go on! The blurb says that this game contains “an account of the disastrous sidewalk chalk tournament of August 27, 2011”. This is an excellent blurb, because it raises many thoughts and questions - 1) a sidewalk chalk tournament - wow, what an original idea. But how will that be handled in a text game? 2) why was this tournament disastrous? How can be such a tournament be disastrous in the first place? 3) it doesn’t mention any location - why? 4) Why is there an account of this incident only now, after 9 years? Is the incident something that can be safely tackled only now, after a sufficient amount of time has passed?

The introductory “disclaimer” at the beginning of the game further raises the player’s curiosity. Its serious style sounds ominous as to what is to come, the more so as answering “no” to the question after it, about freeing the narrator of all responsibility as to the accuracy of the facts, etc., results in the game session ending on the spot. On the other hand, the player partly expects that what follows will be hilariously trivial after the grave style of the opening.

What follows is a very well-told, multi-layered story of what happened on the said day, and not only that but also about what happened previously and what led to the present state of affairs. It starts innocently enough - you are one of the judges in the competition, your task in the beginning is to clarify one contestant’s complaint regarding a fellow contestant, and you leave your desk to walk up to that contestant. Soon after that, strange things start to happen, and at times you are a bit at a loss as to what exactly is going on. These are deliberate story gimmicks, and everything comes nicely around in the end, Humor and more serious themes are entwined successfully throughout, and this game is a beautiful example of how a story can be told using parser IF. Just about everything about how this game has been implemented is perfect - the story-telling technique, the pacing, how the player is held in suspense and how everything is gradually revealed. There were no bugs or problems that I managed to encounter, and the parser is very understanding and flexible. I find it hard to fault this game for anything - so it’s a 10.



Refreshing - a pure word game for a change! It is actually divided in two parts - in the first part of the game you are supposed to collect keywords by solving various kinds of word puzzles. There is a story behind all of this, but it’s very brief- after you have collected a sufficient amount of keywords, you can embark on fighting a monster with your arsenal of words. The problem, of course, is to collect enough words to fight the monster successfully. The first few puzzles are easy enough, but I started having problems with the fifth one already. Fortunately, solving a word puzzle unlocks at least a couple of new ones, so you can skip a difficult one and come back to it later. After I had collected around 20 keywords, I decided I would try to encounter the monster (this option had become available a lot earlier in the game already). I was defeated, and the game instructed it would be good to have at least 30 keywords before this final fight. The problem was, I really couldn’t crack any more of the word puzzles. There was a walkthrough available, and I looked up a couple of solutions from there, but as the walkthrough only mentioned the direct answers for each puzzle, and not through what logic they were arrived at, it was not fruitful to play on. The game could have had a built-in hint system for the various puzzles, or the walkthrough could have explained the solutions. Now, even after I saw the solution, I couldn’t understand why it was the correct word. For example, one puzzle involved an artist asking me to name colors to add to her palette. Then, I named various colors, one by one, and she accepted them, but none was the ultimate keyword she was after. I checked the solution in the walkthrough, and the correct word was ‘easel’. I couldn’t figure out why, in a long time. Then I came to think of the word ‘hazel’, but it is not pronounced exactly the same, so I am still not sure, if that was the reasoning for the solution or not.. That I was not able to gather 30 words to enter the endgame successfully is not the game’s fault; I probably could have figured out a few more if I had designated more time to the puzzles. So, I like the premise of the game, and my shortcomings of finding enough words to end the game successfully don’t disturb me too much. Even if I didn’t see the successful outcome of the game, I appreciate the idea and the design. The only complaint I have is the aforementioned lack of hints, or nudges forward, or even explanations of the right solutions. 8


A lot of the puzzles (including the color one) have you give a lot of examples and after you’ve done enough, they give you further hints. So ‘easel’ is only hinted after you say enough color names.


Oh ok, thanks for the advice! I thought I had already said nine or ten colors and I didn’t see it was going anywhere. With this knowledge, I will try it out again, together with some other puzzles. :+1:


I’m a native English speaker, and I’m not sure of its meaning, either. Here’s my best guess:

Rope ties things together. So maybe the “rope of chalk” refers to how the sidewalk chalk tournament, despite all of the point of view changes, ties the various parts of the story together. It is the common feature to all of them, after all. Again, just a guess.