Amanda Plays ParserComp

The past 2 years I submitted games to ParserComp, and this year I didn’t, so I am free to play games without my usual high level of anxiety interfering. I don’t know if I’ll get to them all, but I’ll try them in the order Itch lists them for me.

I’ll try not to spoilerize too much.

The very first one was Moon-house Technician by @Outgrabe, and it required me to download some kind of new interpreter, which I generally don’t do. So with apologies to the author, I’m going to put this on the back burner and think about getting back to it later. I just have an aversion to installing a bunch of different interpreter-thingies just to play one game with them, and in no way, shape, or form should the author take this personally.

So the first game I played was Alphabet City by @Jgesq, which says it is the “Parser Edition.” I see from the author’s Itch page that they have lots of “Alphabet City” games, which appear to be choice games although in a format I don’t recognize. The author says they’re new to Inform, and I sympathize with the intense wrangling it takes to make a working parser game in Inform.

That said, this game could have used several rounds of play testing, as it’s a bit of a mess. Things not implemented, obvious synonyms not implemented, being able to take things that you should not be able to take, the game telling you to do things you can’t do, etc. All very standard new parser author problems (I have committed all these booboos and more). But play testers would have found these problems and allowed the author to smooth them out. As it is it’s difficult to play.

The story is that your girlfriend has disappeared into addiction and the seamy underworld of the city, and you have to rescue her, even though you’re in a somewhat fragile state yourself with a month of sobriety under your belt. You have to rescue her before you hit 100 points, which provides some urgency to the gameplay, although I’m not entirely sure why that rule is there. And getting/losing points feels kind of arbitrary; for instance, eating one thing giveth points, and eating another thing taketh points away. There’s also at least one un-signposted instadeath.

The good news is that the sense of place and of addiction and alarm feels very real, and there’s a gritty feel to this world which is very appropriate. I didn’t finish it because although I found Jayne, I couldn’t figure out anything to do with her. There are a lot of objects and places and people, but very few of them yield any useful information, and fighting with the parser got tiring, so I called it quits.

This could be a great game with some serious testing and editing, and I really hope the author takes it to the next level, as I would like to play a streamlined version of this. Ask for testers here and you’ll get them! You can also PM me directly and I’ll send you a transcript of my play. Don’t be discouraged by this review! Making a parser game is really, really hard. Getting help is a snap here, though.

Also, there are no content warnings on this game, and it needs them: substance abuse, addiction, implied threat of abuse and overdose (which might turn actual although I did not find out).

22 Likes

Next up: Race Against Time by @Finn_Rosenlov

A zippy sci-fi story instantly rockets you off to an international research station which has been decimated by a killer virus. Your mission is to destroy the station, save Earth, and not die in the process. Moody and somber descriptions of the space station filled with bodies set the tone nicely, and you’re off to be a hero.

I struggled mightily with the parser in this Adrift game, too. Multiple disambiguation problems made me type things like UNLOCK EASTERN DOOR WITH GREEN FOB, which is just too much. Also, this is a game which follows the old-school philosophy of needing to SEARCH everything after examining it. There’s also a fair bit of MOVING things, some of which were very read-the-author’s-mind kind of actions. Fans of the traditional parser mode will be fine here, but I feel like I did my time on the front lines of long commands like ASK LADY MERRIWETHER ABOUT THE PUFFY POMERANIAN PUPPY back in the nineties, and I like a sleeker approach these days.

So after half an hour of struggling I went to the walkthrough, only to be stymied by a command that doesn’t work in the game: X SPACE.

So I didn’t finish this game either, although I wanted to. This was a far smoother experience than the previous game, but it also suffered from a lack of testing and editing. CREDITS and ABOUT didn’t yield any response, so I can’t tell how many testers it had, but it needed more. This, too, could be a great game if it was more user-friendly.

Which brings me to my first PSA of the comp: Get testers. Fix problems. Get more testers. Fix problems. Do this until the game is smooth. There will always be a comp coming soon, so nobody should feel pressure to meet a particular deadline. My games are always a huge awful mess before multiple rounds of testing, and it’s awful embarrassing grunt work to clean them up and keep cleaning them, but if you want people to be able to play your games, this is the only way to be sure they can.

15 Likes

Next up: The English Restaurant by @ericzinda

This is a Perplexity game, and I know I’ve played one before and had trouble with the engine before. And to continue my streak of fails, I failed to get very far in this game. The goal is (and I am not giving away anything that isn’t in the first sentence of the game) to order a vegetarian meal for your son. Except the game does not recognize VEGETARIAN, VEGETABLE, VEGETABLES, NOT MEAT, or any of the many other things I tried.

The stated purpose of the game-- to help people practice English skills-- is laudable. But English is my native language and I could not progress after getting a menu.

I’m acutely aware of the possibility here that all these failures could very well be me-- after all, it’s either everybody else or it’s you that’s the problem, and which is more likely? I’d like to see this game through, so if someone could help me with the correct wording I’d be grateful. Or perhaps this is the point? That it’s tough to be understood when you don’t speak the language?

10 Likes

I also found English Restaurant confusing… I was able to order something for the son (I tried “soup” purely at random, and it just happened to work), but the game didn’t end after that—the waiter just kept asking for my order… Not sure if that means I didn’t order correctly, or if there just isn’t an actual ending. But here’s my transcript in case it’s helpful!

english_script.txt (4.6 KB)

Edit: Played around a little more, and the command “what are the specials” got me the response “Ah, I forgot to tell you about our specials. Today we have tomato soup, green salad, and smoked pork.”

7 Likes

Next up: Project Postmortem by @Gamefic

I FINISHED A GAME! Whew. I was starting to wonder if I had a ministroke today. This is a very short, direct, simple, one-puzzle game with a little map. It’s so short that I won’t say anything about the story, but I enjoyed my time with it.

I did run into a few problems: typing anything before logging out of a computer yields this error:

An error occurred in the game driver: Scene named `` does not exist

Stack:

And then you have to close the game window and restart it (although it does pick up where you left off when that happens).

Also, opening a drawer does not tell you what’s in it unless you SEARCH it after opening.

But all in all this was a fun little game. I think I’ll leave it there for today while I’m ahead.

12 Likes

Next up: 19 Once, by 19once (couldn’t find a handle here)

Aaaaand another fail. I spent about 20 minutes trying to get this game to accept any command at all. I get one of two responses:

I will need to go to a chat screen first.

or

I will only need to log, think about, or talk.

But LOG just acts like LOOK, THINK (about) and TALK (to) just tell me to go to a chat screen. CHAT, GO TO CHAT, and a dozen variations on that just tell me to go to a chat screen. There’s no help or hint.

So, moving on.

EDIT: Updated review below.

8 Likes

Next: Free Bird by Kanderwund/ @Cerfeuil

Couldn’t figure out how to play it. The directions are for people who know how to do python things on a computer. I could learn, but I’m not going to.

Which brings me to PSA #2: Make your game easy to play if you want people to play it. I don’t play games that don’t make it easy for me. Don’t ask me to download a random unknown interpreter. Don’t ask me to do computer-y things to play it. There are a LOT of games out there to play, and I’m not going to spend time trying to figure out how to play yours.

Edit: I don’t rate games I can’t play, so this will not translate to a poor score from me.

7 Likes

Next: Beef, Beans, Grief, Greens by @aschultz

Andrew Schultz is the undisputed (go ahead, dispute me on this. I’ll just point you to his IFDB page and then you can be quiet) king of wordplay games, cranking them out at a rate of several per year. Having earned a master’s from the College of Ogden Nash and a PhD from Seuss University, his ability to come up with rhyming games is staggering.

That said, I am really bad at rhyming games. I don’t know why, but I’m always picking the wrong thing to try to rhyme, and lawnmowering through the alphabet and forgetting what I’m supposed to be doing. Give me anagrams and I’ll sail through those, but not rhymes. I’ve apologized to Andrew for this deficiency before, but it bears repeating: sorry, Andrew. I tried on my own and got focussed on the bump in the rug and tried a million rhymes to no effect. I was disappointed that LEAVE REEVE didn’t work, accepted that I’m out of sync with another rhyme game, and went to the walkthrough. And I have to say, never in a million years would I have come up with any of those on my own, especially when there’s stuff like LOVIN instead of LOVING. Literally not one of them would I have come up with. Like I said, I’m bad at it.

If, however, you are a person who is good at rhymes, you will adore these games. They’re silly and playful and the stories are ridiculously zany and there are helpful tools to help you rhyme (yes, even with the helpful tools I still suck).

Man, my record in this comp so far is atrocious. I really need Itch to throw an easily playable, standard parser game at me so I can get my groove back.

11 Likes

And I am not to get my wish. Next I tried Return of the Sword, by @OldTimer (I think? The name on the game is Older Timer. Sorry if this is the wrong handle!), and couldn’t figure out easily how to open it. There’s an exe file in the download folder, but clicking on it yields nothing. No messages from my computer at all.

I can’t believe how badly I am striking out here.

6 Likes

I’m really enjoying these reviews. Keep them coming.

This year’s comp has a real mish mash of weird and wonderful formats. Some games are playable online, some are downloadable and some are both. I prefer to download games and play them offline. I spent all day downloading games and trying to get them working, so I feel your pain.

For ‘Moon-house Technician’ by Tyler Wright, this is written in an ancient mainframe language called Rexx and it’s the first time I’ve seen a text adventure written in this language. Here’s a direct link to the recommended Rexx interpreter on SourceForge. There is a bewidering number of platforms supported, so scroll down the list of files until you find one that looks like the correct one for your platform. As I use 64-bit Windows, I guessed that Regina396w64.zip was the correct file and I happened to be right. For a 64-bit Mac, it’s probably regina-rexx-3.9.6-x86_64-apple-darwin23.4.0.tgz.

Once the file is downloaded and unzipped, you should find a file called regina.exe (or something similar for the Mac). Just drag the downloaded game’s rexx file onto the regina.exe file and it will start.

For ‘19 Once’, the authors are credited on the game page as Yvonne Jeagon & Larissa Jemmy.

Rest assured, there are a few conventional parser games yet to come, so don’t throw in the towel just yet.

8 Likes

I’m just catching up to you. ‘Return of the Sword’ is written by Jim MacBrayne in qBasic64 for Windows. You’ll need a Windows emulator on your Mac to play that one.

5 Likes

I recognize that this information will be useful to others, and thanks for providing it, Garry.

But I am not going to do any of this, and no one outside of your friends or the hardcore tech-IF people is going to, either. Rule #1 for me of game authoring is: MAKE IT EASY TO PLAY. Like, supported by a standard interpreter or online. One-click play.

Also, just to be clear, instead of trying to copy people’s names, I use their handles to tag them and link to the games. This is because I am lazy.

Sorely in need of that, so looking forward to it. @OverThinking just popped up for my next game and my relief at seeing Charm’s name was huge.

8 Likes

Thanks, Amanda! I updated the game to fix that error.

7 Likes

Next up: Paranoia by @OverThinking

Ahh. A game I could play. Kind of. I’m quite familiar with Charm’s work by now, so I know that nothing will be standard and that each game is an opportunity to experiment. At the risk of setting too low a bar for a fine author, I’ll point out that 1.) You can play this game online with one click to open it, and 2.) It’s clearly had some testing and is functioning. But that’s kind of my bar right now.

You’re some kind of experimental subject, and your job is to get very familiar with your one-room surroundings. Very familiar-- tasting and smelling and touching everything is important here (I felt invited to try some racier commands to no effect, sadly). Looking closely at the objects around you is a great setup for a little tutorial, used here quite nicely (although I’d add LOOK (L) since all that Xing and SMELLing can get you away from the room description pretty fast).

You press buttons, things change, and this becomes a game of memory, or a verbal “What’s different between the 2 pictures” puzzle.

On my first play through I had clearly not done enough deep exploration and wasn’t getting anywhere, so I restarted and quickly ran into a weirdness which I’m not sure was purposeful or not; I was asked to quit as an urgent request, and so I did, and that was it. No option to restart. So huh.

Third play through gave me a looong section of rooms. I was never really sure if I was was looking for differences from the original room, or from the previous room, so I went with the original room thing, but my memory isn’t fantastic, so I didn’t get anywhere.

I’ll probably go back to this after the comp is over and play with it again while taking notes. I highly recommend taking notes if your memory isn’t sharp as a tack.

Enjoyed it!

8 Likes

I sympathize with Amanda. Games entered into a comp should be easy to play. Games that require judges to jump through hoops to play will not be rated as highly (or at all) as they would be otherwise. Many judges will just move on to the next game.

7 Likes

Next up: MysteriousCave by Ragi (no obvious handle here)

A teeny-tiny Adventuron game with one very easy puzzle and some lovely artwork, this takes about 5 minutes to play through.

Unfortunately, almost nothing is implemented in this game, so examining the things around you just yields the standard “You notice nothing special” response. And I have a constant irritation with Adventuron over this, because you can type “X flibbertigibbet” or “X giant horsie balloon” or anything that patently isn’t there, and Adventuron will tell you “You notice nothing special.” Not that this is Ragi’s fault-- I encounter this in most Adventuron games and it makes it hard to know if you’ve misspelled something or if it isn’t implemented.

Anyway, it’s a playable game and the art was delightful.

9 Likes

Next: Mystery Isles by Oz Realms (no obvious handle)

Another one I couldn’t easily play. The download link from the Comp site yielded something that couldn’t be clicked on, and when I went to the game page I was confronted with a $2.00 optional fee, which offended me even though it was optional. It’s like the time I went to buy a painting from another artist at a fair and there was a tip option and I walked away without buying the painting, because no.

But also the game page says I’m supposed to download some kind of emulator, which again I’m not going to do. That makes a hefty amount of interpreters/emulators/computer-y stuff one would need to play the majority of games in this comp, and no to all of it.

I sound like an old lady yelling at the clouds, but it’s annoying me at this point. I just want to play some IF.

EDIT: Updated and reviewed below.

9 Likes

I feel your pain… I don’t know why the author buried the information so deep but Mystery Isles is an Inform6 game so if you download the zip-file at the bottom you can play the z5-file with a interpreter you probably already have.

EDIT: There’s also a link at the very bottom to play the game online.

5 Likes

Thanks! Maybe I’ll try it again later, but I’m too irritated by the difficulties (and asking for a fee!) to be fair to this author right now. I’m also just generally irritated by the difficulties in playing nearly anything in this comp, and I don’t want to take that out on anybody who runs afoul of me right now. On the flip side, anyone who who has a playable game at all is in my good graces, so there’s that.

9 Likes

Thank you for the review!

You’re so right. That is going directly into the list of things for release 2.

It’s the former!

6 Likes