Adventure + Cheat

Ok, some explanation is in order. The basis for this is Aaron Reed’s excellent port of Adventure for Inform 7, which he used to showcase his Intelligent Hinting system. What I’ve done is, I’ve removed the intelligent hinting system and made only one very simple, very basic alteration.

Because the biggest hang-up for Adventure, for me, was always the time limit, I’ve made it so that cleaning/rubbing the lantern extended its life by 500 turns. I considered detracting some points for doing this but I thought, then I’d be replicating the behaviour of the batteries. This way if someone wants to cheat, fine; if not, they can still play as intended.

I’m unsure about the specifics of this port; the comments at the beginning of the source code read

[rant]Advent 080512 A classic and one of the standard Inform 6 example games
! Adapted to Inform 5: 17.05.1994 to 24.05.1994
! Modernised to Inform 5.5 and library 5/12 or later: 20.12.1995
! Modernised to Inform 6 and library 6/1 or later: 11.11.1996
! A few bugs removed and companion text rewritten: 09.12.1996
! Some very minor bugs indeed removed: 24.02.1997
! And another two: 04.09.1997
! [RF] Source reformatted and very minor bug removed: 02.09.2004
! [RF] Added teleportation, also minor bug fixes: 21.03.2006
! [AR] Adapted to Inform 7: 12.05.2008

Regardless of what this all means, the fact remains that Aaron Reed has ported the whole thing. I have just finally succumbed and made it so I could play the game without any worries regarding light limits.

I know I could have played SpAdventure, but apparently that one has a couple of quirks that make magic REQUIRED for winning the game. Not what I wanted to experience at all. There’s also a TADS version that has an “easy” mode with a very large-limit lantern, but that’s TADS, I can’t play it on iFrotz.

Also, I’m not “releasing” this because, obviously, I didn’t make anything. I just thought maybe others might be interested in playing this bastardisation - a version of Adventure that’s a tiny, but significant, step towards the sensibilities of modern players.

Mind, modern players will still have a lot of difficulties with other old-school-isms, but now they have a lot of time to struggle with those. :wink:
AdventureCheat.z8 (317 KB)

Awesome! Now I have no excuse for not playing Adventure. Hate those time limits.

Oh, I’m pretty sure you’ll find lots of other things that’ll frustrate you thoroughly. :wink: It’s a funny thing, though, I know the answer to a lot of puzzles just because they get spoiled around so much. THe dragon, the bird, xyzzy…

Not the gold nugget, though. I solved that once in a version that allowed me to exploit a bug. I’m looking forward to doing it properly. :slight_smile:

Don’t get me wrong, I’ll happily subject myself to frustratingly old school game design, as long as I can take my damn time over it. :smiley:

Cool, you Kobayashi Maru’ed it. But why not go whole hog – no time limit? After all, no one is really going to give you half marks if you say ‘I hacked the time limit, but only a little bit.’ The game is hard enough anyway, it doesn’t really need a time limit. I would make getting the battery give you infinite time so you still have to find it.

If I went that way, why stop at that? Why not rework some puzzles, remove some randomness, alter the pirate, remove the mazes…

I understand what you mean, but as you see, the whole hog isn’t quite as straightforward as that. I just wanted to alter it a tiny bit, so that modern players had the option to extend the time limit if they so wished. The batteries give 2500 extra turns, which is a lot. This cheat allows you to increment your existing lamp life - “clean lamp.g.g.g.g” is equal to getting the batteries, a lot of turns with a minimum of hassle.

Also, actually using the batteries is an optional puzzle - a die-hard adventurer can (and must, for the highest score) finish the game without using them at all. So the player doesn’t have to find it, and it’d be a extra hassle. I understand the idea that the player would work hard to get the batteries and, since it’s a sort of cheat anyway, they’d go the whole hog and have unlimited light in the new batteries, but I really prefer to leave it up to the player.

I mean, I could actually make every room light. But where would be the fun in that? So I shirked from “infinite”. Small increments seemed wisest.

On another note, what does it mean, I Kobayashi Maru’ed it? All I can think of is the Ninja character in Kid Radd. :wink:

EDIT - Also, not much of a hack, really. The source code is out there and I made only a minimal adjustement. All those tons of mods from the original Colossal Cave, now, some of those must have been REAL hacks.

And I Wiki’d Kobayashi Maru. But I would argue Adventure isn’t a no-win situation, merely a potentially frustrating one for newcomers. Personally, I expect one day to try and solve the expanded versions of adventure, after first completing a cheater’s version of the simplest.

Arguably, you’d have to do all that to make it significantly less frustrating for newcomers. The battery limit is just one of many ways that you can paint yourself into a corner.

Exactly my point. I did not set out to make a less frustrating version of adventure, merely to remove the biggest barrier that I, myself, have always found to hinder my exploration. Hence this being just “Adventure with a bit of a cheat”, rather than “User-Friendly Adventure”.

I think there were two ways to solve the golden nugget.

And I’m pretty sure the way I did it, years ago, in DOS, was not one of them. :slight_smile:

In the version I had, putting the nugget in the cage did not make the stairs disappear, because I wasn’t carrying it directly!

Heh! I didn’t expect you to take my metaphor so seriously. I was just being flip and complimentary; what you did is cool in a similar way to how what Captain Kirk did is cool. Don’t like it? Hack it! I am all in favour. 8)

I accept your arguments on why you did it the way you did; after all, it’s your hack. I just personally would have done it a bit differently, trying to keep the perceived values to the player of the solving puzzles (like the battery) roughly the same, while trying to entirely remove the necessity to start over or fiddle with the lamp in the late game, although as zarf pointed out, the light puzzle is hardly the only thing that might force you to start from scratch – it’s just the only one that you can’t learn to avoid.

Well, this is unexpected. Due to my little cheat I’ve finally finished Adventure, taking my time over it, but it was the weirdest game session(s) ever.

Because, due to my having played bits of it many times before, and from reading reviews and articles on IF in general, a large amount of the game was already heavily spoilered! Magic words, the rod, the bird, the dragon, the existence of two mazes and the subtle difference in one of them…

Then there were the bits that I solved myself - the nugget, the troll, the rusty door, the plant, the clam… but those are self-evident. The troll and the plover’s egg emerald gave me more trouble, they weren’t immediate, but I wouldn’t call them hard, and the others were self-evident.

I actually skipped the REAL frustrating bits, therefore, by having them spoiled slowly and thoroughly over many years of IF theory.

And then the last move I had to check the source code for. I knew it was guess the verb, and I was right, and I really wouldn’t have gotten it by myself.

The funny bit, though? Without the light limit to contend with, I actually navigated both mazes by trial and error. I kept walking around until I got somewhere!

I was left feeling, however, that this was a very, very fine example of cave exploration. While “Hunter, In Darkness” is a brilliant and atmospheric game, “Adventure” is THE cave crawl. I felt it was, finally, well worth my while to get familiar with the cave system. I didn’t even need a map (granted, though, I have drawn a few of them over the years, over many attempts. Memory had a lot to do with it).

And Laroquod, I suppose I got too serious because I actually thought about those things. :wink: I wouldn’t like to bastardise it TOO much, otherwise it wouldn’t BE “Adventure” any more, but it’s tempting to do something about it since, well, you CAN.

And hey, if you would have done it slightly different… well, the source code is I7, very easy to understand and modify. What’s stopping you from customizing it so you can make a version of Adventure YOU can gleefuly see to the end? :wink:

Well I’ve solved it many times and have even reimplemented my own multiplayer version in LambdaMOO. If I were to work on or even play that maze again, I’d inevitably get sucked back into trying to add multiplayer puzzles to my own version of the game. I’m gonna let that sleeping dog lie awhile longer.

I’m instantly intrigued.

It’s basically done but there are no multiplayer puzzles yet so there is no actual reason for it to exist as it currently offers no real benefits over any other version. (I kind of did things backwards in that respect.) If anyone’s got a cool idea on what multiplayer features might be fun in the Colossal Cave, please let me know as I’ve got that environment ready to accept & test such ideas. My main idea so far is adding a variety of different monsters that require cooperation to kill, or at least so that one player can fend them off while the other works on puzzles. (No matter how many players, there is still only one lamp, and I’m thinking you won’t be able to hold it and fight well enough at the same time to kill anything bigger than a dwarf.)

Making it more like a dungeon crawl in D&D is not exactly brilliant; it was just my first idea on what to do with a multiplayer replica and what I was working on when last I put it down.

My alternate way to get the nugget out:

The intended way is to use plugh or xyzzy; there’s also a way to get out through the pirate’s maze.

Major spoiler fail! Please edit to fix the tag.