A tip for Windows 8 users

I noticed that on my new, much faster PC, compiling Kerkerkruip in Inform 7 took much longer than on my previous PC. Turned out that at the end of the compilation process, Windows 8’s “Antimalware Service” starts running, and this takes quite some time to complete. It probably suspects that Inform is trying to install BAD STUFF on your hard drive!

So, if you’re running Inform 7 on Windows 8, you should definitely do the following:

  • Go to Windows Defender, then Settings.
  • Add your Inform folder to the Excluded files and locations.

This might also be a concern on Windows 7 or Windows 10, but I’m not sure about that.

See also: [url]https://intfiction.org/t/inform7-slow-compiling-windows-10-windows-defender-problem/10165/1].

This issue popped up in a few other threads recently and it’s not specific to Windows 8. I had it with Windows 7 and it turned out it was down to the Windows Defender handled certain things.