A new online adventure game osmiumisland

not sure of the correct place on this site to announce this but I’ve just ‘finished’ coding a post-beta version of a new adventure game osmiumisland.com and would welcome feedback. I’m still working on improving the text interface, spelling mistakes and coding more Easter eggs but’s playable in its entirety. Warning - it’s massive, about 360+ rooms and would normally take several hours to complete. However it is split into 5 zones so you can always consider ‘zone1’ as the first ‘game.’ As far as fiction goes each room has an alternative history; this is nothing to do with solving the game but is provided as a feature; you can also save and load a game. There is no real violence and no bad language and it is suitable for all ages. Thank you.


Welcome to the forum.

I hate to get off on a bad start, but my first impressions of your game aren’t good. While reading the text, it suddenly jumps up the screen. I quickly realised that random events are taking place, none of which seem to be important, they’re just for colour, and the text jumps up to accommodate the printing of these events. I tried to copy and paste some sample text and it kept jumping to the end before I could do so.

The first thing that any adventurer will do is examine the surroundings and any objects in the current location:

x kilt
I don't understand

examine kilt
I don't understand

look kilt
I don't understand

look at kilt
I don't understand

So, it doesn’t understand the most basic commands of any text adventure. Pushing on:

get kilt
You get the hessian kilt.

x me
I don't understand

You are wearing a hessian kilt.

I didn’t ask to wear it.

examine hessian kilt
I don't understand

remove hessian kilt
I don't understand

So, I can get it and automatically wear it, but I can’t remove it.

There’s a character named James, who keeps interrupting and causing the screen to scroll so that I can’t refer back to the room description.

talk to james
I don't understand

talk james
I don't understand

speak to james
I don't understand

ask james
I don't understand

ask james about kilt
I don't understand

tell james
I don't understand

tell james about kilt
I don't understand

I tried a few other things, but nothing seemed to work. In between trying to read the text, it scrolling off screen and me scrolling back to the top, I managed to see that there was a COMMANDS command. This gave me a list of commands and they were indeed quite spartan. Most of the commands seemed to be related to showing statistics, like in a role-playing game, so maybe that’s what this is.

I haven’t got the patience to sit through 360+ rooms of a game where the parser doesn’t understand the most basic commands and random events keep scrolling the text off screen while I’m trying to draw a map and take notes. Others may like this, but it’s not for me. No offence. I can see that you’ve put a lot of work into it, so see what others think.


x kilt

was one of the commands I have tried early on as well, alongside with

look at kilt
look kilt

since the instructions implied that the game was inspired by early text adventures.

Are you meant to be able to read the various writing on the rocks? I also can’t seem to drink the “medium bottle of water”. Or the latte. Edit: or in fact anything. I know you said this is a very early version… but that thirst seems to be a key mechanic that isn’t actually coded in.

Edit2: Ah right… you just type DRINK on its own. (That’s going to confuse people)

Edit3: Following that logic… I now see that READ on its own, will let you read the various notes on the rock. To be fair… HELP/COMMANDS does sort of hint at this but it’s definitely not the usual VERB NOUN input a player of old text adventures expects!

(You may want to add “take” as a synonym for “get” for the 50% of “weird” people that prefer to use that version)


I had the same “X KILT” experience.

I want to add that I miss a sort of hook which pulls me inside of the game’s content. I feel like a nobody being nowhere.

Also somewhere you write something like “This is probably the greatest IF on the web” or similar. That’s quite bold and I don’t think it’s true.


other points;

I liked the pictures.

I actually think the real-time effects are quite cool, but i agree with the scroll problem. Maybe something like a Scott Adams style split screen would work better for this.

I initially thought the color highlighted words were clickable. Perhaps this is something planned for later, but it would be nice to have this. Obviously this would do the same as x whatever, which would have to work too.

Looks like there might be some RPG elements. I discovered i could attack people, but nothing much came out of it. Thought perhaps the “energy” is connected to this.

Best of luck.

Hi all, thanks for the updates!
Some great ideas here for improvements. First of all let me clarify a few things:
a) All commands required are detailed in “commands” - this is absolutely not about guessing or uncovering hidden verbs to progress - all commands you ever need are listed.
b) I confirm ‘Look’ is only for the room - it redisplays the contents. I confirm there is no ‘look item’ - what an item looks like is nothing to do with the adventure.
c) ‘eat’ - I have fixed this bug - you can now ‘eat burger’ as well as just ‘eat’
d) scrolling issues - I love the idea of the split screen - great suggestion. I’ll have a play around with the real estate of the page and try to implement it - I hadn’t realised what a pain this would be for people trying to create the initial map - sorry. I will work on this as a priority and update the thread when done.
e) The timer is set to 15 seconds. Is this too frequent? What do people suggest, maybe 30? There is a ‘hidden’ development command to stop and restart the timer. Shall I make this a feature? It will stop the characters giving you clues, which I guess could be a stated trade-off.
f) ‘Probably the best game’ is purely ironic - it’s a play on the original Carlsberg ‘probably the best lager in the world’ adverts which were on all the time during the same era in the eighties!
g) You can’t ‘attack’ anything - in fact it will detect this and the character you attack will reprimand you! The whole idea was to have a non-violent game. The robots do attack you, but with comical violence, as they are all armed with only comical weapons.

OK here are some clues for the game.
There are essentially four types of item in zones A to C: keys, clothing items, normal items and money. All are obtained by uncovering the correct ‘trading chain.’ These start with finding something freely available on the ground and then giving it to the correct character. You can uncover these quite simply by trying to ‘get’ and item held by another character. so for example if you do “get book” when fred is holding it, he might say, “no, but I will swap it for a candle.” You then have to go find a candle. If somebody else has it, then you find what they want etc. So as well as drawing a map, you will need to write down your trading chains. Here’s a clue: ‘key’ characters ie either robots or those involved in solution chains, stay put and do not move around. Only the cosmetic characters move. But the cosmetic characters give you clues when you are holding something - they will say if they think it is useful or not. So in zones A-C you need to both unlock doors (including the doors that lead to the next zone) and deactivate the robots. To deactivate a robot you need to a) be carrying the correct deactivation item and b) be wearing the correct shield item of clothing. You can if you want ignore the robots and just uncover the chains required to get door keys, and open up the whole adventure, but you can’t defeat the boss robot unless you have deactivated all the others.
In zone C, some items are ‘use’ items. No difficult text required, just ‘use glue’ for example. If it’s of any use in that location with anything there, it will detect it. Many items are broken and require something else to fix it. So say Fred wants the lawnmower to give you something you need for a trading chain, you would need to say “use welder” first to repair the lawnmower. The game will always say if something is broken or mended - then you know you need to look for something to fix it. Other “use” items may uncover further items but there are usually strong clues to suggest this.
In zone D, you have ‘papyrus’ objects. These contain fragments of a password written in strange languages. You have to find the right characters who speak the right language, and build up the passphrase to gain entry to zone E.
In zone E, there are lots of radioactive items which need to be recovered and recycled. One this is all done, and you have all deactivation codes ( there are 11 normal robots in total) you can enter the final room to confront the boss robot.

Hope this helps - I will definitely add the split screen - that’s a great idea. THANK YOU all for trying this - I am completely open to suggestions.
please vote on whether you would like a time start / stop ?
kind regards :slight_smile:

Can I just say I have no idea why half my last post is in a larger bolder font? Sorry if that irks anyone, it wasn’t intentional !

Cool, you have obviously put alot of effort and thoughts into your game!

I like the non-violent way.

I didn’t know the beer ad, and I don’t spot a joke even if it sits on my nose :slight_smile:

So you can’t (and needn’t) look at items. But how do I find out what seems to be written on the rock?

As mentioned in my post, you just type READ.

Not quite sure who the author is targeting as an audience for this game. The non-standard input will frustrate most old-school text-adventure fans, I imagine.

1 Like

The horizontal line was turning it into a heading. Make sure you include a blank line above and below for it to be parsed as a horizontal line. I’ve fixed this for you.


Why not just print any random background events after the user’s input, like in a conventional text adventure? This avoids the frequent timer-based output and the scrolling issue.

1 Like

I think 30 sec is better than 15. I think start/stop is not needed since (afaik) there is no harm from the walking NPCs.

Hi people,
thank you so much for your comments. I’ve just uploaded a new version with a split screen. The location description along with who and what is in there is in the top box, and this stays in place until you move to a new location. All dialogue is now in a lower box. Couple of little buggettes fixed as well. It’s funny what you can miss when developing; I’d got so used to the map that ‘mapping’ wasn’t an issue! I confirm that ‘read’ is all that’s needed to read stuff. Most 'read’s are red herrings usually a philosophical quote, but a small number are clues to robot defence items and deactivation items.

Another question for the community: I agonised as to how much ‘map’ to give away. Has anyone found the skeleton map on the resources page useful?

thank you all :slight_smile:

Oh, and sorry the timer is still 15 seconds - but as said this fires changes only in the lower box now. Let me know if this feels about right…

Oh, as for audience, this game started off in life as something I coded frantically over about a dozen cappuccinos as a last-minute covid lockdown project for my computing classes ( I was teaching in a school at the time, 11-16. ) That’s now evolved into a python port ( both only have about 40 rooms so are solvable in about 15 minutes ) so as such I wanted to have a non-violent theme. The huge version online now is still all in javascript. I obfuscated it originally because school children soon learn how to hack the code dynamically and the characters in the game started to take on very unflattering and rude names for the teachers!
So the eventual goal is to allow it to be used 2 ways: One as a normal logical game to solve, suitable for older teenagers upwards, and the other just for the younger kids at school to drive around and find the Easter eggs. I plan to add many more ‘educational’ eggs to this end. This will also serve to make the game slightly harder to solve because there will be even more keys in circulation which will only exist to unlock egg rooms. Oh, and the ‘hd’ / ‘historical detail’ command was added to wind up my lad who’s doing a masters in history :slight_smile: It’s a tongue-in cheek take on British history - the real events of which can sound every bit as absurd as the fictional ‘history’ in this game.

So the real driver for the game? I work in a school and I run several coding clubs and basically I get them to build the same sort of game over the course of the year, although they do it in python. Their ‘easter eggs’ will be coding ones, for example an ‘egg’ which shows how a bubblesort or quicksort or something else works, or some revision flashcards.

Ha, ha, ha! Love it!

You should take a look at Adventuron, not for general programming, but for text adventures. It was originally designed to be used in an educational setting.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.