A Colder Light - UI system feedback

I have to say interfaces like this one and those produced by Undum make a lot more sense in the touch mobile world, without quite losing the feeling of a parser (because there’s real object manipulation with a world model behind). I have still not tried this (great) game on my android smartphone, but at least these Undum games play like heaven:


The problem is that even with amazing input methods such as swype, traditional parser IF still is not as smooth an experience on mobile.

So, yeah, bring it on. I see it’s an updated version from the experimental interface of Dead Cities, which was also quite a blast.

I tried playing Clod’s Quest on my Kindle Fire, and it didn’t play so well. (Undum will only display one of the story pane or status pane at a time. Clod’s Quest really depends on having both available at the same time.) It should be possible to modify Undum in such a way that, when played on a mobile browser, it shows the status panel above the story window. Anybody know how to do that?

Oops, it’s sadly true! I played Clod on PC, only Monster Matter on android. My bad…

OTOH, trying it just now, found a way to get to that menu: you click on the main Undum menu and choose character. The items menu is there. Yes, quite a PITA, it should be always visible as in desktop because you’ll be using it all the time. Changing user-agent to desktop had no effect, though…

still, Undum is truly a marvel to behold…

I know that it was possible to get to the menu, but having to switch back and forth slows everything down horribly.
One big advantage of Undum port over the other versions is that everything’s available all the time.

For those interested, A Colder Light is now up to Release 4. This latest version speeds up gameplay considerably by bypassing the parser entirely, on a suggestion by Jimmy Maher (although it still isn’t instantaneous).

Secondly, I’ve rejigged the UI somewhat in line with some of the feedback here - notably the observation that one had to move the mouse right to the top to get to the inventory, then down again to do an action. I’ve come up with a solution that I think is compact while still being elegant.

Comments welcome!



Ooh, I like it.

(I still think that the “<” button might profitably be replaced by a “more” button.)

I like that layout much better. Beneath is particularly interesting! I guess we’ve always had inventory and graphical maps expressing world model relations, but bringing other relations into the UI more explicitly feels like something worth exploring more.

If I can add a thing… no web-based game (except Undum as far as I’ve seen) consider a layout that renders the reading easy.
None, including Undum, consider screen resolution. Although it is romantic to think of IFers as nerds with an old green phosphors 14" display, actually some, like me, use to play on a 27" 2500x1600px widescreen.
On an off-line client it is easy to adjust the layout and font size to my needs, but I can’t do it in a web-based tool.

So, although I don’t know how to achieve this, I want to suggest:

  1. max 60 columns, to avoid too long lines, which are hard to track when jumping from one to the next.
  2. a proportional font that lets visually-impaired like me to actually see the characters instead of imagining them from the average shape. :slight_smile:

I bet this is asking too much but it surely would rock the place.

Anyway: as soon as I finish Cryptozooetcetera I’ll give this very promising experience a try.

You have tried just increasing the browser font size (Ctrl++)? I will never add anything to Parchment to change the font size because the browser does it better. If you want more control over the styles you can install extensions like Stylish.

I have the Parchment on my home site rigged for a maximum column width. I am in favor of such layouts, although, of course, you can always resize the browser window.

(Yes, yes, tabs, I know. Eject 'em.)

If no-one else has mentioned it yet, I may be the only person to whom this is happening, but:

With your update, I now see deactivated scroll-bars all over the place.

Image in the spoiler (not really a spoiler, but it is a big image).


Using Firefox. Don’t know which version anymore - but I do always install the latest one.

Thanks, Peter. That’s now fixed.


Beautiful, thank you.

On another note - you know how I’ve been pestering you for an offline version? :unamused: I’ve finally figured out how to download the online version, so it’s all good.

Little FYI, though. Because the beautiful background image wasn’t in the same subdirectory everything else was, I had to download it seperately and edit the HTML to point to it in its new location (it would have worked if I’d kept them in the same folder, but I like to keep things neat: if with HTML I have a folder called “The Colder Light_files”, then that’s where the backdrop’s going).

Allow me now to become the sovereign of nitpicking and ask… is it “A Colder Light” or “The Colder Light”, not that it matters much?

I really like the approach being taken here, and I’d certainly appreciate an extension. I don’t think it makes the game too easy and it takes a lot of unnecessary guesswork out of the player’s interaction with the game controls. That guesswork is important for some games, the Gostak for instance, but not every game.

Two comments:

One, it runs so slowly! Actually, I’ve found that pretty much all glulx games run slowly online, so it could be an issue with Parchment, or my laptop or internet connection, or some combination thereof.

Two, the ‘continue’ button at the start of the game doesn’t work on the very latest version of Opera (11.61). Instead there’s an invisible text box (I guess where the parser would usually be) and you can press enter in the box to get it to start.

EDIT: a third thing, when collecting the wood rune after I’ve dropped it outside, it still says I’m collecting it from the fire pit.

I just took a peek at this game the other day. I had not seen the previous releases.

intial reactions:
Feedback from my browser is slow. There is a delay of 2-3 seconds between clicking a button and seeing a response from the game. This makes it frustratingly slow to play. The button clicking felt very tedious, especially when it came to things I do repeatedly, like looking around (pretty much required to interact with the environment in this game). I am using the latest version of Firefox and Windows 7.

Maybe once you’ve looked around a single time, there should be buttons available to interact with each item in the vicinity. Rather than having to look around, click a hyperlinked word, and then interact with it every time.

There are a couple of bugs, or annoying bits that I would call bugs. Specifically:

[spoiler]the Blades can only be accessed from High on the Ridge, and they are used down in the valley, several steps away. This wouldn’t be a problem if they didn’t melt away to nothing several turns after being summoned, or if I didn’t need to summon the Hunter to follow the tracks every time. It was frustrating having to go back and forth to get the Hunter, the knives, and me all in the right place at the same moment. Since it’s such a short game, I would suggest having the knives and harp just stay put in the player’s inventory once they’re acquired.

Once the hunter has pointed out tracks and helped me follow them, I should be able to follow my own tracks back and forth from there.

In the Wastes, “Follow the bear tracks” and “follow the new bear tracks” give different results, which was confusing. (The former takes you back to your house, the latter takes you on to the icy area.)

I expected to be able to pick up the cooked seal meat, and thought it was strange that it remained “too hot to touch” long after I put the fire out. This made me stuck for a little while, since I thought the bear wanted the meat.

When the seal meat is in the pot and the player carries the pot, you can’t interact with the seal meat; you have to put the pot back on the hook and THEN try to get the meat.[/spoiler]

The plot reminds me a lot of the book Julie of the Wolves, with a couple twists from Norse mythology. The ending scene feels a little dissonant compared with the tone of the rest of the game, but maybe that was the point. I ran through the game twice, found two slightly different endings, but I would’ve been more impressed if

destroying the port had some greater effect on the text, or giving the amulet to Father had some sort of effect. That said, I did like the story and setting. It was well written.

Having commands limited to buttons was good in one way: it made the rune business very clear and not difficult. I was also pleased to find that you can play two runes in any order, and they’ll still work. That may be unrealistic (depends on the language syntax, I guess) but it certainly makes the puzzles easier.

It would be nice if certain tricks were automated after the first time doing them successfully. For instance, the button that says “Summon the Withered Tree” could automatically play the 2 runes, look up, and summon in one click after you’ve proven you know the Tree’s rune name. Repeating the same sequences of 3-4 actions many times got tedious.

Merlin, I’m using the latest Firefox on latest Windows too and am seeing no lag whatsoever. Perhaps you need to upgrade the hardware too rather than just the software?

I’ve been told that in the early Infocom days, commands could take a few seconds to process, even with a tight VM in assembly. Nowadays you get a VM running in javascript in your browser that features no noticeable lag and people still complain… slow down on the coffee.

Only just noticed this, apologies for not replying while this thread was still breathing!

I changed my mind halfway through, to be honest, so I get confused, but I think it’s definitely “A Colder Light”.


The original link seems to be down – is it available anywhere else?

This is where I am vindicated for my obsessively downloading everything and ranting when a game can’t be downloaded.
The Colder Light.rar (546 KB)

Heh. Thanks! I was just looking for this. I wonder if Ingold would be ok with putting this into if-archive and ifdb.