I recently got my very first cell phone, a Sanyo SCP-2700–the cheapest available to me. It has a full QWERTY keyboard and can run J2ME apps, so of course I wanted to play IF on it.
It seems my only option is ZeeME. I can’t use ZaxMidlet or JFrotz, because unsigned apps can’t access the filesystem. ZeeME is different because the story file is included in the jar.

But I have run into a couple of problems with ZeeME on my phone. I’ve contacted the author but had no response. I was hoping someone here might have the necessary technical know-how. I have only rudimentary Java knowledge and know precious little about J2ME. So far I’ve tried the Minizork that comes with ZeeME by default, as well as Christminster, Lost Pig, and Risorgimento Represso.

The biggest problem is that indented lines vanish completely. So for example INVENTORY just prints out a few blank lines. I’ve seen a comment online that the Sanyo SCP-6780 does the same thing. I don’t know how Inform does this indenting; are they tab characters maybe?

I have a few other issues, but that’s the biggest one. Any ideas?

Inform indents by putting space characters at the beginning of the line. (Tab characters are normally not used in Z-code. There are a couple of historical exceptions, such as the prayer book in Zork 1.)

I don’t know why the interpreter would fail to handle that case, but that’s the case it fails to handle.

If the price difference between a phone that can’t play ZaxMidlet and a phone that can isn’t all that big - and hey, I had a fairly standard Huawei which could! - I would actually advise you to get a phone that can.

Yes, I know this is not what you asked and is probably unwelcome information. I mean, here you are, trying to get thigs to run on what you have, and this guy comes up and says “Best to change systems”. Well, trust me, I’ve had lots of experience with mobile IF, and 90% of that experience was eagerly looking for the perfect solution.

The perfect solution so far seems to be the iPod Touch (cheaper than the iPhone). ZCode AND Glulx, plus with the right app I can still have all the docs and all the PDF feelies to view anywhere.

Mobile-phone-wise, I can’t speak about the Android systems, but ZaxMidlet and its higher-quality successor (which, surprise surprise, needs a more powerful phone), JFrotz, seem to be the best choices. I even got the impression ZaxMidlet (and by extension JFrotz) are rather more stable than Twisty or That-Other-Interpreter-That-Starts-With-“H”-And-Always-Puts-Me-In-Mind-Of-Nanny-Ogg-Winking-Feverishly-And-Going-On-About-Hanky-Panky. ZMPP I have no idea about.

I did try ZeeME and Z2ME. Your system can play both, but Z2ME can only play .z3 games, which pretty much restricts you to most of the Infocom classics. ZeeME I personally had a LOT of issues with…

And regarding updating either Z2ME and ZeeME, I think you’re out of luck. You’d have a greater chance of fixing things if you found yourself someone who understands the source code and is willing to poke around in there.

EDIT - Oh, and Z2ME only allows you one saved game at a time. Still, I beat Hollywood Hijinx like that. :slight_smile: And Leather Goddesses on ZaxMidlet.

Nathan, thanks for posting about your experience using ZeeMe. I’ve been trying to get IF to work on my phone – the Samsung 390sg – and had just about given up on getting IF to work on any device that isn’t “smart.” I had never heard of ZeeMe before.

It seems to work alright for me. I only tried Minizork and Talesinger’s Parasites so far. With Parasites, the long opening text gets cut off and I think the status line gets run into the command prompt, but it is still mostly playable. I think the problems probably have to do with Inform 7 not being designed with minimalist devices in mind. Minizork seems to work fine. I need to try it with Inform 6 games as well as Infocom .dat files.

Any phone with a QWERTY keyboard was born to run IF!


I’m pretty sure that the price difference is vast.

You can get cheap Android phones for <$100 that will run both the Java terps and the online Javascript ones. For sure there’s lots of room for improvement in the terps, but they can do the basics!

Ok, well, you probably know best. But it doesn’t take much to run ZaxMidlet - JFrotz is the really intensive one.

EDIT - and incidently, this is the phone which I used to run ZaxMidlet: gsmarena.com/huawei_g6608-4032.php

It’s nothing fancy, is it?

Hey, it turns out ZaxMiddlet works on my phone, too! The only problem is that I can’t backspace to fix a typo. Other than that, it looks like Gargoyle. Cheers, Pears! :slight_smile:

Supremely glad to have helped. :smiley: It has number of known bugs I was in communication with the author about, but he decided to discontinue it in favour of JFrotz (and can you blame him, really).

Can’t backspace, though?.. That one I’d never heard about, and it sounds seriously detrimental to a goom gameplay experience… how exactly do you mean?

The phone’s keypad has a tiny backspace button, but it doesn’t work in the command prompt. Strangely, it also has a return key, but that button does work correctly to enter a command. At any rate, I can press the left navigation button to bring up a menu from which I can enter the command in a text field, and I can backspace there. However, that still doesn’t completely solve the problem, because when I leave the menu, the text that I wrote is only appended to whatever was already in the command prompt. I can’t fix a typo.

That’s not a terribly big deal, though. You’ve helped a lot, Peter, I appreciate it.