Ye Olde Worlde SUDS

Hi all, it’s been a while, as in years, since I was last on, got distracted away from IF. At that time I was investigating using SUDS. I’d barely started when life threw a spanner in the works. Anyhow, I was short of something to do so I re-installed the beast. Naturally I had to restart from scratch, go through tutorials etc, sigh. I had some questions, went to the web site and found it has vanished, darnation!

So if anybody has a long memory…

(1) Does that mean it is officially dead, or is there a new site?
(2) Does anybody still have SUDS games to download?
(3) Is there a later version than 1.0 and is it available anywhere?
(4 )Was there ever a reference manual, as the help files don’t really fulfil that function?
(5 )Back in the day, 7 years ago, someone said that SUDS was the only point and click generator, is that still true?

Thanks in advance for any replies,

Heres another SUDS thread, from 2010: [url]]

If you’re looking for point-and-click there are several modern systems that do it and are pretty well-supported.

Twine is the most popular.

I’m fond of AXMA Story Maker and prefer it to Twine, though I’ve had to surf some Russian forums with Google Translate.

Quest has a CYOA system and a parser with clickable elements

Thanks for those. I shall certainly investigate.

BTW, the 2010 thread was me! :laughing:

There seems to be a Version 3 available from one of’s backups of the site.

EDIT: adding URL:

Well that is interesting thank you, but I am too much on the fringes of IF to know what you mean by that, so could I possibly trouble you for a little more detail please?

Thanks for the PM. I got that downloaded. Still amazed that in years of being on the internet I’ve never before needed to know that that archive site even existed!

A word of warning to anyone else attempting to install SUDS 3.0, the installer still says it is installing 1.0. IGNORE that, the actual software is definitely 3.0!

So, I had a dabble around the other systems. Wow, amazing what you can do nowadays, but all far too much for an occasional dabbler such as myself!

Hence I figured I’d go back to SUDS, it definitely suits me. First job? Well the obvious thing was to see if I’d learnt the lessons by converting the tutorial game into a proper game, for example, no more walking around underwater forever without it ending badly, and so on.

When I had completed that to my satisfaction I thought, “I ought to try the generate a distributable option”, not that I wanted to distribute my efforts, just to see how the process worked. The first worry was the icon to that was greyed out, and the equivalent menu option was not! Well I had to try the menu option didn’t I? It seemed to do things, status bar going to 100%, being told where the output file was. Good good. Except that there was no file anywhere!!!

Anybody got any further input on this? Perhaps I’ll have to give up on SUDS after all, damn.

The menu option “Make distribution” seems to work for me. (The corresponding menu button isn’t greyed out, but I didn’t try it.)

I see. Thanks.

Well, starting with a fresh load of the Creator and the .SUD file caused the icon to be no longer greyed out, ye hah.

So I tried again. There is a file created. BUT it has a file extension xml, actually “PData\suds.xml” in full. AND if there is one thing this file isn’t, it is not an xml file. Hence, I didn’t see it as being the deliverable file the first time I tried this. It is binary not text as one would expect for an xml file and the first 16 bytes are ABSOLUTEDATABASE. I have no idea what, if anything, I should do with this.

I was expecting “First Tutorial.exe”, somewhere, anywhere!

Here are the files that seem to be created for me:

initial.sop Master Files\ PData\suds.xml prefs.dat Saved Games\ SUDS_P.exe SUDSPlayerHelp.chm

Some of those files on my machine are not new. Some are. The SUDS*.* are not new, they are the originally installed files. They are in any case in the installed Player directory, which is not where I targeted the output. I always get those other files being updated so I assumed they are not part of distributing my game but part of the overall installation. So to avoid confusion I just now moved my .sud file to a completely separate folder well away from the SUDS folders and tried again.

So I started with D:\temp\First Tutorial.sud, loaded it into the Creator and clicked the Make a Distribution icon and targeted the output at that folder. This resulted in


First Tutorial.sud


No files under the SUDS folder tree were created or modified.

Now here is the interesting thing. If I start again, having deleted all those files apart from the .sud file, I can double click that file and the Player runs, and then the game can be played. If I then exit the game without saving, I still only have that one file. So all those other files are irrelevant to distributing the game!

It seems like “Make Distribution” doesn’t actually make a distribution! Maybe it was a work in progress that was never finished. What would I have expected? Well as with any other system I would have expected an exe file to be created which combined the Player and my game. That would give an exe which could only play my game.

Oh well, thanks for the help, but that function looks like a dead end to me now.

When a file is copied, the Last Modified date of the copy won’t necessarily be newer than that of the original.

For me, all the files I listed above are in the directory to which I directed the Make Distribution output (which wasn’t the same directory as the installation directory).

It can be played by you, on your machine, on which you’ve installed SUDS!

My understanding (based on a very brief play with the SUDS system) is that those “other files” (together with the .sop and .xml file) are the distribution!

That doesn’t seem to be the approach that SUDS takes.

The exe that’s created (or copied) is SUDS_P.exe. Your game is in the file sud.xml or perhaps initial.sop – one of the two.

I wonder if the problem is that the version of Windows you’re using needs SUDS to be run in some sort of Compatibility Mode?


Er, no. There was only one instance of the Player and that is the original installation file dated 2007. No new exe was ever created.

Other games do not have any other distribution files with them, they just play.

I tried using the compatibility trouble shooter and tried again using settings for XP SP3. That appeared to make a difference in that a Player now turned up in the target directory. Yee hah! However, running a binary comparison with the default player showed that the files were identical, as was further shown by the fact that that Player was not specific but could run other games as normal.

I also took just the default player and a game, no other files, to another PC which has never had SUDS on it. Played perfectly. The other files were created as a result of playing, so were not necessary to start playing the game with.

Having played around some more, the only way in which those other files change anything for the user is that they make the Player choose my game by default to start with, but that only lasts until I play some other game. Also, they pre-set the preferences to my ones, but again that doesn’t last. Which seems not much effect for such big files. I can only presume they assist with loading speed, but once you’ve played another game they refer to the latest game.

So yeah thanks for mentioning compatibility settings. You could have saved yourself some time and just said that as it turns out!

I now conclude that, with the right compatibility settings, some sort of distribution set is made, but it is not permanently tied to your specific game as one might have hoped.

BTW, the Player appears to need no installation, which helps.