World Index images broken in Inform 7

I don’t know if anyone can help me, but I just installed Inform 7 and the World index map is showing red X icons for all of the images. The right-click properties for these list a png image name (ew_spacer.png for example) and then these properties:

protocol: Unknown protocol
Type: not available
Address (URL): inform:/map_icons/ew_spacer.png
size: not available
Dimensions 28x30
created: not available
modified: not available

Other images include help.png, below.png and others:


I’m running this on Windows 7 x64.

As far as I can tell, everything else is working. Images on the menu bar are okay, the Skein icons work, etc.

Any ideas what could cause the failure?


This usually happens when Inform 7 can’t find the images it needs or the relevant images are in the wrong directory. I’m guessing that Inform 7 didn’t install correctly. You may want to try reinstalling it. Another thing that comes to mind is whether the version you installed is a 64-bit version.

Hope this helps.

The only bug report I’ve had like this was from someone who had installed Inform 7 on a networked drive, and IE’s security settings prevented it reading the images. Where did you install it?

I’ve installed it to the default folder: c:\program files (x86)…
and to c:\Inform7… <-- with this folder, I specifically ran the installer from a “Run as administrator”, even though I’m an admin on this machine. I also reset that folder’s permissions to grant me full control, not just modify rights.

Same result in both. From all of the “Index” area images, not just World, it turns out.

So the program files and the .png images it is pulling are NOT on a network drive. But my “My Documents” folder – and therefore the Inform\Projects etc. folders – ARE on a network drive.

If moving that MY Documents\Inform… folder tree to the local drive can be done, I’m happy to do it. But I don’t know where to tell Inform7 that the files are not at the default location. Registry? .ini setting?

And thank you for your help!

IE is not my default web browser, if that makes any difference. Chrome is my default.

Having “My Documents” on a network drive doesn’t matter, and having Chrome as the default browser won’t matter either: IE is always used to render the HTML content in Inform 7 (such as the Index pages). You’ve not made any changes to IE’s security settings, have you? That shouldn’t make a difference, but you never know with IE …

I assume you’re using the latest Inform 7 (6G60)? And that if you look in the “Documentation/map_icons” directory under the installation directory, there are lots of PNG files, all of which you can display correctly by double clicking on them?

If the answers are both “yes”, and you’re prepared to try some test builds to debug, drop me an email (my email address is in the BugReport.txt file in the installation directory) and we’ll take it from there.

Yes, the png files are all present and open.
I’m not sure what the default png viewer is in Win 7. I tend to muck about in such things more than is “healthy” perhaps. If I try to view the images by making IE the default, IE tries to download them rather than view them. They open in Windows Photo Viewer and several others. Changing between 2 or 3 MS products and Photoshop as the default viewer didn’t change Inform’s behavior. IE is up to date. I saw another thread here that mentioned Apple’s Quicktime. I don’t have that installed.

Yes, I’m using the latest build; just downloaded it Thursday.

I’ll email you on Tuesday.

Thank you!

“Unknown protocol” implies that the inform: URL isn’t bring properly handed off to the app, so it isn’t getting as far as loading the PNG.

Try doing the install without doing the run as administrator option.

I’ve been thinking about this and going back over old emails to see if any similar problems have shown up, and I can’t help wondering if this is somehow the cause of the problem, after all.

Although Inform7 by default offers to save projects under “My Documents/Inform/Projects” you don’t have to save them there. If you save the project to a local drive, close and restart and rebuild the project saved to the local drive, does that make any difference? (I’ve just tried having a project on a network drive here and it seems to work okay, but with network issues you can never be sure…)