Workaround for crash when creating a project?


#1

I’ve been cooking up a work of IF in a homebrew system (because I have a bad case of NIH Syndrome), but I’ve decided I should try out the mainstream authoring systems. I’ve played a bit with Inform 7 and now I’m looking at TADS 3.

Working through the first few steps in the TADS 3 Quick Start Guide, I clicked Create! on the new project wizard, and TADS Workbench crashed. I poked around and found the exact symptoms in this bug report: bugdb.tads.org/view.php?id=243

Since that report has been around for quite a while, I figure there must be some way to work around the problem. Any clues for a newbie?


(Jim Aikin) #2

I just tried creating a new project. No problem. I’m using Workbench HT-24, Build Win121, TADS 3.1.3. Running in Windows 7 Pro.

In your description of the crash, and indeed in the description in that old bug report, there’s no indication of which type of project you were trying to create – Introductory, adv3lite, plain T3, etc.

Have you tried creating a different type of project? What OS are you running? Are you using the current version of Workbench?


(Emily Boegheim) #3

Belated reply - I know that Workbench will crash when creating a new project when the Description field is left blank (bugdb.tads.org/view.php?id=214). Could that be your problem here? If so, just leave the default project description in place while going through the New Project wizard and delete or change it later on.