Vorple by Juhana Leinonen

Yeah, it’s not included by default but there shouldn’t be any problems adding it separately.

That, and also because everything can now be minified into one file, and also because if the CDN ever goes away it’ll break the games.

It’s been discussed, but ultimately it’s up to the people who maintain the IDEs. I wouldn’t expect it to happen in the nearest future.


I notice that the html code for an adventure still contains the supporting directory structure:

vorple.media.defaults.swfPath = ‘interpreter/’;
vorple.media.defaults.audioPath = ‘.’;
vorple.media.defaults.imagePath = ‘.’;
vorple.media.defaults.musicPath = ‘.’;
vorple.media.defaults.videoPath = ‘.’;

This seems to be an artefact of the original Vorple and one that I really think makes good sense.
I remember that you had noted that you planned to set it up per the original documentation at some point.
I know I can modify the master copy on my computer to implement it as you intended,
The question is whether I should do that or has there been some change in philosophy that means it will eventually be removed.

No, that’s very much intentional. Inform places all resource files to the same directory so Vorple must be instructed to look for them in the current directory (denoted by the period).


Did you ever get the chance to look into the issue with Vorple not working on Safari, unless the dev tools are open?
My reason is that the Safari Web Inspector is rather useful in setting up/debugging style-sheets on a Mac and the issue prevents me form using it.
(Haven’t yet found a good wysiwyg CSS editor for the Mac that doesn’t totally deplete my software “budget”. Do you happen to know of good one?)

If it’s a patch that I can make, or I need to do something differently, please let me know.

No luck yet, but if you can fix or even find where the problem is I’d be glad to accept any info.


I tried to get it to load as you noted, but it doesn’t allow me to get past the “Loading…” message.
Could you go over how you got it to go past that point and what version of Safari you were using.
I don’t mind doing the forensic investigation, but it’s easier to do if I can get it to work as well as break.

Juhana and Dannii;

I believe that the issue of Version 7.0.5 (9537.77.4) “hanging” on starting a Vorple game lies in the parchment initialization code and not in Vorple.

I made the following “bare” test adventure:

[code]“Safari Test” by Gary Gauthier

Release along with the “Vorple” interpreter.
Include Vorple by Juhana Leinonen.
Include Vorple Hyperlinks by Juhana Leinonen.
Include Vorple Multimedia by Juhana Leinonen.
Include Vorple Notifications by Juhana Leinonen.
Include Vorple Screen Effects by Juhana Leinonen.
Include Vorple Tooltips by Juhana Leinonen.

Example Location is a room. [/code]

Then I tried commenting out various lines in the resulting “play.html”, until it stopped hanging Safari and I could get the Developer tools in Safari to run. The only line that needed to be commented out was the call to “parchment.init();”, which seems to indicate that this might be where the issue lies. I don’t know enough about parchment internals, at the moment, to take this much further. Perhaps, Dannii, you may have some ideas?

You don’t get the same problem with the Parchment interpreter rather than Vorple?

I don’t get the same hanging when I run the adventure within the new Inform7 IDE.

It seems to be only when I attempt to run the web-based adventure. When I do that, I find that commenting out the parchment init call allows me to initiate the developer toolset in Safari. That implies that the commenting out of the call to the parchment initialization somehow avoided the hanging of Safari v7. That doesn’t necessarily mean parchment is the cause.

I did post a link to a test of the new Inform7/Vorple for Juhana to try. I believe Juhana said that Safari hung unless the developers tools were open. That would imply that the issue is present even when running across the web.

I’m just going to find that link and post it for you.

(By the way, I have resolved the dialog button issue noted in the same post, so actual Vorple functions seem to run cleanly once one is up and running.)


In the following quote is a link to a test framework that I put together for Vorple and the new Inform7. It doesn’t contain a real adventure. It was intended to be just enough to demonstrate what one could do with the latest version. I can arrange to post source, if you’d like, but the link should allow you to see what happens under different browsers.


I tried running it with the “Web Inspector” open (as Juhana had done), when I initiated the link to play it in the browser. It was a bit slow to start up, but it did load in Safari v7, BUT only when the “Web Inspector” was open. I also noted that the web inspector showed that the dropbox site seemed to have added some .js code that has no place in the adventure. Note that previous dropbox hosted adventures on the older version platform were also reported to be a bit unpredictable with Safari.

This is getting stranger by the minute…

Any ideas???

I’m on linux and I’ve put the latest (extracted) vorple-inform7-template.zip into ~/Inform/Templates

With Inform 6G60 I could use the Vorple interpreter, but now with 6L it says:
“On this Release, I tried to use the ‘vorple’ template, but couldn’t find a copy of it anywhere.”

Where am I supposed to extract it?

[edit] Ok I found it: I wrote “vorple” instead of “Vorple”, now it’s working. Also we can put the template into game.materials/Templates

Btw, my z8 game is 490 kb, so it’s close to the z8 limit. Will Vorple soon be available for glulx as well?

Not soon.

I feel like whenever I encounter this level of failure googling something, it usually means the answer is incredibly obvious, but where would today’s modern woman save a .js file if she wanted Inform to find it and stop throwing errors?

ETA: If the answer is “right there bare naked in the materials folder,” then I’ve got a different problem of some kind.
EATA: Never mind, I am having a different problem of this kind.

I didn’t find any notice here yet, so I’ll like to ask: has anyone tried to make Vorple work with (older) I6 projects? Is it possible? I’ve played around with it, but did encounter some “communication” problem between z-machine and vorple. I think it has something to do with the vorple startup routine, but since there is no way to debug, I can only guess.

I tried to use vorple, but without sucess.

"Vorple 1" by sarganar

Include Vorple by Juhana Leinonen.
Release along with the "vorple" interpreter.

Hall is a room. "Hello man."[/code]

The story compiles fine inside the IDE. But the online game produced by Release button never load in my Chrome (ver. 40). I use win I7 over a win7.

The Chrome javascript console sets:
[code]Invalid JavaScript: vorple.parser.setVorpleStory()                    interpreter/zvm.min.js:13 
Uncaught TypeError: Cannot read property 'length' of undefined 
Uncaught TypeError: Cannot read property 'top' of null                      vorple.min.js:37 

Any idea?

I think Vorple is supposed to be capitalized when you’re using it as the interpreter name. I could imagine a scenario where it would crash if you don’t do that, not sure if it’s actually the problem.

I have my own issues- I opened a github issue about it, but does anyone even know if Vorple is being actively developed?

Here’s my story-


Include Vorple Multimedia by Juhana Leinonen.
Include Vorple by Juhana Leinonen.
Include Vorple Tooltips by Juhana Leinonen.
Include Vorple Hyperlinks by Juhana Leinonen.
Include Vorple Notifications by Juhana Leinonen.
Include Vorple Screen Effects by Juhana Leinonen.
Release along with the “Vorple” interpreter.

An Open Field is a room. "Nearby is a small cave. The muddy earth slopes downward toward a cliff to the south. To the east, there is a forest, and beyond that, a massive castle.

Use the command ‘win’ to end the game."

Winning is an action applying to nothing. Understand “win” as winning.
After winning:
say “Pausing…”;
pause the game.

When I run the win command in Chrome 40.0.2214.111 m, I receive a JavaScript error: Uncaught TypeError: Cannot read property ‘split’ of undefined.

Does anyone have an idea for a workaround or know what I can do about this? Is there a vorple alternative that gets me all the same stuff but is being maintained?

Thanks for the report, but unfortunately I’m not able to diagnose or fix the problem right now; hopefully someone else can find a workaround.

I’ve got an error trying to compile a test of the tooltips extension.

I’ve got this;

Include Vorple Tooltips by Juhana Leinonen.
Release along with the “Vorple” interpreter.

Instead of examining the rucksack when the rucksack is open:
say "Inside the ";
place an element called “rucksack-open” reading “rucksack”;
say “is an old flask which is filled to the brim with water”;
display a tooltip “You’ll need something to carry your stuff in” on the element “rucksack-closed” in 2 seconds;
say “.”;

And the error that comes back is this;

You wrote ‘place an element called “rucksack-open” reading “rucksack”’ : but this is a phrase which I don’t recognise, possibly because it is one you meant to define but never got round to, or because the wording is wrong (see the Phrasebook section of the Index to check). Alternatively, it may be that the text immediately previous to this was a definition whose ending, normally a full stop, is missing?

Any ideas? The vorpal extensions are loaded and I’ve tried adding them from the public library and manually.


There’s an error in the documentation, that line should be

place an inline element called "rucksack-open" reading "rucksack";

(Also note that you create an element called “rucksack-open” and try to add a tooltip to an element called “rucksack-closed”.)