Viv Dunstan's IFComp 2023 reviews and musings

We All Fall Together by Camron Gonzalez

This Texture piece sees you fall through a long fall, encounter other characters, and reflect on your life.

It’s an atmospheric setting, but often I was frustrated with the lack of control re what I could do. For example at one point there’s another character who appears, but I wasn’t given the chance to interact with them at all, and could only think about stuff. I wish the story and interaction possibilities had been fleshed out more. There were so many other things it could have responded to.

Ultimately the story seems fixed in its destination, it’s just a matter of how you get there. Though as reading I was thinking more of it as a metaphor for life in general, which was an interesting thought. Thanks to the author for conjuring that for me.

There are quite a lot of typos. Here are some I spotted, in case the author wants to fix them:


“Reach to high” should be “Reach too high”
“You’re turn to tell me something” should be “Your turn to tell me something”
“Do it for you sky diving buddy” should be “Do it for your sky diving buddy”
“you’re sky diving buddy” should be “you sky diving buddy”
“my hearts beating” should be “my heart’s beating”


20 Exchange Place by Sol FC

This is a tight hostage negotiation choice piece written in Ink.

First thoughts are there’s a lot more text than for the estimated 15 minutes or less play time. I read very quickly, and estimate the play time as at least double that, possibly up to an hour. However the text is well written, and gripping, and well worth reading.

Next thought: I’d make a rubbish hostage negotiator in real life! I’m sure there’s a good ending or two to find in here somewhere. But safe to say I didn’t find one, despite replaying several times. However the fact that I wanted to replay shows how well written it is. And how rubbish I am at the set task!

A good - if extremely hard to win - piece, but definitely budget for a significantly longer play time than stated on the competition site. And don’t be surprised if things don’t go well.


Put Your Hand Inside The Puppet Head by The Hungry Reader

This is a rather wacky Twine choice piece, where you set out on a daring mission to recover lots of puppet figures, before the studio where they were used to make programmes is destroyed. Note I played for about an hour (there’s no time guide on the competition website), including replaying a view bits from saved files.

I liked a lot about this. You are on an abondoned studio lot, split into four sections, and you have to explore each one, including figuring out how to gain access, while dodging scary monsters that are after you. It was really quite spooky. The author in the notes at the start describes it as a bit like Pac-man in these bits. Though to be honest it felt more like Hunt the Wumpus (or rather Avoid the Wumpus!), very IF appropriate.

Your goal is to collect and save as many puppet characters as possible. Each one when you put your hand in it to rescue it responds with a unique character. It was quite hard to put the puppets down safely in the getaway van for safety. The puppets can help you in situations, but carrying a puppet near the monster is risky. I took a pretty low risk strategy of whisking them to safety as soon as possible. And saving a lot.

I didn’t manage to rescue all the puppets, especially in the last quarter segment of the game, where I couldn’t get past a puzzle (getting the light on in the final setting). I also seemed to run into a bug mid game - but not a killer one - that I’ll detail in the spoiler text at the end for the author.

But otherwise I really enjoyed this. I also liked the nicely written epilogue (note: I didn’t see some stuff other reviewers mentioned, but I don’t think I unlocked the relevant part of the game i.e. didn’t rescue the relevant puppet). I feel as though I’ve had a real adventure, high stakes, and did good. Thanks to the author.

Bug notes for the author:


The main bug I spotted was when I tried to get Mince back who I’d lost. This is what appeared on screen:

From that point onwards the overall count of puppets I’d rescued included Mince, but he wasn’t properly listed on his stand.

I also noticed a minor bug later on: “You leave this key in the glove compartment. You have 1 keys left on the ring.” It really should say “1 key” if you have just one there.

Oh and I occasionally ran into a bug where I’d be in a location and it wouldn’t be showing me any options to move, even back to where I’d been. It would just say a description, and then show the inventory text. That was potentially a bit of a killer, though clicking back/undo would usually mean I could keep playing.


Just over a week through my playing I’ve already played, judged and reviewed 10 games. Am pleased with that given I’ve been recovering from Covid and also dealing with my ongoing neuro illness. I’m not going to reveal individual public scores, but so far I’m averaging 5.8/10 in my ratings. Haven’t quite reached the absolute heights of my scores yet, but some strong ones.

I’m also pleased that although I’ve been using my initial list of games to try as a starting prompt I’ve also been lurching rather unpredictably towards other games. This is helping keep the variety good. I am also having a great time as a player.

I will be continuing, hoping to reach 20+ reviews in the end. But in the meantime I want to thank all the authors. And also my fellow reviewers. After I’ve finished a game and usually after I’ve entered my own score in the system I always like reading other people’s thoughts on the games. Often we agree on things, often others pick up on different things. But it adds to the fun for me as a reviewer. And makes me encouraged to keep reviewing too.

Ever onwards, and we’ll see where I get to in the coming weeks.


Last Valentine’s Day by Daniel Gao

This Twine piece sees you reliving the same Valentine’s Day over and over again, repeating the time you find your partner has left you, and trying to change things.

I’m going to be honest and say that I wasn’t sure what was happening. For example was this in the player’s mind as they repeated, or a literal time loop, or a mix of the two. I’d favour the former, and it being a case of coming to terms with their life.

I certainly found most peace in the game as I engaged more with the world around me, rather than rushing home to get there in time. The little vignettes of life that you encounter around were fascinating, and intriguing how they altered between loops.

One thing I found frustrating was how you would often only see part of a message from the partner who leaves. That message also changes. The incomplete picture made it hard for me to understand them, and what had happened. it felt like a selfish view of the world from the player’s perspective. Which of course everything boils down to in the end. But for a game where loss of another person is so fundamental I felt that person was too far out of reach, not defined well enough. Equally though that was also rather poetic, as the player struggles to attain a new sense of self.

So yup, not quite sure what was happening. I often miss allusions and metaphors, and benefit from things being spelled out plainly. But the writing was otherwise strong, and I found it quite a moving piece. Though something was still just frustratingly out of reach.


Assembly by Ben Kirwin

This is a really creative parser game, clearly IKEA inspired, that sees you fight dangerous foes with only the power of flat pack furniture. It’s a very amusing concept and largely well realised. If you’re flat pack phobic avoid this game, but for everyone else it is a lot of fun, with some neat puzzles.

However there are some downsides for me. Early on you see quite a lot of items of flat pack furniture, with their descriptions. I did not take proper notes at this point, and you need to remember what the names represent visually later. Take notes folks!

The other downside is there were some disambiguation issues, not least between flat pack assembly instruction booklets and the flat pack items. I had a particularly difficult time at one point trying to physically manage the parts of a flat pack item.

The game is also lacking other characters largely, apart from some rather anonymous ones. And that’s a slight shame. Though there are plenty of flat pack items to interact with.

The ending also feels a bit abrupt. It has a big build up, but then, well, it’s over in a flash. As a player I’d have appreciated some kind of epilogue, or notes on amusing things to try, or author notes. Something for me to decompress with.

In a nutshell this a great game, but one that could have been made a little smoother to play. But a really neat concept, and entertaining. Thank you.

Notes for the author:


It was picking up the hinder parts that I really struggled with e.g. “GET HINDER” or “GET HINDER PARTS” didn’t work. But “GET ALL” did thankfully.

Also I didn’t realise WILLIAM was accessible - it’s only mentioned in the room description as being in the lower drawer. Not when you examine or search the lower drawer.


Dr Ludwig and the Devil by SV Linwood

This is a comedy parser game of a pact with the Devil, written very much in the style of Hammer horror movies of the past.

This was enormous fun. The game is well implemented, both parser responses and rich objects and locations you can interact with. There’s a helpful grimoire to look things up in, and the conversations - including with the Devil - were coded well.

The puzzles are generally pretty easy, but if you get stuck there are built in hints (which work well) and also a walkthrough.

The game isn’t very long, but feels very rich - like having a big dark chocolate cake or something (hey, I’m veering onto food reviews!). I liked that very much.

Some quick notes for the author:


Thanks for changing the response to UNDO!

I loved the old style writing e.g. “(Editor’s note: Ye author is notte refponsible for any damages caufed by making an ille-conceived deal.)”

Might be nice to add response to THANK X e.g. I wanted to thank the devil, and Hans, and the priest at various times. Might be a nice little character addition.


Dysfluent by Allyson Gray

This is a really thought-provoking Twine piece about speech impediments and specifically stuttering. It puts you in the shoes of a chronic stutterer, trying to get through a busy day, and experiencing lots of problems as a result.

First of all I need to address the timed text issue. It’s used throughout. Timed text is a bit of a nemesis for me. I read really fast, and hate waiting for text to slowly appear on screen. However given some of this timed text was capturing someone struggling to speak and get sounds out I feel guilty for saying I didn’t like it. In fact I think that particular use of it was fine, and appropriate. I just wish that the rest of the game’s text e.g. the descriptive sections in between hadn’t been often timed/slow too. Let people who want to read those quickly.

The story is a mix of the current busy day and flashbacks to younger you. Initially there aren’t many real choices, but later they are more numerous and significant.

Colour coding is used to indicate how approachable different things you might say are. The default colours could have problems for colour blind people. Fortunately there’s a setting at the start of the game that can switch them to a better palette. Though this is still likely to be problematic for someone who can’t actually see any colours. At first I thought showing the colours before you make a choice was revealing too much too early. But then a chronic stutterer probably has a good idea of which phrases might come out most successfully.

Overall I found this really evocative, leaving me with lots of thoughts and a better understanding for what someone in this position experiences. I wonder if it was semi autobiographical. It definitely felt as though the author knew what they were writing about, and communicated the feelings of the stutterer so well.

Note for the author I spotted a typo:


“You struggle for what feels like hours as the interviewer stares expressionlessly, only looking away to takes notes.” - should be “take notes”


Thank you so much for your review of Dysfluent, and for your kind words!

I very much appreciate that you gave the game a chance even though it has a mechanic you’re not fond of; I’m processing all the feedback I get in hopes of finding a better balance for it in the post-comp version!

The “total colourblindness” issue is an excellent point, too – I had a solution in mind for that, but unfortunately I didn’t manage to implement it before the deadline… that will definitely make it into a future version too, along with (hopefully) a mode that’s compatible with screen readers.

It really warms my heart to read that the experience was informative and thought-provoking! Without going into too much detail, there are indeed aspects of the game that are drawn from real life, and I’m so glad that I was able to convey these thoughts and emotions.

(Thanks a lot for pointing out the typo, it should be fixed now!)


Milliways: the Restaurant at the End of the Universe by Max Fog

Ok my longest game played yet in the competition. This is an old style parser game, that’s a direct sequel to Infocom’s Hitchhiker’s Guide to the Galaxy game, which I know well. I’m not sure how well this game would work for people unfamiliar with the Hitchhiker’s universe, but would be interested to hear!

I played for two hours and nearly got to the end, but ran into a bug with an object that kept disappearing (the heatproof tray has a horrible habit of disappearing at times after you’ve got it) so couldn’t finish it. The game has some bugs, over and above it being traditional old style. To be fair it would be an almighty task for playtesters to work through thoroughly! And I do admire how so much has been coded by a modern author in ZIL. I’m going to include some notes for the author at the end.

However … I was wowed by the imagination, and the use of Hitchhiker’s locations, and characters, and jokes. And I just had a very happy two hours of play time. Again I’m not sure how well this would work for someone unfamiliar with the Hitchhiker’s world. But this Hitchhiker’s fan was very happy. I also liked the hub like structure based on a classic Infocom puzzle, which was rather forgiving, albeit with so many more spokes than in the original Infocom game that sometimes it could take you a while to get to where you might need to go next, and you could be cycling through a lot.

The game has a comprehensive walkthrough which I peeked at at times, especially one place where I was ridiculously stuck (the philosophical word), but wanted to play on. And in game hints, which are appreciated. You also have the Guide that you can look things up in mid game, which is a lot of fun, and like Infocom’s game.

I’d like to see a polished version of the game produced in future that irons out some of the bugs and also adds a little better object handling re disambiguation. But this is very good.

This is where I got to score wise:

Your score is 310 of a possible 400, in 835 turns. This gives you the rank of Not Your Ordinary Person.

Notes for the author:


I’m really sorry: I didn’t think to make a transcript. So sorry! But hope these notes help.


Crater Lip
The crater lip continues northeast and southeast here, and below you is a ledge.
>examine ledge
[You can't see any ledge right here.]
>go ledge
[You can't see any ledge right here.]
  • that sort of thing is a little exasperating!


In the gargle blaster puzzle I had real problems with the heatproof tray vanishing after I’d taken it. That also happened at the very end of the game, for no apparent reason. Also with the cupboards I would often be unable to take something after I’d put something in. Though some of those may have been me struggling to get the exact words needed to refer to something for the parser to recognise what I was wanting.


This appeared mid game:

>give blaster to idiot
[Which blaster do you mean, the quantity of pan galactic gargle blaster in the wine glass, [FOO!! Bug #02!], or the bottle of Pan Galactic Gargle Blaster?]

I spent ages trying to give the wine glass to the idiot in the Dining Area. It didn’t occur to me for ages to try giving it to him in a different location.


The junction leads off randomly in different directions. If you want to exit, you can go in one of in the four cardinal directions.

  • typo: should be “one of the four”


(in the room with all the coloured buttons)

>press red
[You can't see any red right here.]
>press red button
Nothing happens.
  • would be nice if could just type former


>give blue frob
You can't give the blue frob to a blue frob!
>give blue frob to slartibartfast
"Of course. The blue frob - although you will need to find its true form for it to work."
  • Slarti’s the only other person in the room. Would be nice if GIVE X defaulted to him.


Putting the blue test tube in the rack was a bit excruciating. The game should support PUT BLUE TEST TUBE IN RACK as well as ON RACK - the former tells you it’s full.

>put blue test tube in rack
You search for an opening in the rack of tubes but find none.
>put blue test tube on rack


>swim east
Did you have a direction in mind?
You head east, then south briefly, and finally a short while to the west.
  • mmm …


absolutely had no idea about the magic word!
had to use the walkthrough



Time passes...
The top line of the computer apears with the text: - should be appears



>search zaphod
I don't thinkhe  would appreciate that.s
  • also ditto for Ford and Trillian


“OOPS!” yells Clyde as he trips over his own leg and sits directly on the microchip, smashing it to hundreds of pieces.
Quickly thinking, Clyde dashes all the pieces under the safe. He explains that if a mess was found, he would get in trouble for it.

  • oh i feel bad now! I’m back to thinking of H2G2 robot Colin!


A keychain with a bunch of keys on it, for many different purposes. One is them is allegedly Hotblack Desiato’s, but it would take years to find the right one all by yourself. You count through a few to prove that this is, in fact, true: One… two… three… forty-two … You get the idea.

  • looks like 2 spaces before “prove”

Thanks for the review! It was very hard using ZIL, and hopefully my next game will be less complicated (that cupboard puzzle takes up 1000 lines), but I’m glad you liked it! (How did you get ALL THE WAY?)
If you want I can send you a save file for the finale…


Bali B&B by Felicity_Banks

This is a warm-hearted ChoiceScript coded simulator where you have to temporarily run your grandparents’ B&B in Indonesia, and get through a week of surprises that pop up in the process.

I liked a lot about this. The writing is strong, and I felt immersed in the game world, and also the culture that it was depicting. I don’t know if this is at all autobiographical, but the tale of an Australian grandchild negotiating their relationship with their Balinese roots and grandparents was nicely handled.

There are a lot of choices to make in the game, and I felt in control. Albeit with a lot of jeopardy to contend with. And yes there were cats - thank you again to the author for another year of cat content! The animals in the game were all well written. But so were the humans, and you have to negotiate your way through lots of interactions, not least with the B&B’s guests.

I was relieved to make it to the end of the week in just about one piece, and very much enjoyed the experience. I now want to read more about Balinese culture and society. So that’s good.

I have some notes for the author re a few things I spotted.

notes for author

At the start it says:

Play "Bali B&B" (latest version).
Play "Bali B&B" (version submitted to IF Comp)

I selected the 1st one, and it took me to

Click here to switch to the latest version of the game (which looks identical to this but is vastly superior, honest).

Erm?! I did then click on that link. I wanted to play the latest version, as I’d asked. I also retried the original choice and got the same result.


There is a feral calico cat in your oven, and some misshapen wriggly things that are presumably a pack of newborn kittens. Or really big, furry maggots. Eu de cat urine fills the air.

  • Is that a typo and should be “eau”?


I wanted to read the author notes and development diary after the game but there’s no link there to let you do that. I had to restart to get a link to see that. Please add a link at the end. It’s the perfect place and I won’t be the only player who wants to read it then. Thanks!


In The Details by M.A. Shannon

This Texture piece sees you as rather a jaded musician who’s got secrets and finds that things are catching up with you as you go to make another performance.

I liked the core setup, and what you uncover about your past. But it didn’t feel as though I was in control enough, or had enough agency. There’s one particular point where you are offered two choices, and I wanted to choose one, but the game wouldn’t let me make that choice, even as I try dragging the verb word over the highlighted noun. It just wouldn’t register that option. I’m assuming this is a deliberate choice by the author, to force you to take the other approach instead. But it was frustrating.

Shortly after that section you have a two-way choice, one of which leads to a sudden game end, where you need to restart and replay to try again if you want to. The other choice leads to a slightly longer bit, but then ends abruptly with “To Be Continued”. Which felt like a very abrupt ending, and felt too unfinished.

So problems with choice/agency, and a feeling of being unfinished. I think this could be smoothed with more work. There’s a good idea there, but it’s not polished enough.

Also minor-ish point, but every time the game referred to “crewmember” (or “crewmembers”) I kept wishing it was two words with a space.


I am glad this is finding a warm reception around the review-sphere, it is SO well written my inability to connect looms larger and larger as a fundamental character flaw.

Unrelated, I am getting the sense I may be the only player that let animal control deal with the infestation.



Thank you so much for spending time and effort reviewing my game. I am choosing not to make any specific comments about reviews until after the comp, but I assure you that I am grateful for any and all comments, which are so useful in improving my game and future games.


Creative Cooking by dott. Piergiorgio

I wasn’t sure I’d be able to run this parser game. The competition listing gives no clues re interpreters etc. The game file is AGT format. But luckily Gargoyle and Spatterlight on my Mac will run it. Gargoyle coped best with visual layout, so I used that.

This is a very short game, nowhere near the hour and a half playtime suggested on the competition site listing. You have to gather a set of ingredients to cook with, and that’s it. They’re not hard to get, and it’s nice to get to the end. I would like to see the game finished. This is very much just a taster - an “amuse bouche”! - for the planned full story.

However the game is plagued by unimplemented objects that are referred to in the description. And that makes it quite frustrating to play. For example in my second location as I started to play I had this experience:

> w

My bedroom
My bedroom, with its large, welcoming double-bed (welcoming not only 
for me, that is...) is against the west wall, and a round table is in the 
centre. Two doors lead east back to my lab and west to the backyard, 
and stairs lead down to my closet.

> examine bed
I don’t understand the word ‘bed’ as a noun.

> examine table
I don’t understand the word ‘table’ as a noun.

The same thing applies elsewhere, far too often. For the author please implement objects like this. Even if they aren’t necessary to complete a game on a simple run through some players will try interacting with them. And it breaks the player immersion when you can’t.

In another location I had a similar problem:

The garden, which is also the common green, is not only where the 
zarnest trees are, it is where the people relax; there are many benches. I 
can only return south to the upper plaza.

> examine benches
I don’t understand the word ‘benches’ as a noun.

> sit
I don’t understand ‘sit’ as a verb.

Fair enough maybe that it didn’t understand SIT, though can it be added in game? But the benches are right there, and I’d maybe like to do something with them.

There’s a more serious problem with one object that you need to do something to after you get it. I’m going to put this in spoiler text. You have to soak the yardvine in water in the pond. I tried SOAK YARDVINE, PUT YARDVINE IN POND (or WATER) [either gets response “I can’t move the blue yardvine.”] and DROP YARDVINE. No good. Only THROW YARDVINE seems to work, which to be fair is in the walkthrough, but wasn’t intuitive.

The fantasy world setting is intriguing, and I was happy exploring it. The author is clearly putting effort into developing the ideas behind it. But constantly being unable to interact more with elements was very frustrating. Please, please in the full version of this game flesh out the objects in locations more. People will try EXAMINE X where X is lots of different things. And if you can support this it can make for a much better player experience.

So yup, folks may be like me initially thinking they can’t run the game, but very possibly can. It’s a short, simple game. But needs a much fuller implementation. And I don’t think that’s a problem of the Magx system, but just more author coding that was needed.


One Does Not Simply Fry by Stewart C Baker and James Beamon

This ChoiceScript piece is a simulation of a cooking competition, that’s seriously inspired by Lord of the Rings, but is slightly twisted sideways. So eg you have a fellow competitor called Sour Ron, you can play Froyo with life partner Samfool, and so on. The writing is really funny, and I enjoyed playing through, including picking which mix of ingredients to go, and how to balance cooking and interaction with fellow competitors.

However the balance between volume of text early on and interaction wasn’t good for me. There was far too much of essentially reading masses, then clicking “next” or equivalent. Then repeat. There are significant choices to make later, but early on was a bit much. And even when I replayed - which I wanted to do - and played quickly, and was able to skip the intro (thanks authors!) there was still an awful lot of early text to wade through.

So I don’t think the balance was quite right. But it was very funny, and I enjoyed it. It definitely merits replaying. It will work best for people who know Lord of the Rings (either book or film versions) and also competitions like Great British Bake Off. I just wish the balance had been tweaked a bit more.


Oh no! :cry: If you feel like elaborating on this, I’ll make sure to improve things in Spatterlight.

1 Like

I only tried them both with the opening intro where the layout in my admittedly old version of Spatterlight wasn’t quite so good. See the screen shots below. Gargoyle first.


Gargoyle pic:

Spatterlight pic:

That is running Spatterlight 0.5.14b on my Mac. However I’m about to try downloading a newer version and see if that’s better. Thanks for the prompt :slight_smile: And actually looking at those screen shots now it’s really not that much difference. I think it’s more a question of my window sizes and also the better matching centred text portions etc. But will go peek. It jumped out as much more different to me earlier this morning!

1 Like

Thanks for the swift reply! I realise that these things are alway going to be a matter of taste, but your comment made me curious, so I couldn’t help myself.