Victor's Variomatic #4: "Scroll Thief" by Daniel M. Stelzer

Victor’s Variomatic is an ongoing series of… well, of invitations, really, invitations to play works of IF together. I make a post proclaiming that I will attempt a certain game and everyone who wants to join is is most heartily encouraged to do so. We’ll post about our progress or our thoughts in the comments. If the game is difficult, we try to help each other out instead of using hints. Once the game is finished, we discuss what we did and did not like. The topics will remain open, so you can join in immediately or connect with prior players years later – though, of course, the first of those two options would be a lot more fun.

For this fourth instalment, I have chosen Daniel M. Stelzer’s Scroll Thief, a game that did well in the 2014 IntroComp and has been released as a finished product just a few days ago. It is a big game (the source code is almost 70k words) and it should be filled with Infocom-style puzzles (it bills itself as a spiritual heir to the Enchanter series). So let’s give Daniel’s offering the attention it deserves; and please help me when I get stuck, which I feel pretty sure is going to happen! :slight_smile:

You can get the game here.

I’m enjoying myself! Very good implementation. Current score: 8 out of 100.

I can get the silver key, but wondering whether I should do something about the rusty key first.

I’ve gotten a fair way in – I’ve reached Act 2 and am in the cavern area.

Now I’m stuck. The hint site refers to spells that I don’t have, which leaves me out of ideas.

I seem to need one of VAXUM, JINDAK, or VHELAS.

I’m still in the library, now with 32 points. These are my tasks:

[spoiler]You are currently contemplating the following problems:

  • acquiring a number of spells—thirteen, say—and escaping
  • descending the staircase in the Research Room[/spoiler]
    Slightly out of ideas right now, but I’ll return to the problems tomorrow.

Oops, that’s an oversight on my part in preparing the hints (it should point you toward the puzzle to get one of those spells). Should be fixed now.

(Waiting a bit for the new version. Inform save compatibility is a pain in the ass, though an understandable one.)

The autopilot is available again in this version, which might help to some extent–you can have the game ‘fly on autopilot’ to a later point, giving all the necessary commands for you. (E.g. “autopilot to checkpoint act two” on the first turn will play through Act 1 automatically and drop you at the start of Act 2.) But it’s no replacement for true save compatibility, alas, and there are too many variables in this game for the “write to an external text file” method to be feasible. It might also solve the puzzles in a different order than you did, and thus not put the game in exactly the same state you had it.

So I played this for a while, got stuck, downloaded what I believe is the latest release (Release 2 / Serial number 150815
), played through to my stuck point again… and I’m at a bit of a loss again. And the hint system is confusing me further. I’m at a measly 23 points and there are definitely some things I managed to do in the introcomp version that I can’t figure out how to do now.

My current tasks and spells are

[spoiler]You are currently contemplating the following problems:

  • acquiring a number of spells—twelve, say—and escaping

  • getting a palantir into the Clean Room

  • opening the wooden door to the southeast of the Antechamber

  • figuring out where the objects in the closet went

    GNUSTO: write a magic spell into a spellbook
    FROTZ: cause something to give off light
    BLORB: safely protect a small object as though in a strongbox
    NITFOL: converse with beasts in their own tongue
    REZROV: open even locked or enchanted objects
    LESOCH: cause a gust of wind

and I have access to the purple tome and de evocatio, so I can also in some circumstances do ZIFMIA, VEZZA, SERAGE, and YOMIN.[/spoiler]

As far as I can tell, what I need to do to accomplish these are

[spoiler]- acquiring a number of spells—twelve, say—and escaping - dunno. This sounds like a long-term, cumulative task. I don’t know how to find more spellbooks in the Main Stacks, if there is in fact a way to do this. I cast LESOCH in there a few times and knocked all the named books off the stacks, but this also destroyed my access to the Encyclopedia Frobozzica, so I restored a save to get back to before that point.

  • getting a palantir into the Clean Room - I recall from the introcomp game that this involved a vent in the closet, and the current hints also seem to point that way. But I can’t get a good view of the clean room; if I follow the hints directive of ADVENTURER, POINT SPHERE SOUTHEAST (or the other suggested syntax about AIM), he doesn’t actually do anything. I can’t command him while he is in the Clean Room, and he always comes back out after one turn. Investigating the closet is not revealing any clues to me. One of the hints says something about a tapestry and Frob, I think? But that confused me and I backed out again. I’ve seen no other references to such a spell nor have I located a tapestry. This might be a red herring in the hints.

  • opening the wooden door to the southeast of the Antechamber - I’ve read about YONK, and I think maybe I could YONK REZROV to either get the transparent sphere or actually force the door open. However, I don’t have a YONK scroll. Maybe that’s what’s in the Clean Room, since there are references to metamagic experiments down there.

  • figuring out where the objects in the closet went - I think I need some metaspell to reverse VEZZA and see the past here. I don’t have such a spell.[/spoiler]

As a totally separate, minor reaction point that may be personal:

I feel uncomfortable about summoning the librarian and having her lie around asleep in her nightgown. I know she’s protected by spells and the game keeps me from doing anything to her, other than the YOMIN to get information. But the situation she’s in, being asleep, half-dressed, and at the mercy of a stranger, makes me feel rather anxious on her behalf, and reminds me of a couple occasions when I felt unsafe because someone turned out to be watching me sleep/have entered my bedroom without my prior knowledge and permission. I’m not saying “this shouldn’t be in the game” or anything like that, but I kept wanting a way to wake her up or give her clothes or send her home or something.

Anyway, that aside, I really like a lot of things about this and would like to become unstuck.

Hm…part of that sounds like a glitch, though I haven’t been able to reproduce it. Sorry about that.

You’re telling the Adventurer to point a palantir through the doors, and it’s not giving any response? Or is it giving a response, just not a useful one?


[spoiler]There is a way to send her home, though it requires a spell from a bit later in the game. (If you leave her there for long enough someone else will eventually intervene on her behalf as well.) There was also originally a way to awaken her, but she would immediately teleport herself away, and then she couldn’t be yomin’d for information. There are alternate solutions which don’t require information from her, but players were frustrated by apparently getting so close to the solution, then having it closed off suddenly.

Based on this, though, I’m adding that back in tonight’s daily build. You still can’t touch her (so ATTACK LIBRARIAN, etc) won’t work, but shouting or otherwise making noise can cause her to wake up. (It doesn’t help directly with the puzzle, since she disappears immediately after and it’s impossible to use vaxum or serage on her, but it’s available.)[/spoiler]

EDIT: New release is out, changing the one thing mentioned in my response to your note. But other than that pretty much nothing has changed so it’s probably not worth breaking your savegames.

I was getting

> adventurer, point sphere southeast
The Adventurer doesn’t respond in any way.

when using the syntax recommended by the hints. This seems to be a disambiguation problem, though, as I was finally able to get a better response (and then a helpful additional syntax hint) from

adventurer, point blue sphere southeast

Something else I tried:

I used YONK REZROV to open the aquarium and have been looking through the transparent sphere. (I keep accidentally calling it the clear sphere even though I know the game doesn’t recognize this…) Then I can open the battered scroll tube with rezrov, but the izyuk spell is too curled up for me to gnusto it. To fix that, I tried to blorb the scroll (which worked) and then to lleps blorb it again (which refused, with a message saying this would cause distressing recursion). I was hoping that lleps blorb would take the blorb strongbox away again, leaving the scroll unfurled and legible on the table.

It also seems like it might be a nice easter egg if

lleps vezza would show you something about the assimilation incident

Oh, another thing (sorry!):

[spoiler]If I nitfol and then vaxum the snake, I get

The snake backs off to let you pass.
“Pass, friend.”

but do not actually move to the next location.

This is still in Release 2 / Serial number 150815.[/spoiler]

Aha, that first one is a bug I’ve run into before (but I thought I had fixed). If the Adventurer is forced to disambiguate, they sometimes just give up and interpret it as an “answering it that” action, which is then blocked…sigh. I’ll see if adding some more disambiguation control rules helps here.

The second one is not intended but that should be a valid solution. (It’s an oversight on my part: I have an “instead of casting blorb at…” rule which doesn’t check properly for the presence of metamagic.)

The third one is probably a “continue the action” missing in one of the rules.

I’ll put all these into the bug tracker and handle them later today.

(Cross-announcing from the other thread since this is where the bugs were reported.) All three are fixed now and a new release is pushed, though I’m worried I might have broken something else subtly in the process–the first involved fiddling around in the parser code to work around a deep-seated but in Disambiguation Control, and I’m not familiar enough with the parser to do that with impunity…