Unexpected file dialog behavior in GNOME version of Inform 7 GUI

I’ve occasionally experienced intermittent strange behavior relating to the project-opening dialog in the GNOME (Linux GUI) port of Inform 7. Occasionally, when I start Inform, the “reopen last project” button is disabled, and when I try to manually open the project, I find that folder names in the file list in the open dialog are also all disabled. Usually, this means that I can’t open a project at all, since though a complete system restart or three seems to fix the problem eventually.

I’ve gone ahead and posted a quick screencast of the problem to illustrate, in case what I’ve just said is unclear: https://youtu.be/tzLWvZX7YXQ

Note that at the end of the screencast, I manage to find a trail of non-disabled folders on which I can click to reach the project and open it. I believe this is the first time that’s happened: normally, on the occasions when I’m seeing this behavior, I can’t manage to usefully interact with the file system in the file-open dialog box at all.

I’m running Linux Mint 19.1 and using the OpenBox window manager in this video, though the problem also occurs when using other window and desktop managers. As you can see in the screencast, Inform isn’t kicking out any error messages to the terminal from which I invoked it.

I am of course happy to provide any other relevant information or to be a guinea pig for debugging purposes.

We’ve discussed this issue a bit here:

There is a way to fix this in the source (I’m not sure why it wasn’t a problem before, but the open dialogue doesn’t (easily) let you open a folder without the .inform extension).

An easier workaround is to go to file system in the open dialogue, press ctr-l and then type in the path of your project.

2 Likes

Ah, that makes sense. Thank you for the quick response! I appreciate your help.