Ultimate Quest (NVidia/Emily Short collab)

You guys. Ultimate Quest was so good.


I hope they leave it up for a long time, but you should probably try to experience it in the next week or whatever.

It’s an Emily Short-written old-school IF (with some new-school design decisions, like limiting the verb set to USE, EXAMINE, ANALYZE, THINK ABOUT, RECYCLE and TWEET). The one downside is you’re pretty much required to spam twitter about a dozen times over the five episodes - but I logged in with a “spare” account I had handy, which has zero followers anyway, so I didn’t bother anyone.

I would say the thing clocked in for me at about 3-5 hours, so it’s a considerably heft game.

If I had to guess, I would say it’s probably running some flavor of Inform under the hood - but that’s just a guess. Unfortunately, the “standard” verbs like SING and JUMP don’t get a response - but that would probably be an unfair red herring to those players not familiar with IF. Same with XYZZY.

Lots of good puzzles, some extraordinarily tricky, some clever, some really nice flavorful writing. You’re missing out if you don’t play it.

The prizes are probably gone by this point, but playing the game is a prize in itself.

-Truthcraze (unaffiliated with NVidia or Emily Short, despite appearances above)

It’s just a Glulx file under the wrapper, yes.

OK, can you talk me back into this? As I said in another thread, I felt relieved when I semi-accidentally wiped out my progress and stopped playing. I enjoyed the opening sequence but increasingly found it a chore.

Here’s some things I didn’t like:

Parser communication problems stemming from the restricted verb set:

[spoiler]Early on, when you get to the roof, I spent an awful long time figuring out how I could go anywhere. Eventually (perhaps after using another body part) I did come across a hint that I would need to use my feet. I typed USE FEET ON ROOF to get to the next part.

But then, when I needed to go down stairs later, I typed USE FEET ON STAIRS because that was how I expected navigation to work. Also USE GECKOSHOES ON STAIRS. Eventually I hit on USE STAIRS, which I might’ve tried earlier if I hadn’t been trained to do something different earlier.[/spoiler]

Occasional failure to communicate goals:

In the roof scene I had thought my goal was to figure out a way to open the skylight before the drone wiped out my health. Only after trying a bunch of things did I examine the drone and get told that I had to find a way to protect myself before I opened the skylight. The method of protecting myself I did not find intuitive – why couldn’t I use the fitcloth to make armored clothing? – and then USE SKYLIGHT to open the skylight seemed, well, cheap as well as non-obvious. I think this would’ve gone better if the puzzle were signposted as protecting yourself from the drone, and then you automatically opened the skylight once you had solved that.

A certain object that I think must have been bugged.

The clawdigger by the gates gave me all sorts of inconsistent messages. I used light on clawdigger to power it up, at least I got a message that it was powered up, but then I could not even come close to get it to work. I tried USE CLAWDIGGER ON GATES, since USE GATES had given me the message “If you’re trying to dig, you’ll need some help” – but that didn’t work. When I tried to combine other things with the CLAWDIGGER (I think that’s also USE?) I usually got the message “You now have CLAWDIGGER,” though the clawdigger wasn’t in my inventory. I think I eventually got through by combining the gecko with the clawdigger and typing USE CLAWDIGGER, but I’m not even sure why that worked.

Something that I’m not even sure if I understood:

On opening the skylight, and on digging for the component, I was given a “This will take a long time are you sure you want to do it?” prompt. As far as I can tell there was no other way to progress at that point. Was I screwing myself over? If not, why was the game trying to prevent me from doing what I needed to? If yes, was there a clue?

That Timed Sequence:

[spoiler]I had the worst time with the bike. For one thing, the game was inconsistent about when time passed; typing USE VELOXE (or whatever) ON CYCLE got a disambiguation-style message about which part I wanted to use it on, and also caused a turn to elapse and got me killed. I understand how this works mechanically in I7, but it was pretty annoying, since I was punished for trying to discover what my options were. And every death led to a multi-undo, where it was very hard to keep track of where I was in the undo sequence unless I went all the way back to the racetrack – partly because the game wasn’t communicating when the clock was ticking.

And again I felt like I wasn’t getting feedback about exactly what problems I needed to be solving; except for the part where you weren’t going fast enough to clear the ramp, the death message wasn’t clear on whether my speed score was too low or I had used too many turns or what. Eventually I got what seemed like a very clear hint that I should stickify my wheels, and doing so gave me a sarcastic message and a death. (Maybe I should’ve made myself sticky boots to go up the walls?) It was at this point when I restarted, because the message made it kind of seem like it might not reset the whole episode; but I guess I knew it probably would, and was more willing to risk that than I was to play guess-the-number-of-undos again. It would’ve been great if death had automatically taken you back to the beginning of the optimization puzzle, and failing that, it would’ve been nice to have a save function.[/spoiler]

Overall I thought this game was an unsuccessful attempt to make the parser more accessible – mostly because restricting the verb set but not the action set recreated the problem where the game doesn’t communicate its affordances, because players will sometimes know what action they want to perform but be unable to express it using the restricted verb set. But everyone else seems to love it. Is it just me? If I fight through this part will I like the rest better? I feel bad trashing this because Emily Short is one of my favorite IF writers, though hopefully the general praise this is getting will soften any blow my criticism might provide, and anyway I will admit to some sour grapes about puzzles I can’t solve.

I played most of the first episode and haven’t gotten back to it. I like the setup, but the interface had a lot of friction. (And I have a lot of work on my schedule this month, obviously.)

I think you’re describing real problems. It’s not that everybody loves it uncritically, it’s just that people differ a lot in how annoyed they get while pushing through (or not).

Sure, there are things that I would have provided feedback for, if I were a playtester. “Use feet on roof” is definitely one of them, as that is not how traversal is handled ANYWHERE else. But the game as a whole I really enjoyed, and thought that the intfiction community would appreciate as well.

The other issues you bring up, I can see how they would be bothersome, but I managed to get by in (nearly) optimal fashion - I think I died once during the chase, and it was quickly obvious (to me) what I did wrong and what I needed to do.

But part of what I like about adventure games/interactive fiction is the frisson you get from getting stuck, frustrated, then finding the right solution. I appreciated Ultimate Quest more, I think, than I do most IFComp entries because IFComp entries always come with a walkthrough. And the lack of walkthrough for UQ heightened the experience for me.

Basically, those annoyances you listed above probably actually made me like the game MORE.

Yeah, I can feel the pleasure of getting stuck and finding the solution. The problem I had with the last part was that the game was making it hard for me to try out solutions (and elsewhere to implement the solutions I had found); far too much of my time was spent in the metagame of trying to undo to the right point rather than in the game of trying out potential solutions. And this was worse than the typical IF game, because saving is (AFAICT) disabled.

I also had a lot of flail-y moments that I never would have had with more traditional IF conventions. I still don’t want to go into details because it seems like maybe the contest isn’t over* but there was a point at which I had to restart twice because I couldn’t figure out how to leave a room that had neither a door (“use door”), nor a floor (“use feet on [floor]”) in the room description and no nearby rooms that supported “go [wherever]”. There were also some misleading responses, especially in the endgame. And the lack of saving was especially brutal in the second episode, which has a “battle” sequence that’s longer than the undo buffer.

Despite all that, I had a great time with the game. Some of that was external to the game itself – I had a friend visiting from out of town that was willing to provide some friendly competition and of course the lure of prizes didn’t hurt, though I was more enthusiastic about the concept of winning prizes by playing IF than the prizes in and of themselves – but I’m also apparently just really into the exact kind of games that Emily Short makes. I found the actual puzzles (as, not the parser issues) really satisfying and the worldbuilding was delightful as always. And I liked that some of the minigame mechanics felt borrowed from genres I generally don’t step foot into, but adapted to be workable by me.

*I am pretty sure I was in the top 50 – I finished at about 9:30, I think; there were some technical difficulties such that disparate starting times needed to be taken into account, but even at 9:30+lag, there were not many game-winning tweets on the hashtag – but I haven’t heard from them, which makes me think that the winners haven’t all come into existence yet

Well, I’ve played through the first episode again all the way this time – it’s a lot easier and smoother when I already know what I’m supposed to be doing! And this time I got through that puzzle with only a few multi-undos. I’ll see what the other parts are like! (Assuming they stay up long enough for me to get around to them.)

I gave up during the second episode. I like the writing, but I can’t deal with the implementation (what can be combined with what during the battle seems very restricted and completely arbitrary; can’t undo far enough; objects get into buggy states where they can’t be recycled).

I am stuck at the skylight. The drone kills me to death. Think asks to put up a protection but I do not know which body part to protect

You’re trying to protect your whole body, not an individual part of it.

You'd need a much bigger piece of FITCLOTH to suit up your whole body.

Right, you can’t fit your whole body. You need to make an external thing that can protect it.

If I remember the solution correctly, this page will help if you need a bigger hint.

EDIT: Ugh, that could’ve gone better. Changed the link.

Sorry, your image does not display

Yeah, I had linking trouble so I changed the page.

That works for now. Thanks

My opponent can produce the chorus and the chain effect. Why can’t I?

The chorus bonus has to do with where you are in the overall structure of the bout. See this tweet: twitter.com/Ultimate_Qs/status/ … 1188153344

The chain effect is given if you re-use something your opponent just used.

On the off chance there’s somebody in this thread still - where do you get the ANECDOTE conversational gambit?