Twine offline Story Formats keep resetting to default

Please specify version and format if asking for help, or apply optional tags above:
Twine Version: 2.3.9 offline
Story Format: any

I’m not sure if this is a legitimate bug to report on the Twine github, or if it is just me, so figured I’d start here. Is this a bug or am I doing something crazy?

I installed the 2.3.9 version of Twine onto my Windows 10 desktop two days ago.

I have used the below steps 1-6 without a problem on the online Twinery version. So I’m hoping that means it’s not just me.

Steps:

  1. Installed Twine offline installer to default path.
  2. Got the latest SugarCube online from the docs here.
  3. Got the link to the Illume online format.js
  4. Fire up Twine
  5. Open Formats and add the path to the the SugarCube link. It installs without a problem and I set it to use it as the default.
  6. I then add the Illume. It installs without a problem. I set it to the default.
  7. I got into my story, and ensure the 2.33.1 is selected for the format.
  8. I exit out of Twine. When I look at the story-formats.json in my profile, it looks great. Note: See modified-story-formats.json, in the zip attached
  9. I fire up Twine again and exit out.
  10. Next time I start up Twine, SugarCube is back to 2.31.1, 2.33.1 is gone and Illume is no longer listed. I open the story-formats.json and the array looks like it might be broken, with an odd 2.31.1 entry added after the array is closed. Note: See broken-story-formats.json, attached in the zip. To me it looks like the array is broken when it tries to insert 2.31.1 back onto the list after it was replaced in step 5.
  11. Then the next time it starts, the JSON is reverted back to the default that was there after a fresh install.

From that point on, the story-formats.json seems to be reset back to default and I no longer see my two added formats.

I then tried downloading both and installing using the file:/// and it has the exact same issue, where it disappears eventually. I also tried setting the story-formats.json to read-only once I got the modified copy, and that doesn’t prevent it either.

story-format files.zip (1.5 KB)

clarification: There are two ‘offline’ variations of the Twine 2.x application:

  1. The install-able ‘Desktop’ release.
  2. A downloadable copy of the ‘Web-browser’ based release that can be run locally.

The installable version, sorry. :slight_smile:

When you say you “add the path to the SugarCube link”, what specifically are you doing? What does the path look like?

What I tend to do is:

  1. Put the SugarCube files where I want them to be on my computer.
  2. Open a new empty tab in my browser.
  3. Drag the “format.js” file from that directory to that browser window.
  4. Copy the URL at the top of the page.
  5. Paste that URL into Twine in the “Add a New Format” window and click “+Add”.

After that, it should work fine.

My path looks like this:

file:///C:/Program%20Files%20(x86)/Twine%202/SugarCube/format.js

If you aren’t using a path like that, then that could be the problem.

Hope that helps! :grinning:

I’ve tried it with both the online version and the downloaded version of the files. I have the online Twinery version set up using the online files and they are both working perfectly.

Online format URL:

For my PC, it’s Windows 10 and I have my user profile stored on a second drive (hence the D). I created a subfolder under Twine where the stories are kept to keep everything together. The single ticks are not there, and all files within the zips are located together.

  • Sugarcube: file:///D:/Profile/Documents/Twine/StoryFormats/sugarcube-2.33.0/format.js
  • Illume: file:///D:/Profile/Documents/Twine/StoryFormats/illume-1.0.5/format.js

For SugarCube, you should be downloading the recommended release from the main SugarCube v2 page (in the “Downloads” section).

Also, if you want to take a look at the source or submit an issue, here’s the SugarCube v2 GitHub page.

Hopefully that does the trick! :grinning:

That was the site where I got the offline version.

In the documentation, there is directions for the online install, which was my other attempt when the offline stopped working. https://www.motoslave.net/sugarcube/2/docs/#guide-installation-twine2-online

I thought I had downloaded the right versions, but I’ll redownload them all to make sure Upgrading to 2.33.1 won’t be a bad idea anyways.

You originally said you were using the offline version of the Twine editor, but then you said that you had gotten the SugarCube “format.js” file for the online version of Twine.

I just wanted to make sure that, if you’re using the offline version of the Twine editor, then you’re using the offline version of the SugarCube “format.js” file in that instead.

Sorry for the confusion on that part. First I tried using the offline download, then when that one lost it I tried the online version just in case. Then when both were having issues I was trying both.

I re-downloaded the program and the storyformats and both seem to be working now. So must have been something that got corrupted in the first install I guess.

Thanks for the assistance!