Tracklist Play Error

Really struggling to get the music tracklist to play here.

Init Passage

<<cacheaudio "1" "Music/Track1.mp3">>
<<cacheaudio "2" "Music/Track2.mp3">>
<<cacheaudio "3" "Music/Track3.mp3">>
<<createplaylist "playlist1">>
	<<track "1">>
	<<track "2">>
	<<track "3">>

In the Title Passage I have

<<playlist "playlist1" play>>

Yet on running it I get:

"Apologies! An error has occurred. You may be able to continue, but some parts may not work properly.

Error [StoryInit]: <>: no actions specified."

What version of SugarCube are you using? A lot of the recent changes to it involved the audio code, so you might want to make sure you’re using the latest version of SugarCube (currently v2.30.0).

Also, what is inside the “<>” in your error message? You need to put SugarCube macros within “preformatted text” markers (select the text and use the “</>” button) if you want them to appear properly in this forum. If it’s “<<track>>” then you might try adding a volume level, like “<<track "1" volume 0.5>>”, to it to see if that fixes that error. The volume level is supposed to be optional, but if it’s saying “no actions specified” then that may be a workaround if the code isn’t allowing no options like it should.

Please let us know what you find out. Thanks! :slight_smile:

I’m on Version 2.3.3 of Twine

The story format of Sugar Cube says it is on 2.28.2

Additionally when I got to that link for the latest SugarCube Version it only has a download link for a twine version of 2.2 but the one I have installed is 2.3.3.
So should I still download that one or wait out for the newer twine one to come out? I’m a bit confused on that one.

That’s the one you want. Assume that it actually reads as Twine 2.2+ or something to that effect—updated it to read: Twine ≥2.1.

As to the audio issue, as documented within the release notes for SugarCube v2.29.0:

  • Fixed the <<createplaylist>> macro’s track actions to actually be optional as intended.

Thus, you can address the issue by either upgrading to the current SugarCube version (v2.30.0) or, with your current version (v2.28.2), by adding volume 1 to each <<track>> entry—e.g., <<track "1" volume 1>>.

1 Like

You could also just update to Twine v2.3.5, which includes SugarCube v2.30.0.

1 Like