Total Newbie Twine Question(s)

So I thought I’d download Twine 2.3.1 for Windows and have a look at it. (Or, I guess it’s 2.3.1 – that information is usually to be found under the Help menu, in an item that might be called “About Twine.” There is no such item in the Help menu.)

I created a new story. I got a light blue window with an Untitled Passage in it. I double-clicked on that window, changed the title to At the Beginning, and wrote a couple of sentences. Then I clicked on the X in the upper right corner.

My understanding is that at this point the interface is supposed to change my initial box to display “At the Beginning.” It didn’t. And when I click the Play button, I get a black window that says, “Double-click this passage to edit it.” Well, I did edit the text, didn’t I? So I close that window and double-click on “Untitled Passage” again. You guessed it – the new text I entered there is still there. But Twine refuses to display it.

But wait, there’s more. I create a couple of linked pages using the [[xxx]] notation in the Untitled Passage. When I close the edit window, I do indeed get two new boxes, with the proper titles displayed. But according to the Twine documentation, there are supposed to be little lines between the first box and the two new ones. There aren’t. The three boxes are all free-floating.

I’m not going to call this user error, because it’s fairly clear I’m doing exactly what the documentation tells me to do. Until further notice, I’m going to call it poor documentation.

So how exactly do I go about making the thing behave the way it’s supposed to?

1 Like

Oh, this is lovely. I quit Twine and then re-launch it using the shortcut on my desktop. Now my first box, At the Beginning, is properly displayed, with arrows pointing properly to the two new boxes I created by adding links. There is also a box called Untitled Passage. When I click Play, as before I get the “Double-click this to edit it” in a black window. Well, I don’t need that, so I delete the Untitled Passage box and click the Play button again … and … I get an empty white window. Twine displays NOTHING in play mode, even though I have three boxes.

Yes, user confusion is inevitable when one starts learning a new system. But what am I doing wrong? What should I be doing instead?

I just opened my copy of Twine on Windows, version 2.2.1, and also a web copy of Twine 2.3.1, and tried to recreate this. I was unable to do so at this time. I also downloaded a new copy of 2.3.1, and tried creating a new game with it, and that didn’t work either.

You can find what version you are using by clicking the ‘home’ button and going to the home page, where it’s listed in the right sidebar.

Does At the Beginning have a green icon next to its name? The green icon represents the first passage. It’s possible that that was removed somehow. You can change the starting passage by hovering over the desired passage, clicking on the ellipsis, and selecting ‘start story here’.

In general, though, it sounds like you’ve experienced an unfortunate bug. I find the web version to be more convenient, although it relies on local storage, so clearing your browser data will erase it, and it doesn’t translate easily to other computers. However, I also frequently download an archive of my online games.

I hope it works out for you in the long run!

Using Twine 2.2.1 on Linux Mint.

I have to open Twine using the command line, but I guess double clicking on the program icon should do the equivalent in windows.

When I open Twine, I first get the “Home” page, which is a list of the stories I’ve already/am currently writing. There is a bar down the right hand side of the page with the options:

[plus sign] story





Do you see any of that, Jim?

Only once I’ve clicked on [plus] story, and given it a name do I see the blue, “graph paper” style window with a single box (with a rocketship icon on it) called Untitled Passage.

Double clicking on the box opens the passage for editing. The page reads:

Untitled passage

[plus sign] Tag

Double click this passage to edit it

Amending the passage title to: Rain-swept street, and the passage text to:

Hurrying through the rainswept November night, you’re glad to see the bright lights of the Opera House. It’s surprising that there aren’t more people about but, hey, what do you expect in a cheap demo game…?

[[Enter the Opera house->Foyer]]

I can either click the X in the RH corner, or hit escape to close the editing window. The blue page now shows two passages, “Rain-swept street” and Foyer.

At the bottom of the blue page are various options, amongst them, “Test” and “Play.” Hitting the Play option opens a new browser window and displays the Text of Rain-swept street. The default “Harlowe” style doesn’t display the passage title, only the passage text. If you want a more traditional text game style you can switch to “Sugarcube” but Harlowe and Sugarcube use different code formats (for setting/changing variables etc.) so I’d say it’s best to stick to one format and learn that rather than switching to and fro.

The Harlowe manual is at:

I notice it’s just been updated to 3.0.1 but I haven’t read it yet.



Thanks, folks. Using Brian Rushton’s suggestion I was able to get the story to start with my opening node. (There’s still no green icon next to its name, however.)

Right now I’m experimenting with macros. I can see that there’s some power under the hood here. I’m still basically a devotee of parser-based IF. I love being able to click on things, but I find it very limiting that there isn’t actually a model world for the player to interact with.

And no, I wouldn’t want to develop a story in the browser. I always insist on local file storage. For backup, if for no other reason!

1 Like

If you want more of a world model, I’ve been impressed by some of the features of the Elm Narrrative Engine in that regard:

It may be worth checking out. It’s also fairly new and still under development. It used a more traditional interface.

Ink is another good option, but requires integration with Unity or other display software.

Of course you’ve already invested time in Twine, but I’m just throwing these out there in case you’re interested.

Thanks for the suggestion, Brian. The Elm engine produces a nice point-and-click display. I’m very conversant with parser-based systems, however. I’ve written half a dozen games in Inform and TADS. I’m curious to learn more about Twine for a few reasons: (1) A lot of people are entering Twine games in the IFcomp. (2) It seems to be in active development, and sadly, one can’t say that about either TADS or Inform. (3) Clearly, modern audiences will prefer a click/tap interface to one that requires typing. (This is especially true if you’re encountering the story on a tablet or phone.)

1 Like

I don’t use TADS, but from what I understand it’s a pretty solid platform with the unfortunate factor that the authoring environment isn’t uniform cross-platform (can you use it on OSX?), and development slowed before the era of making everything browser-playable.

As I’m sure you’re aware, Inform is a mature platform that doesn’t really need constant patches and fixes, though these are addressed. Graham Nelson just rarely discusses Inform development in public, and it’s common for years to go by between updates.