This is dumb, but how do I install Vorple?

I’ve tried to get Vorple installed on my computer and working with my projects on Inform, and I’m just having a hard time and I can’t get it.

Would some patient, blessed soul be willing to show me a very slow/clear/treat-me-like-I’m-five step by step to what I need to do to get it installed and running? I’ve tried using it on a friend’s computer before and it’s a lot of fun. I’d like to try using it again! (note: I use windows, not apple/mac)

Hi, the following steps should work:

  1. Download and install Inform 7 from http://inform7.com/

  2. Download Vorple 3.1 from https://vorple-if.com/download.html

  3. Unpack the file “vorple-inform7-3.1.0.zip” somewhere. On my system, it lives at “D:\Spiele\IF\Vorple\vorple-inform7-3.1.0”.

  4. Download the server software nginx from http://nginx.org/en/download.html - in this case the latest stable version for Windows, currently http://nginx.org/download/nginx-1.16.1.zip

  5. Unpack the file “nginx-1.16.1.zip” somewhere.
    On my system: “D:\Spiele\IF\Vorple\nginx-1.16.1”.

  6. Start Inform 7 and create a new project. I will call it “Vorple Test Game”. For the directory in which to create the new project, choose the subdirectory “html” in the nginx directory which we created in step 5.
    So, on my system: “D:\Spiele\IF\Vorple\nginx-1.16.1\html”.

  7. Add the following code to the test game:

Include Vorple Notifications by Juhana Leinonen.

Release along with the "Vorple" interpreter.

The Laboratory is a room. "A room for experiments with Vorple."

When play begins:
	display a notification reading "Welcome to Vorple!".
  1. Open the project’s Materials directory: within Inform, open the “Release” menu and click “Open Materials Folder”. This will open the location on your hard drive in a file explorer window.
    For my system, it’s “D:\Spiele\IF\Vorple\nginx-1.16.1\html\Vorple Test Game.materials”.

  2. Go to the folder which we created in step 3 above, in my case: “D:\Spiele\IF\Vorple\vorple-inform7-3.1.0”. This contains two folders: “Extensions” and “Templates”. Copy both of them into the Materials folder which we opened in step 8.
    On my system, they are now at “D:\Spiele\IF\Vorple\nginx-1.16.1\html\Vorple Test Game.materials\Extensions” and “D:\Spiele\IF\Vorple\nginx-1.16.1\html\Vorple Test Game.materials\Templates”.

  3. In Inform 7, click on the Release button to generate a release. Inform puts the files into the Release folder, which is a subfolder of the already-mentioned Materials folder.
    So, on my system, the release is at: “D:\Spiele\IF\Vorple\nginx-1.16.1\html\Vorple Test Game.materials\Release”

  4. Start “nginx.exe” from the nginx directory which we created in step 5.
    So, on my system: “D:\Spiele\IF\Vorple\nginx-1.16.1\nginx.exe”.
    It will run in the background and serve any web pages which are stored in its “html” subdirectory.

  5. Start a browser and open the “play.html” page in the “Release” subdirectory which was created in step 10: put “http://localhost/Vorple%20Test%20Game.materials/Release/play.html” in the URL address field.
    Note: do not open the play.html file from a file explorer, because we do not want to look at the file as a “static” file, so to speak, but rather as it is served by the nginx server.

  6. You should see the game starting up and displaying a notification in your browser (the notification which we defined in the game code in step 7 above).

I hope this helps, and feel free to ask if something isn’t clear.

6 Likes

Hmm. I must have done something wrong again, or something is weird with my computer. I get to step 12/13 and I get a message in my browser saying ‘404 not found’ (no matter the browser I use) when I try to run the game in the server.

Here is what my folder set up looks like:

 C:\Users\chandler\Documents\VORPLE\nginx-1.17.3

nginx1.17.3 contains conf, contrib, docs, html, logs, temp and of course, nginx

In the html folder I’ve got: Vorple test.inform, vorple test.materials, 50x and index.

In the vorple test.materials folder, I’ve got: Extensions, Release and Templates

Lastly, the release folder contains: interpreter, cover, index, play, small cover, style and vorple test (glulx file)

Is there something I could be doing wrong? (I tried nginx 16 and 17, identical directory setups both times) Inform works on my computer though - I’ve had that installed for a long time before hearing about Vorple. In any case, its directory looks like this:

 C:\Users\chandler\Desktop\buildagame\Inform 7

I think it’s because in step 12 above, the link points to a folder called “Vorple Test Game.materials” and yours is called “vorple test.materials”.

You can also just go to to http://localhost, and normally a list of folder should appear and you can just click your way to play.html.

(Also, if you know how to use Python and have it installed, you can use it instead of nginx. But if you don’t have it installed, it’s better to stay with nginx.)

1 Like

The 404 error probably means that nginx wasn’t able to find the requested file at the given URL.

The “html” subdirectory is treated as the root directory of “localhost” when nginx is running, so to work correctly, anything that follows the “localhost” in the browser’s URL bar must be exactly in the corresponding location within the “html” directory on the hard drive.

My suggestion would be to try out these things:

  1. Make a subdirectory “testing” in the “html” directory and copy the “index.html” file from the “html” directory there (this is the file which has a greeting from nginx)

  2. Try to get this file served by accessing “http://localhost/testing/index.html” in the browser. If it works (you should see “Welcome to nginx”), everything else should also work in principle.

  3. For the Inform project, try a directory name without spaces. Make a subdirectory “testingvorple” in the “html” directory and copy the contents of the Release directory there.

  4. Access “http://localhost/testingvorple/play.html” in the browser. If it works, then probably the spaces are the problem. You should be able to get around this by replacing the spaces with “%20” in the URL (this is called URL encoding), so that it looks like this: http://localhost/Vorple%20Test%20Game.materials/Release/index.html

1 Like

Thank you my dudes! I changed the name of my game and changed the URL I followed, and I also made that subdirectory per StJohnLimbo’s instruction, and everything is running smoothly now! :smiley:

3 Likes