The Surprising Case of Brian Timmons

Hello, all. Please enjoy my 2nd effort. Thanks!

The Surprising Case of Brian Timmons

Marshal Tenner Winter

Is the game considered complete, or are you inviting beta testers?


It’s tagged with “adaptation”. An adaptation of what?

Version 1 is complete, at least. It’s an adaptation of a Chaosium scenario (CoC). I state this in the credits in the game.

I would need some hint, I couldn’t reach the western door in the Reformatory.

I tried to fire through the grate or to feed the thing(?) with the last sardine, but to no avail

did you take the sardine out of the can? that should work.

Yes, I took the sardine out of the can.

I tried to cross the room with the sardine in my hands, but failed. Throwing through is not implemented, throwing at fails ,feeding the thing fails too, because I cannot refer to it neither as “grate” nor as “thing” “brood” “floor” “voices” and so on.

try “dropping” the fish while in that grate room. sorry, it was only my 2nd game.

I guess the error is somewhere else.

Dropping the sardine resulted in:
You can see the last sardine, a hand-drawn map and a scrawled note here.
Crossing the room after that failed again.

forgive me, its been awhile since i made it or played it. did u try “put sardine in grate”? or “drop sardine in grate”? i would have to go back and check the code.

yeah, it’s “inserting” so any synonym for inserting the sardine in the grate should work.

That’s it! Thanks, my fault !!! No need to write excuses …


Okay, it turns out not to be over yet …

I am in the Safe Room and I have shot the goon. “cast spell” doesn’t seem to have any effect. All other commands I tried seem to result in my death.

Hmm…I just tested it and if the goon is gone, the spell should work. I will keep testing. It’s been awhile since I made it and played it.

Okay, I checked out my code. Turns out, there is a big ass bug in the game; totally my fault, of course. In fact, Peter Pears tried to tell me about it but I chose to ignore him cuz we were at odds in that conversation. Turns out, he was right, lol.

Apparently, if you cast the spell at the thing in the tunnels, it won’t let you cast it at Douglas in the end. I’ve examined the code and I can’t figure it out for the life of me. Forgive me, it was my second game and that bug somehow got past me and my playtesters.

I will figure it out and make v2 with the fix. In the meantime, PM me your email address and I’ll be sure you get a tester’s copy that lets you get to the ending and see the ending.

Sorry again, still learning my craft here. v2 coming soon! Thanks!

Never mind, the game is pretty short, so it’ll be no problem starting again from the beginning.
I enjoyed it anyway because of the simple underlying mechanics and the setting which is sparse but good. Perhaps you should consider a little more polish. I could send you a transcript, if you want. Now I’m looking forward to the sequels …

– MI

Thanks! Yeah, my games, IMHO, get a little better each one. My conversation system (or lack thereof) leaves a bit to be desired, but I finally fix that in my upcoming games. Let me know if you have any other issues, plz!