The room description heading rule while moving

I’d like to be able to move the player at times without triggering the room description heading rule - the one that makes a fresh paragraph and prints the bold room name. It seems like there should be a “move the player to the Library silently” option that I’m missing. I’ve made a number of attempts, but can’t quite hack together something that works. I’ve also tried suppressing the game from looking after moving the player, with the idea that if the game doesn’t look, it won’t print the room description heading, but no dice.

Most of the time I don’t mind, but I’ve got an action that moves the player automatically a couple times, and it’s . . . bad. I could reconfigure my action and track a marker or something instead of moving the player, but I don’t really want to if I can avoid it.

Is what you want “move the player to Aladdin’s Cave, without printing a room description”?

No, that only represses the description itself. In that example, you still get interrupted by

The Room Name

in the middle of things.


I just make a quick test:

Tiled Room is a room. "Ack! Tiles everywhere!"
Round room is a room. "It's so.... round!"

The player is in the tiled room.

Instead of singing:
	say "The room shimmers a bit as you sing.";
	if the player is in the tiled room:
		move the player to the round room, without printing a room description;
		move the player to the tiled room, without printing a room description.

And it changed the name of the room in the status bar, but the only text I saw was the “the room shimmers a bit” line when I went from room to room.

Are you moving the player a different way?

It also seems to work for me; with the following test code:

The Road is a room. "A road!" The Beach is west of the Road. "A beach!" Instead of waiting in the beach: say "Back to the road!"; move the player to the road, without printing a room description. Test me with "z/l/w/z/l".

I get

No room name between steps 4 and 5.

If I say that I tried that, and it didn’t work, but now it does, would you believe me? I mean, I copied and pasted from the manual!

Argh. Also, thanks.

Ha, no worries. Actually, if you copy-pasted from the manual, my guess is that you accidentally copy-pasted “move the player to Aladdin’s Cave, without printing an abbreviated room description,” which is surprisingly easy to do if you’re reading section 8.7.