The Dreamhold is now available for iOS

More details later, when I’m not typing on an iPad. :slight_smile:

Superb. And I say this before actually trying the app.

You just opened a big door into a whole new realm.
Well done and, uhm… Thank you.

Apparently there’s a flaky segfault in there somewhere. Doesn’t affect everybody. Not sure whether it’s the interpreter engine or display layer going wrong…

You rock hard. I will be encouraging (read haranguing) iOS users I know about this. Thanks for spreading the IF love.

This is very awesome news Zarf! A heroic deed indeed. I really like the UI, feels great! Btw. I experienced the bug upon first loading it up, quitting and restarting helped. Cheers!

Great work, Zarf!

Unfortunately, I’m also getting that “signal 11” fatal error and it doesn’t seem to go away. This is on an iPhone 4 model MC605KS running iOS 5.1 (9B176). Please let us know if there’s anything we can do to help you figure out who gets the error or not.

It is an array-overflow error, which means there’s absolutely no logic to it. (Actually array-underflow – it winds up writing to memory before the start of the array.)

What happens then depends on the exact order that memory blocks were allocated in, which is unpredictable.

I will be submitting a patch tonight.

when I’m not typing on an iPad. :slight_smile:

Speaking of extraneous touchpad typing – it is intentional that all directions need to be prefaced with “go”?

Mm? It’s the standard I6 direction parsing.

Just wanted to note that the problem DID go away for me, when I tried it once more, maybe the fifth time I opened the app.

Strictly from an evolutionary standpoint it seems these
intermittent bugs have found a very clever survival strategy.

it worked when i force-quit the app and restarted it. did you do that?

I did force quit, but that did not help. Then I think I just exited (with a button press) and started it again, and then it just started working.

Thumbing through the collection of all the masks for the first time, it occurred to me that perhaps the old ipod touch wasn’t the best way to lose my Dreamhold virginity. Needing to “go” in a direction would be fine if I had a real keyboard, but this is a platform where every cloddish peck at the minuscule virtual screen is laborious – and those two extra letters nearly double the amount of the typing the game requires for input! (If only, I thought to myself, the snazzy new map could automatically transport me to previously visited locations, but no.)

The abbreviated L and I also gave me guff (“I only understand you inasmuch as you want to look at something”), while the more advanced-level IF abbreviations G and Z performed as expected… which confused me. And, of course, the Apple spellchecker hindered as often as it helped. (Is there a way for a game to populate its lexicon with words expected in the game?)

Despite these gripes (and one other – after taking on a serious play session in landscape mode, it was unclear how to return to playing it in portrait mode) the game remains a thing of wonder. But my interface complications made me feel like I was flipping through fragile pages of a valuable manuscript with my hands permanently formed into clumsy fists.

In any case, pretty much IF’s best shot at the iOS crown so far, unsurprisingly. But everyone will have their own ideas about what would push a release from good to great.

So, to be clear, you don’t have to type “go” before directions. (You can try this with the downloadable or web version of Dreamhold, which are exactly the same build as the iOS release.)

Possibly you were confused by an incomplete verb, which can produce this sequence of events:

What do you want to take?
That isn't available.

Inform has always worked this way, although the error message has changed in I7 to “You must name something more substantial.” Typing the direction again will work as expected.

The standard abbreviations “l”, “i”, “g”, and “x thing” all work (“look”, “inventory”, “again”, “examine thing”). “Look” requires a preposition – you’d have to type “l at thing” – but “x” is the usual abbreviation here. (This has changed in I7; recent releases accept “l thing”. I’m not sure I like that change, but it postdates Dreamhold, anyhow.)

Unfortunately, no. I included a preference to turn autocorrection entirely off, but there’s no way for me to customize its behavior.

It is a self-updating dictionary, so if you reject a correction of “ne” (tap on the popup correction bubble) that will tend to increase the acceptance of “ne” in future commands. However, in my playtest runs, I was never able to convince it to always accept those direction words.

This is entirely controlled by the device’s orientation sensor, not by the app.

Oh, as to the map – I agree that you want to be able to tap a room to go there. I intend for Hadean Lands to have that feature (and the associated logic to jump around the map without screwing up the game state).

However, backporting that logic to Dreamhold – or any other parser improvements – seems like a distraction. I wanted to get the interpreter wrapped up and tested, not spend time updating a 2004 game. That’s why the original Dreamhold game file is in there.

Hey, great news!!! I downloaded it on my Ipod Touch 2 Gen and I got a “Fizmo fatal error: Caught Signal 10, aborting interpreter”, even after shutting the device down and restarting.

try force quitting the app several times, seems to have helped others!

Hey, seems now it works. I guess I’ve tried about 10 times. The map is really nice, zarf!

[code]This didn’t jive with my experience of the game, so I thought I’d try to reproduce my results:

I only understood you as far as wanting to n.
I only understood you as far as wanting to s.
I only understood you as far as wanting to look.
I only understood you as far as wanting to inventory.[/code]Here’s hoping these results can help to impress upon you the non-confabulated nature of my gripes 8) I ended up turning on verbose to avoid having to write out LOOK in full all the time for room descriptions, exits, etc. (The insta-transport map wouldn’t have been so critical except that this particular map is somewhat unconventionally laid out and the connections not always intuitive.)

I eventually gave the device quite a shaking trying to trip its sensor, and it just popped up with a bubble discussing how I was trying to cancel or undo some action, but it could find no such action to reverse. Here we are: “Nothing to Undo”. {Cancel}

I do think that in some states the game locks the device’s sensor, but I’m having a harder time reproducing that.

It’s interesting to see that many people are having problems with this release, but I seem to be the only person having these particular problems 8)

Hm. That is indeed surprising. I don’t know how that could happen.

I suppose it’s possible that the virtual machine got corrupted. When the update appears, you might try deleting the app entirely and then reinstalling it – except that will delete all your saved games, so you probably don’t want to.