The Adventures of Houdini

You play a hamster; what more do I need to say?

IFDB page

Try this transcript:

restart. wake kiwi. follow kiwi. drink. examine tube. nibble tube. nibble.

I wonder if you could intercept the “(first going…)” room descriptions and instead say something simple and hamsterish like “You amble over to the northeast corner of the cage.”

The response “You prefer to keep your options open” doesn’t make much sense to me.

In the vein of the thread I posted last night about how I’d prefer to see “silly commands” removed from most games: The responses to “climb wheel”, “push wheel”, “push Kiwi”, “pull Kiwi”, “kiss Kiwi”, “touch Kiwi”, “get all”, “touch me”, and “hit me” are missing newlines. “Pushing” a sleeping hamster should perhaps behave like “wake”, and the response to “pulling” a sleeping hamster seems odd. “Push me”, “pull me”, “kiss me”, and “wake me” all give inappropriate responses.[spoiler]> x dome. x nest. enter nest. sit in nest. squeak at Boo.

wake boo. (Boo dashes away down.) wait. (Boo scurries to Bars Northeast.) follow boo.
If that is around here anywhere, it’s too far away to see. (missing newline)[/spoiler]
Essentially it looks like “follow” wasn’t implemented at all, which is odd for a game involving furry creatures dashing around. I think you ought to implement it. Perhaps for each NPC you could have an associated “follow-direction”, which is set whenever the NPC leaves the PC’s current location, and zeroed whenever the NPC re-enters the PC’s location or the PC herself moves.

restart. exit. s. s. x food. eat. (wat)
restart. exit. s. s. e. u.
restart. stop. (wat)
restart. exit. push coconut. (yes, “the” coconut, thank you Inform)
restart. exit. climb coconut. look. (actually the whole “roof” interaction is underimplemented; try digging, going down, etc.)
restart. smell. (whoaaa what just happened)
restart. exit. x litter. burrow. d. dig.

“Wave” is perhaps underimplemented, given that your name is “Houdini”. Admittedly by this point I’m getting to that stage of “I’ve tried everything I can think of to progress in the game, and failed; guess it’s time to grasp at straws”.

To balance out all the little glitches, there is a lot of clever polish here. Transcripts that do work properly include[spoiler]> restart. wake kiwi. exit. s. u. e.

restart. kiss kiwi.
restart. wake kiwi. exit. s. push tube north. push tube up. d.
restart. squeak. xyzzy. wave.[/spoiler]But after waking the other two hamsters, storing some seeds and a carrot in my pouches, running on the wheel, climbing the bars, and fruitlessly pushing the tube around, I’ve run out of ideas and will have to admit failure.

OK, I’ve uploaded version 2 which deals with these issues. (What would you expect “wave” to do, btw?)

I dunno, I was just thinking “Houdini… magician… wave wand… wave…” so maybe something would happen (remember I was grasping at straws) or at least there might be a funny message.

I’m still assuming that it is possible to escape the cage, and the title is a reference to Houdini-as-escape-artist. (Is the name of the PC discoverable as “Houdini” in-game? Should/could it be?)

I see a different and more appropriate squelch-message for “follow Kiwi” in version 2 (although if you “follow Kiwi” while in a room adjacent to Kiwi, you still do move into Kiwi’s room before getting the squelch). It puzzles me that Houdini doesn’t find Kiwi “that interesting”; why then does Houdini raptly report each of Kiwi’s movements, even if she’s just nosing around in the litter or wandering aimlessly(?) on the other end of the cage? Given the emphasis on the other hamsters’ movements, and the amount of implementation that clearly went into them, I’d been assuming that they would both play some key role in the escape — and thus dismissing them as “uninteresting” seems like it ought to be a reverse-red-herring. They must be interesting, somehow, dammit! :slight_smile: They don’t seem to have unique personality traits, though, which means the solution isn’t to bribe one of them with a carrot (missing newline in “give carrot to Kiwi”, btw, and excessive helpfulness from Inform if the carrot is in your pouches when you try that), or make them fight, or… well, I can’t actually think how either of those would help Houdini escape, but anyway the solution doesn’t feel like it will involve social engineering among my fellow hamsters. Neither can I tell them to do anything, like maybe stand on each other’s shoulders. The seed pile is similarly overimplemented; perhaps I could transfer the entire pile to under the cage door, then stand on it? Problem is, the cage door seems to be located in a spot that’s not directly above any room, so that can’t be it.To the “dig” transcript in my last message, add “dig in litter”. I notice that “dig” works in the Lofty Lookout, even though it doesn’t work in the cage; I don’t know if that’s a result of your version-2 changes. I also notice that “smell” has been fixed. Most of the above transcripts still apply, though, so I won’t repeat them here.

smell me. climb cage. climb door. climb bars.
I like the response to “give seed to me” (while holding a seed); it’s probably the Inform default, but I’m a sucker for surprise juggling references. “give seeds to me” (while holding three seeds) unfortunately does not work.

After taking all 40 seeds from the food pile, it is possible to get a runtime error from Inform:
*** Run-time problem P15: You can’t move nothing.
I believe it happens when Kiwi tries to take a seed from the (empty) stash.

Seeds in general are not handled quite right; you’re clearly using one of Inform’s clever tricks to make countable objects, but then verbs like “get” and “drop” don’t actually handle the object as having a count; instead it’s treated as N separate objects that each generate their own messages. I’m sure there’s a way to do this properly.

restart. exit. s. s. get thirty seeds. (Doesn’t work? Oh well, fine.) get pile. get pile … (30x) … get pile.
drop seeds. (Yikes!) get seeds. (Whoa nelly! also missing newline)
put seeds in pouch. (Yowza!) drop seeds. (wat)

restart. exit. s. se. enter wheel. examine wheel.
(missing newline on “pull wheel”)
(“turn” and “turn on/off” are considered the same verb, which is a little odd)

The message for “jump” (on ground level) is a little stilted[spoiler]unless you have already tried “jump” from above ground level. Maybe set a flag or timer to make the two “jump” messages interact?

You’re not much good at jumping.
You’re climbing along the bars… etc…
You let go and fall down.
This is another place… etc…
You’re not much good at jumping up.
Just an idea.[/spoiler]Man, I’m still not getting anywhere with this game! It’s crazy overimplemented, with the hamsters running around doing their own agendas, and the countable seeds, and the wheel you can run on (and “turn” on, as I just found out)… but I don’t feel like I’m making any progress toward a solution or endgame. It just feels like a big sandbox. I’m not even racking up any points for the crazy things I’m trying; the game’s just sitting back in its chair going “Nope, try something else. Nope, try something else. Nope, try something else.”


restart. exit. u. e. examine it. examine bottle. touch bars. kiss bars. touch door. close door. eat door.

[spoiler]I just noticed that “swing” is sort-of implemented… but as a transitive verb, which is wrong. Inform’s helpful disambiguation for “swing” on the ground is ungrammatical, the message when inside the coconut is odd, and the only thing I can think to do is “swing. swing. swing. jump” which just puts me back on the ground.

restart. exit. e. u. e. u. swing. x tube. look. d. x tube.[/spoiler]

Don’t hamsters kept in the same cage kill and eat each other?

I do enjoy the game though. Super cute.

The picture looks like some sort of dwarf hamster; they’re more or less ok with sharing a cage, especially with littermates.

I still can’t get out of the cage, and I so want to. The game is very cute and very frustrating, kind of like playing with an actual hamster.


Regarding getting out the cage: waking up the other hamsters and exploring every nook and cranny of the cage (i.e. roleplaying a hamster) is well rewarded.

OK, I’ve obviously made the solution way too difficult, so I’ve just uploaded a new version (3) that awards points to guide you along (it also has a built-in hint function). So hopefully that will be up in a few days; let me know if that makes it clearer.

Tanga: Syrian (teddy bear/golden) hamsters are solitary and should always be housed separately. This game is about Roborovski dwarf hamsters, which are social:

OK, version 3 is up. If it is still not realistically solvable, I suppose I will just have to come up with an entirely different solution.

MUCHMUCHMUCH better! Of course now I think you’ve overshot in the direction of too many hints, but that’s just because I’d already thoroughly explored the previous version so the changes stand out to me. I immediately hit on the right path this time. The awarding of points is useful (again, I feel like it’s too useful, but I’ve already been thoroughly spoiled, so I’m no longer a good judge). Major spoiler-solution in the critique below…

[spoiler]“If the wheel were moving, you’d get squished into the ground or thrown into the air.” The hint doesn’t need to be so big or out-of-character. The last version simply didn’t have any text at all when you said “climb”, which was a major problem. I think an appropriate level of hintiness would be something like “You’re squeezed in between the bars and the wheel on the southeast side of your cage. [if wheel is moving]The rungs of the flying wheel are drumming against your back.[else]The rungs of the wheel are poking somewhat uncomfortably into your back.[end if]” Then you’d have to TURN to grab the flying wheel with your paws before you’d actually be flung. (This requires that TURN be more fully implemented, although if its current behavior weren’t so cluebattish, I might never have gotten as close as I did to the solution in my earlier attempts.)
It was not obvious to me at all that my running on the wheel would eventually encourage Boo to do so; this time I figured out really fast that that was my goal, but it was just by accident that Boo happened to be nearby while I was experimenting with the wheel. Kiwi was always “dashing away” from my current location, and commanding “BOO, ENTER WHEEL” had given a dismissive response. Requesting things of the other hamsters should give a very gentle hint; I dunno, something like “Boo is more of a visual learner.”
It’s kind of weird that TURN works once Boo is already running on the wheel. She just switches direction in tandem with you? I think you should have to EXIT WHEEL and wait a couple of turns (just a couple) for Boo to stop running before you’re allowed to switch directions. Also, if you ENTER WHEEL while Boo is already running, the messages need to indicate that you match her stride, or something.
Also, you can enter or exit the wheel (or tube) while carrying things in your paws. But the game isn’t smart enough to automatically get out of the wheel (or tube) before going NORTH or whatever.

climb coconut. down. // should work the same as “get down”
Again I may be spoiled, but I liked the implementation of Kiwi following the carrot. Again the implementation has realism problems: I can hold the carrot in my paws while sitting in the spinning wheel.
Is there a reason that Kiwi doesn’t follow the lab block the same way she follows the carrot? (Incidentally, as a non-hamster-owner, I’ve never heard of a “lab block”, but the EXAMINE text is perfectly sufficient.)
get carrot. put carrot in pouch. drop carrot. // should work, without having to “get carrot” a second time before dropping it
get carrot. run. run. run. run. run. // will eventually get you from A to B, without ever needing to use your pouches
exit. s. s. e. run. // starts the wheel spinning without actually being inside it. oops!
dig. // still needs to be implemented sensibly everywhere, not just in the one place it’s useful
run on wheel. // seems like a natural thing to type, but doesn’t work[/spoiler]

Version 3 is definitely what I’d call a decent puzzle game. Which is to say, it’s finally sunk to my level. :wink: I like it!

Fourth and (hopefully) final version is now up. Enjoy. (Is it spamming IFDB to post an announcement that the final version is up?)

It never is. In fact, I would urge every author to put up a news announcement for EVERY new version release.

I think maybe I am stuck, I will keep trying for a few minutes. Also seem to maybe be a few bugs:

[spoiler]1. dig with no response:

Cage East This is another place where the litter is nice and thick and good for digging. You bury stuff here all the time. There’s a paper tube here. You can also see a lab block here. To the northwest you can see a coconut. To the north you can see Kiwi and a water bottle tip. To the south you can see a wheel.

dig litter
If you want to dig, just dig.

  1. “nothing is running on the wheel”

Cage East This is another place where the litter is nice and thick and good for digging. You bury stuff here all the time. There’s a paper tube here. You can also see a lab block here. To the northwest you can see a coconut. To the north you can see Kiwi and a water bottle tip. To the south you can see a wheel.

x wheel It’s a wire wheel for running on. It’s lined up with the east side of the cage. nothing is running on the wheel. It’s spinning. In the wheel is Boo.[/spoiler]

After using a hint I completed it. A couple of other thoughts:

1. “run north” doesn’t work
2. “in” doesn’t work to get in the wheel
3. after getting the lab block it’s not obvious it is small enough to store in your pouches, unless you are familiar with lab blocks - its description is a “big block of hay”.
2. “drop carrot” doesn’t work if the carrot is currently stored in your pouches

Heh. That’s good news, though with (for instance) my Apollo 18 games I would have flooded the news and pushed some worthy reviews down the list. As much as I appreciate being able to do so on IFDB, I really don’t want to push back reviews, because those’ve been helpful to me.

I’ve been fiddling with the idea of monthly or bimonthly lump updates and news, with something special if I feel I really have tried something new. Maybe having established guidelines would help people feel less awkward posting a news release? Because I have to admit News Release is kind of a $5 word to me.

Oh, I would have welcomed news releases for the Apollo games. It maddened me that “She’s actual size” was at v1, according to IFDB, whereas in reality it was v6, and I myself had v5.

I just noticed that the command “QUIT” doesn’t work very well, at least not in Parchment.>quit Really? You've only just started scurrying!and then there’s no prompt; it is in fact waiting for a “y” or “n” response, but there’s no indication that it’s waiting for input at all. If I type “y”, nothing happens when I hit return; I guess the game just decided to exit without any further interaction. If I type “n”, I get a game prompt again, but without any acknowledgment of what just happened:[spoiler][code]>quit
Really? You’ve only just started scurrying!
Please answer yes or no.> n

I can’t hear you!

Coconut Inside
It’s all warm and dark and cozy in here.

You can see Kiwi here.


The “Really?” is possibly misleading, I guess. It is a question, but it could be worded better. As for the rest, it seems to be standard fare. You say “quit”, the game asks “Really?”. If you say no, you’re back in the game, no more questions asked - that’s how it’s usually done. If you say yes, then I think the interpreter quits and therefore you can’t input any more commands. If it were a J2ME application, it would probably close the application; if it were a computer program, the same. But since it can’t very well close the browser or your tab, it restricts itself to simply quitting the game.

I didn’t say it was hard to fix. :slight_smile: The minimal fix is to add a “>” prompt during the waiting-for-input phase, and an “OK.” once you’ve answered the question. Bonus points awarded for:

  • changing the “yes” response to “OK, goodbye.”
  • changing the “no” response to “OK, so you don’t quit.”
  • changing the “yes” response to also print your score (since this particular game is scored)
  • changing the text “You’ve only just started scurrying!” to “You’re doing so well!” if the player has, in fact, been scurrying for a while