Suddenly getting compiler error 2

Well, this isn’t great! Suddenly, I’m finding myself unable to compile anything in the Inform 7 IDE (Windows build 6M62) due to the above-cited error. I’d put my game aside for a week or so to let it percolate, but up until that point have never experienced this error before, and can’t think of anything I would have done to my computer that would have generated this error (from the error messages I’m getting, it sounds like a file permissions issue?)

Here’s what I’m getting from the report pane:

Translating the Source - Failed 
The application ran your source text through the Inform 7 compiler, as usual, but the compiler unexpectedly failed. This should not happen even if your source text is gibberish, so you may have uncovered a bug in the program.

When a program like the I7 compiler fails, it typically returns an error number: this time, the number was 2, so I7 probably stopped because of a fatal file-system error.

It is very unlikely that your computer is at fault. More likely causes are:

•disc space running out on the volume holding the project;
•trying to run a project from a read-only volume, such as a burned CD or DVD;
•trying to run a project which belongs to another user, whose files you have no permission to alter.
However, if you think it more likely that the Inform 7 compiler is at fault, please check that you have the currently distributed build of the system: if you have, please consider taking the time to fill out a bug report at the Inform bug tracker ( 

Sorry for the inconvenience.

And here’s the console dump:

C:\Program Files (x86)\Inform 7\Compilers\ni \
    -internal "C:\Program Files (x86)\Inform 7\Internal" -project "C:\Users\russo\Documents\Inform\Projects\Test.inform" -format=ulx
Inform 7 build 6M62 has started.
Can't open debug log
Offending filename: <C:\Users\russo\Documents\Inform\Projects\Test.inform\Build\Debug log.txt>

Compiler finished with code 2

Any ideas on what’s causing this, and how to un-bork things – maybe a reinstall would do the trick? – would be greatly appreciated!

In another thread, @artao described a problem which happened at a different stage in the process, but also produced a “Can’t open debug log” message.

According to artao, the solution was to deactivate Avast.

Don’t know if that helps, but it might be worth a try, and it’s quickly done. (Right-click the Avast icon in the system tray, then there should be an option to deactivate the protection for various periods of time, for example 1 hour. I think other anti-virus software offers similar options.)

And I guess it can’t hurt to ping @DavidK directly.


Thanks – my search terms were too narrow so I wasn’t finding that thread, but it was just what the doctor ordered; in my case AVG, not Avast!, in case others run into the issue. Temporarily disabling it fixed the issue (I guess a setting must have gotten automatically updated in the past couple of days, since I’m not sure why this was working before? But not going to look a gift horse in the mouth!)