Stian's IFComp 2020 reviews

Last House on the Block
An Interactive Fiction by Jason Olson

I sometimes do complain about under-implementation, but this game, I’m sorry to say, is not even close to being finished. On the positive side, I discovered a few seemingly unintended funny responses, such as:

>x rock
You see nothing special about the unusual rock.


>search bookshelf
There is nothing on the nearly-empty bookshelf.

Suffice to say it will not be particularly fun trying to rate this game. In it’s current state, it’s hardly playable, but the idea is sound enough, and I’m sure it could be fun when it’s done.


The Wayward Story
An entry by Cristmo Ibarra

Another piece of puzzleless parser IF, though I’m not sure I understood this one. Then again, perhaps I’m not supposed to. What seems to be wayward in The Wayward Story is the story itself. Alternating between mystical, adventurous places and familiar everyday situations, it certainly lives up to its billing as “surreal / slice of life”. The narrative seems to be the essential thing here, and the writing is pretty good, with a rather unique voice and embroidered descriptions of that which seemingly is deemed important. I’m afraid the story didn’t provide we with much though. However, playing through it took me only 20 minutes, while the estimated playtime is 90 minutes, which means I might just have missed out on large parts of it. On the other hand, I never felt that I left anything significant unexplored. If anyone should tell me that there is much more to it, I may give it another chance, otherwise I’m satisfied, even if not entirely convinced.

1 Like

An Interactive Fiction by n-n

Having provided me with two different endings in just over 10 minutes, one of which seemed optimal, BYOD is clearly the shortest parser game in this year’s IFComp, but it packs a lot of coolness into that time. Coming complete with an .nfo and an e-zine, this game puts you in the shoes of a humble hacker and lets you save the day. The feelies are fantastic, the hacking is elegant, and the implementation is flawless. Great stuff!


I had the same experience as you with Entangled. I got half the points. I was puzzled about the scarf, although I forgot to ask the guy about it and then he took off with the flask, so I assumed I just messed up. I still searched all over but couldn’t find any trace of him or the scarf.

I still don’t understand how the time travel happened in the first place. Did the PC just get included by stumbling in at the wrong time when the scientist triggered the machine? And then the scientist’s older self was there and they went kaboom? But the PC wasn’t injured or anything.

Actually, I didn’t even realize what had happened at the time, and it was only in retrospect, when I noticed all the people and some of the places were different, that I remembered there had been an odd message when I’d walked along the path through the field. It said something about there not being a diner in the past. Up to that point, the locations had all looked basically identical. I’m not sure if this confusion is intentional or not, but if not, then I’d say the descriptions of the places need to be a bit more obviously different. Could the abandoned house really not have changed at all in 40 years? …Did the whole house get sent back or something?

Also, the transcript attached to your message seems to be for a different game (Desolation).


Thanks for reviewing, glad you enjoyed the game!


I got the feeling that it was supposed to be confusing, that you are supposed to discover it gradually, but it’s a good point.

Oh, darn! Thanks for letting me know.

1 Like

by Jim Aikin

In Captivity, you start off as the fair maiden locked in the tower, but in contrast to most fairy tales, the boys trying to rescue you are completely useless. You need to make your own escape. To do so takes you (or at least me) around two hours, most of which are spent searching up and down the castle for various hidden objects. Some of these objects are only there after performing another action first, which means you may need to search everywhere twice or thrice. The problem with such puzzles is that they are not gratifying; what you get from them is merely the relief that you finally can proceed. To be fair, these are not the only puzzles in the game, though the rest are fairly obvious.

As far as fairy tales go, Captivity carefully balances traditional storytelling with a modern perspective, and does this pretty well. There are only sporadic touches of humour here, which makes it all the more effective, though there are not really any astoundingly funny moments either. Its strongest aspect is probably the various colourful characters you can talk to, who are all decently implemented.

The castle is relatively big, so it is no surprise that a lot of rooms are lacking relevant scenery, such as windows, or that things described are not implemented as objects. This, along with a few bugs here and there, do unfortunately hinder the immersion that I find is necessary to enjoy a fairy tale.

Comments for the author (contain spoilers)
  • At some point in the kitchen, you can “take all” and get things that don’t yet exist:

> take all
Gorlick won’t let you have the long-stemmed pipe while it’s in his possession. wooden platter: The cook scowls at you.
“That meat is for the master’s supper. Don’t you be messin’ with it, now.”
wooden platter: The cook scowls at you. “That meat is for the master’s supper. Don’t you be messin’ with it, now.”
You take the bowl of cherries.

> x cherries
You see no cherries here.

> i
You are wearing your beaded reticule and a necklace, and carrying a little enamel box, a sheet of music notation, and a

> x meat
You see no meat here.

> x wooden platter
You see no wooden platter here.

  • An unexpected response:

> tie shoelace to boots
Bibbidgy does not respond.

  • The dragon should probably not be fixed in place:

> take dragon
The baby dragon is fixed in place.

  • Embroidery in the duchess’ room is not implemented:

The Chambers of the Dowager Duchess
Framed pieces of Dowager Duchess Dorolinda’s embroidery decorate the walls of this floral-scented chamber. Throw-rugs in
a variety of colors, fabrics, and weaves are strewn across the floor. The doorway to the upper hall is to the east.

A wicker sewing basket sits over near the wall.

> x embroidery
You see no embroidery here.

  • TAKE ALL often makes you take the enamel box out of the reticule and put it in the reticule.

  • There is not really any way to know that the scissors need to be in the reticule when the duke suddenly arrives. Perhaps she can always put them there automatically, e.g. saying something like “You shouldn’t be running around with scissors”

transcript.txt (203.0 KB)

Flattened London
A Fanwork in Two Dimensions by Carter Gwertzman

I am fairly familiar with Flatland, but only had a brief glance at Fallen London prior to this game. Flattened London is a truly delightful mash-up of the two. Featuring a consistent, weird, and lovingly created world that shines of respect for its inspirational material, it offers some of the most intriguing exploration in this year’s IFComp. In this world, most everything is strange, but naturally so. It also remains mostly unexplained, but also naturally so.

Both the writing and the puzzles are impeccable, and fit right in, both in the narrative and in the world. Descriptions are just as detailed as they should be, and almost everything has been implemented thoughtfully. Although puzzles are slightly on the easy side, they are fun, and there are enough of them to delight and amuse; most of them can be worked on in parallel. It also seemed pretty clear that there are several ways to solve several of the puzzles, and there are several possible endings. In the end, I managed to reach a particularly enjoyable one in just over two hours. All through this I only stumbled on a few minor issues with the implementation, which is greatly impressive for a game of this size.

Comments for the author (contain spoilers)
  • The shelf in the elevator can be taken while rushing past it:

Elevator Shaft (in the cage-elevator)
You are deep in the earth.

The elevator rushes north, past what looks like a shelf carved into the side of the shaft.

>take shelf

The elevator screeches to a halt at the top of the shaft.

You are carrying:
a shelf

>x shelf
A niche in the side of the elevator shaft. Something wooden is inside.

  • After a while, the elevator disappears, though I can walk north/south through the shaft.
  • The rug should probably get a different description after you have traded it to the antiquarian:

Antique Shop
The place has a rather homey atmosphere. Ancient objects of all shapes and sizes are for sale along the walls, though most of them just look like junk. Outside, the desolate lane awaits. In the east wall of the shop is the door to a back room.

A beautiful old rug is spread out across the floor of the shop. There is no price tag.

Running the shop is a weary antiquarian.

>x rug
An antique rug from the people who came before, in excellent condition. You’re sure they wouldn’t mind you having this.

transcript.txt (219.8 KB)


Under They Thunder
A text adventure from OkayCo. New? Ooh, Nay by Amos and Abel Fay

This is a game that I was not looking forward to playing. Not because I expected it to be anything but impressively and lovingly implemented, but because I had already burnt myself trying two of the author’s previous offerings, Quite Queer Night Near and Very Vile Fairy File. In neither of these three games have I been able to make any progress on my own. It seems there are some type of word games I sincerely suck at, which is good to know I guess. This time, I only lasted about 15 minutes before feeling sufficiently confused. Needless to say, I will not be rating Under They Thunder; a lot of work seems to have gone into the implementation, and I’m sure it’s great for those who do get it.

That was actually the last game on my parser-games-that-can-be-run-in-a-free-interpreter list. A lot of them were brilliant, and I’m really impressed by the contributions this year.

This means that I do have time for some of the other games too. I have already played several of the choice/web-games, but not really devoted enough time to them yet for a review.

I must admit I’m a bit frustrated that there are so many games distributed as executable binaries this year: (s)wordsmyth, Creatures, Radicofani, Saint Simon’s Saw, Tangled Tales and Tragic. I am not able to play, rate or write about any of these. The reasons for this are:

  1. I run Linux.
  2. I generally don’t find it sensible to trust executable binaries that are not distributed along with the source code.
  3. My computer would probably be too slow for them anyway.

Some of them did look mighty interesting though.

Then there are the Adrift games, Just another Fairy Tale and Return to Castle Coris. I tried the former first in an alternative interpreter called Scare. That didn’t work. Probably it does not support the version of Adrift that the game was written in. I then tried a web link someone posted, but the game kept resetting my progress. I guess there is no good way to run Adrift games on Linux at the moment.

Lastly there are two Quest games, The Brutal Murder of Jenny Lee and Tombs & Mummies, which both seem possible to play through a web interface. It does warn of intermittent resets, but so far it seems more stable than the Adrift web runner. I’ll give these a go next.

Lastly there are two Quest games, The Brutal Murder of Jenny Lee and Tombs & Mummies , which both seem possible to play through a web interface. It does warn of intermittent resets, but so far it seems more stable than the Adrift web runner. I’ll give these a go next.

Quest: If you create a user and log in on , you can save your progress and you won’t be timed out. I tried this but experienced significant problems, but then I tried later and everything worked perfectly.

Online Play of ADRIFT games: Just realized that this feature is currently down. Hopefully, it will work for you once it is up and running again.


Thank you for letting me know!

Online play of ADRIFT games is up and running again. Links to the games in this post:
Online Play of ADRIFT games

It is certainly possible that the online player does not run well on (some?) Linux web browsers, but just in case, I want to mention:

  1. Unlike more modern online interpreters, online play of ADRIFT games requires internet access also after starting the game.
  2. To SAVE your game, simply type SAVE and note down the filename. Next time you return to the game, type RESTORE filename
  3. I have experienced, that sometimes when starting an ADRIFT game online, it shows the text from your last ADRIFT session instead of showing the introduction of the game you have just started. Typing RESTART should restart the game and show you the introduction, or you can simply RESTORE a save-file.

I hope it will work for you this time :slight_smile:


@Stian My game is no longer in the competion

Sorry to hear that.

Just another Fairy Tale
by Finn Rosenløv

This is a classic style fantasy adventure, seemingly written for young children, but much too hard for me. I picture the boy from Time Bandits as the protagonist, taken from reality and inserted into a fictitious world filled with magic and fraught with danger, but nothing a young boy can’t handle.

The reason I did not get very far in two hours is mainly down to the verbs. Perhaps Adrift has a different set of standard verbs than Inform and Tads; a lot of the ones I’m accustomed to were not recognised, and when I finally gave up and had a look at the walkthrough, the solutions surprised me. I was reminded of the challenges Jason Dyer writes about when playing very old games. In these games, you need to forget any expectation you have about which verbs will work and which will not. In a sense, Inform games have made me very comfortable with a certain way of interacting with parsers, and I’m not really equipped with the lateral mindset for something completely different.

As far as I came, I found the story to be quite okay. It’s very stereotypical, but also cute in a way. The moments in which it shines are whenever it is obvious that you are a little boy, and a rather obedient one at that. A feature I enjoyed – which sometimes was necessary, but only occasionally implemented – was being able to examine elements over a distance. In the end I think I might have enjoyed it more if I had consulted the walkthrough earlier and gotten a bit further, though that would also have been counter to my instincts.


You might be right that there are a few differences between ADRIFT’s default verbs and those of Inform/TADS. However, another explanation can be, that many of the authors come from the British tradition in the 80s/early 90s where the homegrown games often were equipped with a VOCABULARY command. The other ADRIFT game actually has a VOCAB command. It is also recommended to read the playing instructions of that one.


That’s very good to know, thank you!

Return to Castle Coris
by Larry Horsfield

Like Just another Fairy Tale, this game takes on the classic style fantasy genre head on, albeit with a more adult focus. The writing is remarkably solid, which perhaps is not surprising, seeing as Return to Castle Coris is episode eight of a series. Here, the action takes place underground, further and further into the unknown. It actually reminded me a lot of certain games taking place underground that I played in the past, especially Ultima Underwold and Legend of Grimrock. Such were the feelings evoked by the writing. Unfortunately, however, I found this even harder than Just another Fairy Tale; not only are the verbs many and (to me) obscure, but it seems you also have to imagine nouns that are not described, and perform rather random actions that work in specific places while giving no informative response in others. Perhaps it’s a learning curve, going through the episodes chronologically. At least I managed to die spectacularly a few times.


While the Adrift webrunner worked pretty decently this year, I had much less luck with the online Quest interpreter. I have been trying to play The Brutal Murder of Jenny Lee, but after four attempts over roughly a week I’m giving up for now. There is a disclaimer on the web site that the online interpreter can be quite flaky, and these days it has been fairly impossible to play more than 5-10 minutes without serious issues.

From what I did experience of the game, the narrative style was appealing; you are an embodied consciousness sent to various places in the past, trying to piece together what really happened. It seemed enjoyable, and I hope I will be able to play it in the future.

1 Like