Stian's IFComp 2020 reviews

The Incredibly Mild Misadventures of Tom Trundle
An Adolescent Reminiscence by B F Lindsay

If you are looking to experience more of Lindsay’s intricate and sometimes-perhaps-a-bit-too-clever parser puzzlers like the Bullhockey! series or Frenemies, this game will sadly disappoint. Or will it?

Having just reached two hours of playing time I took a brief glance at the walkthrough to see if I’m anywhere near the end. It seems that this is definitely not the case.

In contrast to the author’s previous games, the first hour and a half is surprisingly straightforward. The story is completely linear and you are always nudged in the direction of the next step. Then, with a boom and imagined laughter in the background, the game suddenly explodes with possibilities. Half an hour later, I managed to figure out just a few of the now quite tricky puzzles, and it seems there will be many more ahead.

I will definitely pick up The Incredibly Mild Misadventures of Tom Trundle again and try to finish it, but perhaps not until the comp is over. Although I now have high hopes that I may yet bang my head in frustration at Lindsay’s puzzles, I’m afraid the two hour limit is way too short to properly enjoy the game.

transcript.txt (271.5 KB)

1 Like

Jay Schilling’s Edge of Chaos
By Robb Sherwin & Mike Sousa

The strongest aspect of Jay Schilling’s Edge of Chaos is the storytelling, narrating a crazy and imaginative story with a language very much suited to it. To be frank, neither were perfectly up my alley, but it is of consistent and solid quality.

The puzzles are not that interesting, however. The game is completely linear and the solution to the obstacles are for the most part so obvious that they feel more like small nuisances. There are a few exceptions to this – some clever constructions, but also one that I found far fetched and impossible to guess without reading through all the hints for it. The hint system was very thoughtfully implemented though, with clues in order of specificity. My final playtime was 80 minutes.

A nice bonus were the images: lovely drawings of several characters that show up the first time you look at them.

Comments for the authors (contain spoilers)
  • The diamonds and patterns are described but not implemented:

>x rug
It’s huge and dominates the floor plan of the room. It has two outside rectangles along the border with a reddish, brownish pattern. Almost like the eyes of the illuminati repeated every eight inches or so. Inside these rectangles are diamonds in a 2-1 2-1 2-1 pattern. These patterns have a bit of a regal shape to them. (I say “regal,” confident that Persia once had queens, I guess.)
Now that I focus on the illuminati pattern a bit more, the rug appears to be covering something up.
>x diamonds
I see no diamonds here.
>x pattern
I see no pattern here.

  • The ceiling and opening are described but not implemented:

>push candlestick
The light comes on again. I see it plainly now, there is a very, very tiny little opening in the ceiling in one corner. A red light is now visible from it.
>x ceiling
I see no ceiling here.
>x opening
I see no opening here.

  • The autocorrect is sometimes a bit silly:

>wave at light
(wake an light)
The infrared camera is too far away.

  • The ‘it’ pronoun does not always refer to the last mentioned noun:

>unlock left drawer
(with the tiny key)
Unlocked.
>open it
The post-it note is not something I can open.

  • The one puzzle that I could not figure out was blowing at the cartridge. I had never heard of this issue, and it would not have occurred to me.
1 Like

The Eleusinian Miseries
An Interactive Farce by Mike Russo

For being the first game of the author, The Eleusinian Miseries is remarkably well done. The implementation is more or less as flawless as they come (at least in the face of a deadline), and I found nothing here to remark on.

Being first and foremost a historical-farcical puzzle game, it seems to be heavily inspired by the excellent Lost Pig and The Wizard Sniffer (this one also features a pig!) and provides them with good company. The approach to humor is similar, although here it feels at times a bit too verbose. Most of the 90 minutes I spent playing The Eleusinian Miseries were spent reading, rather than thinking how to solve puzzles. While the puzzles do a good job of retaining the humoristic style, they are not particularly challenging.

transcript.txt (229.6 KB)

3 Likes

Hi Stian – thanks for the review, and the transcript!

I have played Lost Pig, sufficiently many years ago now that most of the details have receded, and hadn’t come across The Wizard Sniffer, though now that I have it’s on my to-play list – maybe there’s just something in the structure of a farce-heavy parser game that makes an author think “you know what this needs? A comedy pig.”

3 Likes

Ascension of Limbs
Interactive Fiction by AKheon

Despite it never mentioning Lovecraft, the feeling I got from playing Ascension of Limbs is very much Lovecraftian, more so than from many works that are outright fan fiction. Some of the paths the game allows you to choose are pretty gruesome, though always in the service of a higher… something. Other paths still imply this something, although more peripheral.

To accommodate the approach of an antique store proprietor simulation, the list of verbs have been strictly limited as have the possible nouns you can refer to. Considering the mechanics of the simulation this is certainly reasonable, although it feels visually a bit messy to constantly have the full lists repeated after each command. A two-column format would have been an improvement. Other than that, the parser system has been very well adapted to this type of game. You easily get the hang of it, while doing it well is a certain challenge.

Playing Ascension of Limbs provides a curious feeling actually. The very visible game mechanics and the objective voice of the narrator explaining how your store is doing are coupled with horror elements that get more and more central to the game as you progress. You can serve the dark forces, but the level of abstraction lets you get away with it, emotionally; it’s an emotionally peculiar game.

I did two playthroughs with two different endings in about one hour, though I only managed a fraction of the achievements either time.

transcript.txt (128.4 KB)

3 Likes

The Magpie Takes the Train
A short tale by Brian Rushton

Having, as one should, duly enjoyed ‘Alias’ The Magpie, I was very excited to see this sequel among this year’s IFComp entries. To my further enjoyment, it turns out this sequel is almost just as good! Not that there is anything particularly wrong with it; I just wish it was longer and slightly more challenging, matching the length and difficulty of the original. Completing The Magpie Takes the Train took me 45 minutes.

Perhaps due to having played more IF than (most?) other humans, Rushton has managed to perfectly adopt the style of ‘Alias’ for this game. The language, the humor and the puzzles could all as easily have emerged from J. J. Guest, and are just as delightful. It certainly wouldn’t surprise me if this ends up being the game that takes home the prize.

Comments for the author (contain spoilers)
  • I tried ‘take all’ very early in the game and it was perhaps more revealing than intended:

>take all
tray full of drinks: The tray has a glass of grape juice, a glass of water, a glass of soda, and a glass of vodka on it.
glass of grape juice: You grab the glass of grape juice from the server’s tray. He grunts in acknowledgment and continues to stare at the floor.
glass of water: You grab the glass of water from the server’s tray. He grunts in acknowledgment and continues to stare at the floor.
glass of soda: You grab the glass of soda from the server’s tray. He grunts in acknowledgment and continues to stare at the floor.
glass of vodka: You grab the glass of vodka from the server’s tray. He grunts in acknowledgment and continues to stare at the floor.
papers: That’d be difficult to do discreetly, and taking it doesn’t serve your ultimate goal at this time.
grooming kit: Hogg glares at you. “That’s for Horus!” she declaims. “You’re not his groomer!”
tweezers: The grooming kit isn’t open.
emery board: The grooming kit isn’t open.
toy mouse: The grooming kit isn’t open.
cracker: Taken.
cracker: Taken.
cracker: Taken.
cracker: Taken.
cracker: Taken.
magazine: That’d be difficult to do discreetly, and taking it doesn’t serve your ultimate goal at this time.

  • Once vodka has been thrown at the viscount, the same action again gives a suboptimal response:

>x vodka
A strong drink. This is strong enough to strip paint off!
>x viscount
The Viscount is a perennial passenger in Hogg’s observation car, although he never seems to speak. He is wearing a wide hat and a heavy scarf. You could recognize him from his pungent odor alone, though.
>throw vodka at viscount
That isn’t available.

  • The viscount’s neck has some peculiar properties:

>x neck
The Viscount has an unusually smooth neck.
>touch neck
You touch the short tanned neck. It feels exactly as you expected.
>kiss neck
You can only do that to something animate.

transcript.txt (76.8 KB)

11 Likes

Stian,

Thanks for taking the time to play and share your thoughts on our story! Much appreciated!

– Mike

3 Likes

Stuff of Legend
A Lazy Medieval Comedy of Errors by Lance Campbell

Yet another historical comedy, and this was an especially funny one, despite the notable absence of pigs. The writing is mostly superb throughout and manages to make the village idiot protagonist genuinely likeable.

The puzzles were suitably clever, with some rather unique ones; it took me quite some time feeling lost in the middle of the game until I figured out that I needed to be creative with the verbs. In the end I finished the game in about 90 minutes and learned several new words on the way.

Early on, I started mapping the game, believing the explorable area to be much larger than it actually was. It turned out this was not necessary at all, but I include it here anyway.

Map

Comments for the author (contain spoilers)
  • You get no response from “put firewood in oven”:

>take firewood
The firewood is far too bulky to carry around with you. You don’t want to end up looking like an idiot…
>put firewood in oven
(first taking the firewood)

  • It seems unlikely that the stream shouldn’t be able to contain things:

>put straw in stream
That can’t contain things.

  • When trying to take mud, the parenthesis info changes “mud” into “stream bank”, which doesn’t sound very takeable:

>put mud in left
(first taking the stream bank)
You attempt to take some of the mud from the stream bank but it runs right through your fingers. Maybe you should try to find find a container for it.

  • “barrels” is changed to “grain”, even when trying to open them:

>open barrels
Maybe it is because you are a village idiot, but you can’t figure out a good way to open the grain.

  • The description of Clara seems to contain a typo (“is always says”):

>x clara
Clara is a pretty woman with intelligent eyes and a radiant smile. She is a devoted wife and mother, and she is always says nice things to you, although some of those nice things seem less nice than others.

  • The hole in the bucket is described but not implemented:

>put mud in bucket
The milking bucket is practically falling apart and there is a big hole in its side. You decide not to put anything in it.
>x hole
You can’t see any such thing.

transcript.txt (189.9 KB)

5 Likes

Desolation
An Interactive Fiction by Earth Traveler

A brilliant homage to certain classic works of IF, Desolation certainly lives up to its title, putting the player in a desperate situation with only one way forward. The pacing is excellent, feeding the feeling of running away from danger in desolate surroundings, emphasised by suitable bursts of real-time delays in the narration.

The puzzles are not too complicated, especially for those who have played the games Desolation pays tribute to, but delightful to tackle nonetheless. My only real criticism is of the ending, which came very suddenly and felt premature, like the ambitions had been cut short by a deadline. I’m hoping for a continuation.

Comments for the author (contain spoilers)
  • Since I first couldn’t take the pickaxe, I tried to use it for digging without picking it up. That gave quite a frustrating response:

>dig water with pickaxe
You simply need to DIG NOUN.
>dig water
With what? Your bare hands?
>dig mountain
With what? Your bare hands?
>dig mountain with pickaxe
You simply need to DIG NOUN.

  • The bag and rope are described after they’re taken:

>l
Middle of a Rocky Slope
You emerge from a gap in the rocks and find yourself in a relatively flat part of the slope, a small plateau before it rises again and meets what looks like a small rock wall way up at the top of the slope.
More interesting right now, however, is what’s on this little plateau.
Yet another skeleton is lying on the plateau.
Next to the skeleton is a bag and what looks like a rope.
>take bag
You already have that.
>take rope
You already have that.

  • The rock should probably get a different description after killing the dog:

>attack dog
You flail with your pickaxe, now only wielding it with one hand. You manage to sink the point into flesh and the dog yowls in pain and finally gets off your chest. You sit up, pull the pickaxe out of its paw and without hesitation you slam it into its head and it yells again. Then a second time, and then a third, and then a fourth just for good measure after it twitches again.
You stay sitting there for a moment, breathing heavily. You stand up after a minute or two…
…and then comes the pain, stinging your left arm. You look down at your arm and immediately wish you hadn’t. The skin is completely torn up in several places, especially on your forearm, and on your upper arm the bites go so deep you’re pretty sure your actual bicep is showing - or it would be if blood weren’t pouring out of the wound.
You glance at the dead guy’s bag. Maybe he was carrying something that can help with…this.
>x rock
A small rock. Hopefully enough to scare off that dog.

  • The path is described but not implemented:

Top of the Rock Wall
You drag yourself onto the top of the cliff and stand up. You look around a little. There’s the slope you just climbed up from, and there’s a dusty path leading down around a… either an ambitious boulder or a small mountain.
There is a stake embedded at the top of the wall.
>x path
You can’t see any such thing.

transcript.txt (49.8 KB)

2 Likes

Seasonal Apocalypse Disorder
An Interactive Fiction by Zan and Xavid

A puzzle-heavy game that in its current state is unfortunately severely under-implemented. Around half of mentioned nouns could not be referred to, and many actions gave peculiar unintended responses. With polish, however, Seasonal Apocalypse Disorder could turn in to a fine piece of IF. The world building is particularly interesting, inspired by several fantasy tropes but adhering to none. The strangeness here reminds me a bit of the Myst series; it is not similar, but rather similarly strange. Probably due to the particular ending I managed to reach after just under two hours of play, some of the world remained unexplored and some questions remained unanswered.

The puzzles are generally good, though hampered by some confusion resulting from the lacking implementation. As expected from reading the description, you travel through time in order to affect the future through your actions. This, the authors have managed to construct quite well. Neither of the puzzles I solved were anywhere near far fetched, but it still felt like a good challenge.

If the game gets a proper update, I might be tempted to play it again and try to reach a different ending.

transcript.txt (168.4 KB)

Here is a list for the authors containing various extracts from my transcript where I felt something should be implemented: notes for the authors.txt (7.3 KB)

3 Likes

Thanks for your review and kind words. Glad you enjoyed my game.

I will definitely use your suggestions. Always glad for an opportunity to improve my work so I greatly appreciate the feedback.

3 Likes

Lovely Assistant: Magical Girl
An Interactive Fiction by Bitter Karella

Another smart – and particularly well written – puzzler that needs quite a bit of polish on the implementation in order to be truly enjoyable. Described nouns can not be seen, worthy synonyms are not understood and objections are being made to using objects in objectively reasonable ways. A pity really that so many issues are present as otherwise it may have been a worthy contender for best game at IFComp 2020.

As Karella is an experienced author, it came as no surprise that the narration is solid and professional, with a unique language suited to the strong characters and humoristic premise. The puzzles were properly reasonable, apart from being very strict in terms of how to properly formulate the required actions.

My complete playthrough took just over one hour, though quite a bit of that time was spent compiling a list of comments for the author.

Comments for the author (contain spoilers)
  • The chair in the study can not be sat in:

>sit in chair
That’s not something you can sit down on.

  • Curtains in bedroom are described but not implemented:

Your Bedroom
Your bedroom is decorated entirely in pink, from the wispy curtains surrounding the canopied bed to the big overstuffed heart-shaped beanbags that serve as chairs. You’ve decorated the walls with posters advertising some of the biggest venues and events that you’ve performed with Mugwort.

Mounted on the wall is a perfectly ordinary crosscut handsaw.

You can also see a crystal ball here.

>x curtains
You can’t see any such thing.

  • The beanbags cannot be sat in, and it feels unlikely that they should be fixed in place:

>sit in beanbags
They’re not something you can sit down on.

>move beanbags
They are fixed in place.

  • “cut floor with saw” doesn’t work:

>cut floor with saw
I only understood you as far as wanting to cut the wooden floor.

>cut floor
You shove the handsaw into the floor and, with some considerable effort, eventually find that you’re able to make a cut through the floor. You continue sawing, gradually circling around the zigzag cabinet… until the floor becomes too unstable and, with a mighty crack, the boards split and the zigzag cabinet falls through the floor and down to the ground floor.

  • Sink elements are not implemented:

>x sink
The hot and cold water spigots of the sink are two ornate bronze fishes; they vomit water when you turn the tap on.

>x tap
You can’t see any such thing.

>x fishes
You can’t see any such thing.

>x spigots
You can’t see any such thing.

  • Bathtub can not be entered:

>enter bathtub
That’s not something you can enter.

  • Helmet and hat can not be worn:

>wear hat
You can’t wear that!

>wear helmet
(the helmet)
You can’t wear that!

  • Books/shelves in the library are not implemented except for the grimoire and the openable shelf:

Library
The library is a large, stately room in the moorish style, with tall sturdy shelves carved from solid black walnut wood set into keyhole arch-shaped alcoves in deep blue tinted walls painted with decorative hamsas and nazars. Every inch of shelf space is filled with books of all shapes and sizes. A round table in the center of the room is barely visible beneath stacked piles of books. The gallery is to the west. The billiards room is to the south.

The bookshelf has swung open, revealing a passage to the east.

>x shelf
You can’t see any such thing.

>x shelves
You can’t see any such thing.

>x books
You can’t see any such thing.

>x book
You can’t see any such thing.

  • Robotic nouns are not implemented:

>x robot
Smithereens is a custom-designed mechanical automaton made to fulfill all the butling needs for a modern man-on-the-go. His face plate is painted with a dapper mustache and his body chassis is painted to look like he’s wearing a tuxedo. His treads are currently rusted solid after an incident where he butled his way into an ornate Greco-Roman style fountain on the back 40, so he’s currently immobile. Mugwort was intending to get around to fixing that. He does have some useful features, though: His extensible arms can in theory telescope to dust in hand-to-reach places, and his lazer heat ray eyes are in theory good for lighting cigars.

>x arm
You can’t see any such thing.

>x treads
You can’t see any such thing.

>x tuxedo
You can’t see any such thing.

  • The silver key is not visible through the vent despite being mentioned:

>x outlet
There’s a narrow ventilation outlet built into the floor, covered by a metal grated faceplate. Lots of dust and debris has accumulated in the vent since Smithereens stopped cleaning, and you can make out the glint of something small and metallic – a shiny silver key – hiding amongst the dust bunnies just out of reach.

>take silver key
You can’t see any such thing.

  • When trying to solder things that shouldn’t be soldered, no response is given:

>unsolder vent with head
>l

  • “book” is not accepted as a synonym for “cookbook”:

>x cookbook
Boffo has it open to the recipe for Coq au Vin, a dish requiring chicken, mushrooms, garlic, and wine.

>x book
You can’t see any such thing.

  • Garlic should be singular here:

>eat garlic
They’re plainly inedible.

You can also see a cookbook and a pot (in which are some garlic) here.

  • I typed just “use” at the maze:

>use
What do you want to use hedgeclip with?

>x hedgeclip

  • “fresco” is described but not implemented:

Atrium
The atrium is a modest but still impressive room meant to welcome guests to Mugwort Manor. An umbrella stand and shoe rack are placed next to the front door; a large fresco on the ceiling recalls Michelangelo’s Creation of Adam with the notable difference that in this depiction God is offering Adam his choice of playing cards. Above then, two cherubs unfurl a banner bearing the inscription “Colligunt enim Pecto, Stirpe sórores Pecto!”

The atrium opens up into the gallery to the south. The front lawn is accessible to the north. A spiral staircase leads up to hallway of the second floor and down to the wine cellar below.

>x fresco
You can’t see any such thing.

  • “cask” is not accepted as a synonym for hogshead despite being the description:

>x hogshead
A wooden cask full of cheap red wine.

>x cask
You can’t see any such thing.

  • “plants” are described but not implemented:

Garden
The garden is a tastefully wild tangle of plants, both edible vegetables and ornamental flowers. A small ziggurat, designed to mimic the Mesopotamian style, has been erected at the far east end of the garden.

The entry to the ziggurat is blocked by a sphinx.

You can see a pyramid door here.

The sphinx turns its head to watch you, gears grinding loudly.

>x plants
You can’t see any such thing.

  • The maze is not implemented:

Hedge Maze
The hedge maze is more ornamental than actually baffling; since it’s really just a single spiral and the hedges are below eye level, it’s virtually impossible to get lost in here.

You can see Chuckles the gardener and some hedgeclippers here.

>enter maze
You can’t see any such thing.

>x maze
You can’t see any such thing.

  • The feedback from turning/moving telescope could imply that the player does turn/move it. It would be better to get a response that you do not wish to turn/move it:

>look through telescope
You squint into the telescope’s eyepiece, twisting the mechanism to bring the view into focus. There’s nothing of interest visible on the moon.

>turn it
Nothing obvious happens.

>move it
Nothing obvious happens.

>look through telescope
You squint into the telescope’s eyepiece, twisting the mechanism to bring the view into focus. There’s nothing of interest visible on the moon.

  • In the lab, “equipment” is described but not implemented:

Laboratory
The laboratory is a dark room filled with strange and unpredictable equipment, deliberately decorated to resemble a mad scientist’s abode from an old 1960s Hammer horror film; your hair stands on edge as you enter, but you’re not sure if that’s due to the room’s suddenly spookt atmosphere or all the static electricity generated by the row of Jacob’s ladders. The library is west through the secret passage.

The conservatory is to the south.

You can see a plasma globe here.

>x equipment
You can’t see any such thing.

  • In the pool table, “holes”, “pockets” and “tubes” are not implemented:

>x table
It’s for playing pool. Interestingly, unlike most pool tables, the corner holes do not lead to simple pockets but rather to a series of tubes leading down into the body of the table. Mugwort has rigged the table so that sinking all the balls in one shot triggers a mechanism inside the table to open a trapdoor in the floor. It’s very impressive to Mugwort’s more impressionable guests.

>take balls
Taken.

>put balls in holes
You can’t see any such thing.

>x holes
You can’t see any such thing.

>x pockets
You can’t see any such thing.

>x hole
You can’t see any such thing.

>x pocket
You can’t see any such thing.

>x tubes
You can’t see any such thing.

  • When trying to unlock the trapdoor with something, the response implies a visible lock:

>unlock trapdoor
What do you want to unlock the trapdoor with?

>balls
Those don’t seem to fit the lock.

>x lock
You can’t see any such thing.

  • “bats” and “implements” are described but not implemented:

Mugwort’s Room
Mugwort’s room is decorated in dark style that can best be described as Halloween goth, with painted bats plastered across the ceiling and guazy black curtains over the windows. The walls are painted black and the air is heavy with a cloying incense that makes you choke.

There is a bed of spikes made to look like a coffin in the center of the room as well as other torture implements that Mugwort uses in his act, such as the guillotine and the drill of death.

>x bats
You can’t see any such thing.

>x implements
You can’t see any such thing.

  • The drill bit can not be referred to when part of the drill:

>take drill
The drill of death is far too large to remove from this room. But if you could somehow remove the drill bit, that could be useful.

>take bit
You can’t see any such thing.

>take drill bit
I only understood you as far as wanting to take the drill of death.

  • When next to the drill, you are told you need a drill to drill:

>drill dove with drill
You’ll need a drill to do that.

  • “wine” is not accepted as a synonym for pouring from hogshead:

>drill hogshead with bit
You press the point of the drill bit against the top of the hogshead and slowly start to turn it. It takes some effort, but eventually the bit starts to penetrate the wood. After a few minutes you have successfully drilled a hole into the hogshead!

You could pour the wine out now…if only you had a receptacle.

>pour wine in helmet
That’s not something you can pour.

>pour wine into helmet
That’s not something you can pour.

>put wine in helmet
(first taking the wine barrels)
You can’t take them.

>fill helmet with wine
That’s not a verb I recognise.

  • The hole in the hogshead is described but not implemented:

>x hogshead
A wooden cask full of cheap red wine. There’s a hole drilled in the top.

>x hole
You can’t see any such thing.

  • “plate” is not implemented as a synonym for “coq au vin” despite the initial description:

>pour wine in pot
Boffo nods as he sees you place the last ingredient in the pot. He tosses the chicken in as well and begins tossing the coq au vin mixture. A delicious smell fills the room and evetually he ladles out a large helping onto a plate and hands it to you.

>x plate
You can’t see any such thing.

  • The food is described as inedible and without a particular smell:

>x coq
You see nothing special about the coq au vin.

>eat it
That’s plainly inedible.

>smell it
You smell nothing unexpected.

  • Torches in the basement are described but not implemented:

Basement
The basement is decorated to resemble the burial chamber of Egyptian Pharaoh Tutankhamun, the ceiling supported by ornate papyriform columns and light provided by flickering torches held in scarab-shaped wall sconces. It’s all very ostentatious for a room meant to store boxes of old clothes and busted furniture bound for the thrift store.

>take torch
You can’t see any such thing.

  • A trapdoor is described as leading down from the grotto, but presumably this is just the trapdoor leading up:

Grotto
The grotto is a cavernous room designed to resemble an undergound cave lake, based on Ludwig II’s private opera theater in Neuschwanstein castle. Mugwort performs special private shows for select fellow initiates into the magical arts and sometimes bachelorette parties and bar mitzvahs. There is a stage for performers and guests watch the action from ornate swan pedal boats bobbing in the shallow water. A canal leads off to the south.

There is also a trapdoor leading to the lower areas of the house.

transcript.txt (138.8 KB)

4 Likes

Standing on the Shoulders of Giants
An Interactive Fiction by Ilmur Eggert

A rather cute fan- and fantasy fiction featuring Isaac Newton as its protagonist, Standing on the Shoulders of Giants is a short story in parser format rather than a game. As the playing time was less than 10 minutes, the experience never achieved a deep level of immersion or engagement, but the writing was solid enough to carry it through. The story itself was friendly and somewhat imaginative, but lacked the depth and/or length to make it properly interesting. While parser commands are used to progress, puzzles are just about absent, and exploring is explicitly discouraged in room descriptions.

transcript.txt (22.4 KB)

1 Like

Vampire Ltd
A Corporate Espionage Adventure (with Vampires In It) by Alex Harby

Short, funny and easy, Vampire Ltd offers 15 minutes of delightful IF escapism, to a world where vampires suck. The writing is lovely; though not particularly unique it’s certainly a good foray into the humoristic style that characterises a lot of popular IF. Although the puzzles are straighforward, they are mostly well implemented, fun and fits the story well. The lack of other entries on IDFB indicates that this may be the author’s first IF, and if so it’s certainly a solid first effort.

transcript.txt (61.1 KB)

6 Likes

Thanks for the transcript and the kind review - glad you enjoyed the game!

1 Like

Deelzebub
By Morgan Elrod-Erickson, Skyler Grandel, and Jan Kim

This is a game where I found myself resorting to hints. Not because the puzzles are particularly difficult, but because the parser was frustrating, to the point where it was not fun any more, and I just wanted to finish it within the two hour limit. In addition to guess-the-verb-issues on every corner, most of the progress is being done with “ask/tell person about something”, which in the end resulting in me adopting a brute-force approach, asking and telling everyone about everything in turn. On top of that, I also ran into several cases of runtime errors – nothing game breaking, but certainly adding to the frustration.

I would like to point out, however, that I loved the premise, the characters, and the writing of Deelzebub, and I sincerely wish I had played a more polished version of it.

Since QTads is not very accommodating with transcripts, I’m afraid I wasn’t able to supply more detailed comments for the authors.

Academic Pursuits (As Opposed To Regular Pursuits)
An Interactive Fiction by Ruqiyah

Puzzleless and for the most part smoothly implemented, Academic Pursuits uses the parser format to tell a story in a clever way. While not essentially humoristic, the gradual discovery of new information – conveyed by the thoughts and feelings of the protagonist in the process of unpacking – has twists and turns that made me smile. It’s all well written and I really appreciated this way of storytelling.

Comment for the author (contains spoiler, sort of)
  • The parser was confused by certain ways of referring to “book” and “shelf”.

>x bookmark
A flimsy old paper bookmark. Wasn’t this marking a page in a book?

>x book
A chunky, fancy-looking hardcover book titled Solving the Mysteries of the Sangsue Town Murders. A square is cut out of the back.

>put boomark in book
You glance around the office, but can’t see any such thing.

>put bookmark in hardcover
You flip through the hardcover book until you find the marked page, and slot the bookmark in.

>put souvenir on shelf
(the bookshelf)
There might be space for the souvenir on the narrow upper shelf of the bookshelf.

The souvenir is too tall to ever fit on the narrow shelf.

>put it on bookshelf
There might be space for the souvenir on the narrow upper shelf of the bookshelf.

The souvenir is too tall to ever fit on the narrow shelf.

transcript.txt (40.6 KB)

1 Like

Vain Empires
An interactive memoir by Thomas Mack and Xavid

“I’m from Hell, and I’m here to help.” … and Vain Empires is off to a very good start.

The premise for this game is a quite unique take on demonic intervention, and as a consequence the method of interaction with the world here is both interestingly different and somewhat tricky to get used to. Having finally accomplished the first part (standing at 11 out of a possible 75 points) in exactly two hours, I feel that the hour-and-a-half estimate in the blurb is overly ambitious. There is nothing wrong with the puzzles though, quite the opposite: They are clever and challenging but so far also entirely reasonable. What makes them particularly challenging is that they often are timed, or rather turn dependent; starting off a chain of events, success depends upon performing certain actions at specific turns during those events. This leads to a lot of trial and error, but also to a great sense of accomplishment in the end.

Sporting a suitably unique backstory, the protagonist has a lot to say about itself in the beginning. This felt a bit too verbose, that it was overemphasising its difference to humans in a way that was annoyingly quasi-philosophic and devoid of humour. Although that may just be the way demons are… After a while it turns mostly silent, however, and what we are left with are very much textbook room descriptions; unoriginal, but solidly implemented. In fact, the whole implementation is impressive throughout the first part. I’m definitely looking forward to finish Vain Empires later on!

Comments for the authors (contain spoilers
  • The first sentence “It’s a mistake to anthropomorphize humans” is not particularly logical, since “anthro” means “human”.
  • The dealer is described but not implemented:

>x cards
Cards shuffle across the felt as the onlookers rap on the tabletop, make inscrutable gestures to the dealer, and grimly flick chips into a small pile in the center.

The fine details of the game are alien to me. The fine details of human nature are not, though; and judging from its expression, I’d say that the gambler has quite a lousy hand.

The gambler cautiously throws another batch of chips into the pot.

x dealer
I don’t see any dealer here.

incomplete transcript.txt (269.4 KB)

4 Likes

The Impossible Bottle
An interactive fiction by Linus Åkesson

The turn finally came to play The Impossible Bottle, another game I have really been looking forward to. Åkesson is the creator of the Dialog authoring system and his three games seem to have been made in tandem with its development. Being fundamentally different in terms of both premise, story and interaction, they each play to different strengths of Dialog. This time, the author presents us with a real puzzlefest, and it is as delightful as they come.

Taking on the role as a six year old girl you start the game tidying up your toys, but it soon turns into a clever, whimsical and imaginative journey through your house in order to make everything ready for dinner. Storywise, The Impossible Bottle certainly alludes to Alice’s adventures in wonderland; it is equally surrealistic (though admittedly far less trippy). And like the books about Alice, Åkesson’s story also contains hidden layers of depth that are gradually uncovered during play. Despite a few instances of parser strangeness, the implementation is mostly brilliant, and the writing, though sparse, is perfectly suited to the protagonist and her world.

It took me just over two hours to finish The Impossible Bottle, and I loved every minute of it!

Comments for the author (contain spoilers)
  • “turn switch with shovel” gave a funny pair of choices, which should be synonymous but only one works:

> turn switch with shovel
Did you want to:

  1. turn the light switch with the shovel, or
  2. switch the light switch with the shovel?
    (Type the corresponding number)

> 1
You can’t reach the light switch.

> turn switch with shovel
Did you want to:

  1. turn the light switch with the shovel, or
  2. switch the light switch with the shovel?
    (Type the corresponding number)

> 2
You manage to reach the switch, only to be rewarded by a cracking sound and a bright spark. The bulb has burned out.

  • The description of the pillow, saying it is supposed to be on the bed, should probably be different when it is on the bed:

> x bed
Nibbles lies slumped in one corner of it. There’s also a pillow.

> x pillow
Soft and fluffy. It’s supposed to be on your bed.

  • “shoe” is apparently a synonym for the outdoor clothes, which seems a bit strange in this case:

> x shoe
Outdoor clothes for rainy days. You haven’t had much use for them lately.

  • While small, it seems unlikely that there is no room for you under the sofa (this may be the case for other furniture too, I didn’t check too closely):

> go under sofa
You drive over to the huge sofa.

There’s no room for you under the huge sofa.

  • I don’t really understand where the gaping hole in the landing came from; it’s only there when you are small, and apparently it can’t contain things:

Landing (in the fire truck)
A vast floor spreads out in all directions. In the middle, a gaping hole leads to a series of platforms, half surrounded by sparse columns that connect in the form of a gigantic railing high above you. There are doors in the far distance to the north and west, and an open doorway to the south.

> look into hole
The gaping hole can’t contain things.

  • If I take the music box from the doll house while the hamster is inside the large version of it, and go to where the large version was, the description of that room still contains the hamster running in the cylinder. The same for trying “x hamster” in that room:

>take music
As you fumble with the music box, the microscopic hamster falls onto the floor of the upper right room.

Got the music box.

> i
You have:
a music box

> s

> s

Room with striped wallpaper
A window in the eastern wall overlooks the main street. Open doorways lead west and north.

The hamster runs as fast as it can inside the cylinder, driving the musical mechanism. A low-pitched, slightly wrong La Cucaracha fills the room, on repeat.

> x hamster
It’s a perky brown hamster with bright, curious eyes and the cutest little paws. Pushed down over its ears is a hamster-sized woolly hat.

The hamster runs as fast as it can inside the cylinder, driving the musical mechanism. A low-pitched, slightly wrong La Cucaracha fills the room, on repeat.

  • The sink contains “a water” and can’t contain things:

> search sink
A water is in the sink.

> x water
A few drops of water are in the sink.

> look inside sink
The sink can’t contain things.

  • I tried to pry open the crate, but pry is here a synonym to push.

> pry
(I only understood you as far as wanting to push something.)

  • The oil can can’t contain things, and the water could get stains:

> empty oil can
The oil can can’t contain things.

> put oil can in water
The water could get stains.

  • Typing “roll” when in the rolling chair thinks you mean the woolly hat:

> x chair
Mom’s working chair can spin and roll across the floor.

> enter it
You get onto the rolling chair.

> spin
You practise your moves.

> roll
A black hamster-sized woolly hat, with “ROCK’N’ROLL” in white letters across the front.

  • You can’t put things in the water:

> put bundle in water
You can’t put things in the water.

transcript.txt (446.5 KB)

4 Likes

Shadow Operative
An Interactive Cyberpunk Fiction by Michael Lauenstein

When given the choice, I strongly prefer to play IF in a local interpreter rather than a web browser. It’s faster, uses less memory, and I can adjust the fonts to my liking. In the case of Shadow Operative, the author was quite insistent that I play the web version. So I tried it, and I’m glad I did.

Visually, the interface of the web version is really nice. The colours and fonts are somewhat similar to the Alien Night theme here at intfiction.org, which, combined with the good looking cover art in the top right corner, sets the mood nicely. For further mood enhancement, there is also music, though it was impractical for me to listen to it while playing. The window is divided into three columns: the leftmost lists accepted verbs and available exits, the right column shows the inventory beneath the cover art, and in the middle we find the command window which works exactly as I’m used to from Lectrote.

Of particular note is that relevant nouns in the output are links. This makes it possible to play the game using only the mouse; I tried it a bit, but for me, typing was faster. The downside to this is that playing it in an interpreter would have been quite a frustrating experience, as most nouns are not links, and therefore not implemented at all. I’m not entirely sure this is the case; I tried a few non-link nouns and they were not recognised. Another consequence of this is that the play experience becomes extremely streamlined, the exploration limited, and the puzzles really easy with such a small noun space. As such, the challenge was next to none and I was able to finish it in less than an hour.

Still, the writing is decent enough to make Shadow Operative engaging for that time. The cyberpunk elements are stereotypical – including VR cyberspace, biohacking, and touches of Japanese culture – as is your eventual mission, but in a rather cute, nostalgic way. There is also a brilliant twist in the story that took me by surprise.

transcript.txt (119.5 KB)

4 Likes