Spatterlight 1.1 released

You can now set a theme to be activated automatically in dark mode, and another in light mode.

Also includes a new option for flicker in Scott Adams games, as discussed in this thread.

Get the new release here:


Hey Petter, what’s the leftmost column in the browser window for? i.e. The one to the left of Title. It used to just be blank. Now it has a bunch of pause symbols in it (like the pause button on a remote control.) Except next to the Hugo game in my browser list, which has no symbol.


That is the status column. It has always shown a symbol if a game file is missing, but release 0.9.9 added symbols for “playing” (open, running games) and “stopped” (open games that have ended.) In 1.0 a “paused” symbol was also added, for autosaved games.


Cool, thanks.


Does Spatterlight’s Z-machine use Glk or does it have Z-machine I/O?

It uses Bocfel, just like Gargoyle, so that would be Glk.

1 Like

I’ve just fired up Spatterlight (Apple Mac Store version, listed as 1.2) for the first time in a while, and I can’t get games to open - the games list itself shows fine, but when I double click to play a game, nothing happens. It seems the game is running somewhere, because if I try and play a different one, it warns me about closing the first one. Am I doing something silly? Or perhaps it’s not working on the latest MacOS currently?

1 Like

That shouldn’t happen!

The GUI autosave and Core Data database format has been changed a couple of times, but the new code is supposed to open older formats gracefully. Do you happen to know which version you upgraded from?

It might be interesting to take a look at your internal autosave files. They should be in ~/Library/Containers/Spatterlight/ and ~/Library/Group Containers/

Also, everything should work if you delete any autosaves, if you don’t mind losing your progress. Just right-click on the game in the library and choose Delete Autosaves from the contextual menu.

EDIT: If that does not work, you might try just deleting the game from the library and re-adding it.

Thanks, I didn’t upgrade, I’d run 1.2 a few weeks ago without an issue. Anyway, thanks to your tip, I’ve “fixed” it by deleting all my games (nothing would open) and re-adding them. Cheers!

Glad it worked out. I realised I had a very similar bug report back in 2021. The reporter fixed it by deleting the application state file. Could this be the same issue?

Not quite the same - for one thing this was all game formats. I could also delete the games from the library without an issue.

It might still be the same underlying cause. I implemented deleting running games after that report.

Did it happen with other formats than Z-code and Glulx? The others don’t autosave and autorestore, and should never attempt to reopen at startup, so they shouldn’t be affected by this.

I can’t be sure unfortunately. It was every game I tried, and I have a lot of games, so I strongly suspect it was all formats.

1 Like

If you have any idea of how to reproduce this, or something similar happens again, don’t hesitate to let me know.