[SOLVED][Scott Adams] Format limitation, or compiler bug?

EDIT: I have figured this out. My problem was using the 3-letter abbreviation DRO. If I use DROP instead, the problem is solved.

For the Year of Adventure I’m creating a game in Scott Adams format, using Mike Taylor’s compiler sac. I’m running into a problem with trying to display a custom message when dropping a specific object.

Here’s a short sample game source that illustrates the problem:

%start r1
%wordlen 3

%action Q
%valias Q QUI

%action INV

%room r1
little room
%exit e r2
%item ball
%getdrop BAL

%room r2
big room
%exit w r1
%item stick
%action GET STI
here stick
get stick
msg I got it!
%action DRO STI
carried stick
drop stick
msg Dropped.

I compile the game with sac, and play it with Gargoyle.
Getting either object and dropping the stick all work fine, but when I try to DROP BALL I get the response, “I don’t understand your command.”
I was wondering if maybe this is just a limitation of the format, that you can’t give a custom response to a DROP command.
But Adventureland does it with several objects, and Voodoo Castle does it with the rabbit’s foot.
Is this a bug in sac?

Mike Taylor’s SAC shows to be a very promising compiler, very competent as well. It might as well be full use of it. I am probably going to make some online versions of my SAC based games by turning into a z-code then Parchment it.