[Solved] Debian Wheezy I7 dependencies

I first tried installling via the deb package from the main website. (gnome-inform7_6G60-2_i386.deb) But it seems to be corrupt. So I headed over to the gnome inform Git page, but that install didn’t work due to a missing dependency, so I looked for that. It seems to have been depreciated on debian already. No luck with that as well though. At this point I was just fiddling, so I went into the software manager to try and find an old version and see if that would install the libwebkit version I needed. Surprisingly, it failed to install because the file no longer exists. (?)

I’m kind of at a loss with what to do next. I would prefer to use downloads from Git, but I cannot get those to work as of yet. The libwebkit would probably be a good place to start but I can’t find the download within the debian repositories anymore.

I’m using x86 Debian Wheezy (stable).

The libwebkit package can be found on the ubuntu website; that might work?

I’m hesitant to use ubuntu repositories as I’ve read that they aren’t really compatible binaries… is what I was going to say, but I found all the dependencies I needed under squeeze (oldstable) in the debian repositories, I7 has started and appears to be working.

Thanks for the help, I feel a little bit silly but now at least I can continue. Marking this as solved.