[SOLVED] Can't get Leadlight to work

I’m on a Windows Vista computer. I first tried running the ActiveGS standalone application. It seemed to work fine until it got time for me to actually enter my first command. I could type whatever I wanted, but hitting the enter key does nothing, so the game wouldn’t progress. So I tried following the instructions for playing online found on the website for the game, installing the ActiveGS plugin for Firefox. And I get exactly the same behavior. It’s as if every key is understood except the enter key.

Has anyone else seen this issue? And has anyone actually been able to play it? I’m also going to contact the author and see what he says.


The desktop version works perfectly for me on XP. Is there a way to run the .exe on Vista with compatibility enabled perhaps?

This ran for me on Win7, but I had to copy it from where the Installer put it to my Desktop, because Program Files (x86) was “write-protected” from the point of view of the emulator.

Tried running it in compatibility mode for XP, and still got the same behavior. Same for all the other compatibility modes.

Also tried running it from the Desktop instead of the Program Files directory where it was installed. Still the same behavior.


Also tried running as administrator, on the desktop, in compatibility mode. Still nothing. The program appears to recognize every key except the enter key.



Have you tried [Shift]+Enter or [Ctrl]+Enter instead to see if this works?

Does your keyboard have multiple enter keys? I find (using a Windows 7 laptop) that the key at the right of the main keyboard, but to the left of the keypad, behaves as I would expect, while the key on the keypad behaves as you have described.

I had tried the various modifier keys plus enter, and no go. And I was using the normal enter key, but pressing either that or the keypad enter key produces the same results.

I heard back from the author, and he suggested that I use the older Apple IIe emulator, AppleWin. The directions are here: leadlightgame.com/faq/faq.html#OLDPC. It involves downloading the AppleWin emulator and then also the 2-disk version of the game. And now the enter key works for me, so I can play the game.

Thanks for the suggestions, all.



Thanks for posting that link. I was hoping to run the game on AppleWin, which I already have, rather than the supplied ActiveGS emulator. I wasn’t having problems with ActiveGS, it was more a matter of interface preference. The fact that ActiveGS installed a folder in My Documents without permission was another strike against it.

Now I can get on to playing what looks to be a promising game.

Same here.