I’ve been having problems running Six by Wade Clark. Whenever I type “listen” in the place with all the different kinds of trees, there’s fatal exception error and the terp closes. I think it says something along the lines of not finding a sound file? Anyway this happens both in WinGlulxe and Gargoyle. Thanks in advance for your help.

Hi, this is Wade. I’ve not seen a fatal crash like that before in any of the interpreters. May I ask what OS you’re running? If you’re using several interpreters, you’re probably using all the up to date ones, but it’s worth making sure you are using the latest Gargoyle. Could you also let me know what exactly the error says? Thank you.

Something else to try is this: Delete the files sixdata1 and sixdata2 from the game folder before rerunning in Gargoyle.

If none of the above solves the problem, perhaps try turning off both sound and music at the start menu before starting the game, though this is obviously less than ideal and can’t be guaranteed to be the source of the problem, but worth a shot.

The error says “Glulxe fatal error: Reference to non-existant Glk object.” And after testing it some more, it appears to only occur after I restore a saved game; that is to say, I can play through game as normal if I start from the beginning, but restoring a saved game seems to set the bug off. And, come to think of it, the fancy googaws at the top of the screen are gone when I restore a save, too. Hmm. Are saved games working for anyone else?

(P.S. My OS is Windows Vista, and all my interpreters are the latest versions available on the IF Archive.)

Thanks for reporting back, Healy.

One of my playtesters experienced a crash on restore problem, but when we checked his situation carefully, his version of Gargoyle was out of date (it was from 2009 - the latest is from 2010) - and when he moved to the latest Gargoyle it didn’t happen anymore.

I have experienced confused in looking for versions of interpreters in the archive myself. Some of the file names and filing can be convoluted. I recommend you try downloading Gargoyle from Gargoyle’s own page here, rather than the archive:

Unfortunately any saved games you made before may not work anymore. But if you start a fresh game with the latest Gargoyle, I have a feeling (fingers crossed) you won’t have any more problems.

Thanks for your patience, and for pointing out the problem.

PS - If anyone experiences a startup-ish failure of Gargoyle running under OS X Lion for any games (have not experienced this myself but I saw it reported) there is a temporary fix build of Gargoyle available that should get around the problem:

Direct link to the file: … c_r557.dmg

A link to the development page explaining the issue:

I’m planning to do a real release of Gargoyle soon. I’m just waiting on the latest Alan 3 source code to become available.

(That Dropbox link goes to my account, in case anyone is concerned.)

I’ve informed the ALAN developer Thomas Nilsson of your intent to release a new version of Gargoyle soon.

Oh, he knows. [emote]:)[/emote]

Okay all I’m stumped. How do I catch Jack as Harriet? I have chased him everywhere and tried everything I can think of to do it.

Okay, I think I remember. Let’s check…

[spoiler]At one point you’re given this clue:

But not something that’ll hurt him, of course.[/spoiler]

Ah! Got it, thank you. I thought of that option but for some reason thought I had tried it before.