Sitting and Standing Are Awful in Inform

So I have a scene where I want the player to be able to sit in a chair and get up. And I HATE THE DEFAULT BEHAVIOR. Entering it causes the room description to be displayed again, with (on the chair). Getting off the chair, same thing. So I try:

Instead of getting off the armchair1:
	try silently getting off armchair1.
	
Instead of entering the armchair1:
	try silently entering armchair1.

and get a “memory stack is exhausted” error, which I understand is caused by having the same action instead of an action. Do I really need to spend a bunch of time recoding the sitting/getting up actions to meet my needs, or is there a simpler way to just allow the player to sit and stand?

4 Likes

Hmm, I don’t think reprinting the room description when entering an enterable supporter is part of the standard rules – is there some other rule you’ve written that’s doing that? For suppressing the re-description on exit, you can just do:

The describe room stood up into rule does nothing.

(With added conditions as you like – there are circumstances where re-setting the scene can be helpful, though I agree getting off an ordinary chair isn’t one of them).

BTW when my tired eyes quickly flicked over the title of the thread, I read it as “Sting and [something] Are Awful in [something]” and I felt attacked :slight_smile:

3 Likes

That worked perfectly. And I guess I was wrong about the sitting. It was reprinting the room description when I initially moved the player to the armchair and I-- shockingly-- leapt to conclusions.

That is terrible. You know I loved your game. Although bee attacks are really, really awful and scary, so there’s that.

3 Likes

All true! Though there are other As with a blue background out there, maybe one of them is a bee-phobe who lost an eye in a sailing race, it’s very possible.

2 Likes

I’m having the same problem without the happy results. My player was in the wooden chair. The command was “stand.” I got the room description again.

The describe room stood up into rule does nothing when myScene is happening.

I tried it with “when the location is myRoom” and “when the player is myAlterEgo”. I’m using Inform for Windows 10.1.2.20220830.

1 Like

Huh, it’s still working for me in 10.1 (sorry, I’m on my phone so can only use Borogrove). Just confirming your chair is an enterable supporter? If you post a minimal example that reproduces the issue I (or someone else smarter and/or in front of the right IDE) might be able to figure it out.

1 Like

Changing my chair from an enterable container to an enterable supporter fixed the problem.

Thank you!`

2 Likes