Shuffling around question about weird bug

Hi, I have a question about the latest version of Shuffling around. Has anybody else got the following problem?
In the “store i” region, there is a room called “room”. There are also hoses which become shoes. After making the shoes, they are in your inventory, but examining them gives the result “BUG”. Changing the room to moor seems to be the solution, but the game tells me I can only do that with better footing. I assumed I’d only need the shoes here, but they don’t seem to register as being worn. Is there a way to fix that or is my solution false? (I really don’t want to use the gadget to skip that region.)


I don’t know, but I’m guessing Andrew Schultz will. Tagging @aschultz


Hmm, what you did should be right. This doesn’t happen for me in version 3 or 4, but I probably tried different commands than you did.

I thought I tested for this sort of thing at the very minimum, so I’d be disappointed if it got out, but it’d also be a good excuse to (finally) put out the next release. I think/hope a lot of bugs have been shaken out.

One possibility is that there is another piece of clothing you need, which you may not have gotten yet, and I am giving the wrong explanation.

I’ll look into it. If you have a transcript, send it to me, too. I’d be grateful.

1 Like

Oh, I didn’t even realize there was a release 4. I just grabbed the one from IFDB, which seems to be 3. Maybe this wouldn’t have happened with version 4. Sadly I realized too late that a transcript might be useful. The attached text file contains all the text my interpreter (Lectrote) still showed at this point.
I completed store f, then I entered store i, transformed every item in the kitchen and then walked into the “Room”. There I first took the hoses and then I typed “shoes”, which worked. That’s the point where the file begins. Sorry I couldn’t help more.Shuffling Around error.txt (3.4 KB)

1 Like

Your transcript did the trick. Thanks for taking the time!

Taking the hoses before changing them is what caused the bug.

It’s still a bug in release 4–but I don’t know where I sent release 4 to, anyway. Apparently, I fixed it back in 2017, according to Git, but I haven’t released a version since then. I think IFDB has a link to release 3. ifarchive might have release 4 … but I should probably put it on my page.

Well, as I said, this is a reason to push for a new release sooner rather than later. There may still be bugs, but this is a big one.

I still don’t know if the reject message is satisfactory. I should also really add a general “take all” test case for other items. There is always one more test case to check.

PM me with how you’d like to be credited as a bug reporter. I’d be glad to give you credit, because it’s a good bug to have fixed, and you made me aware of a much wider set of things to test.

1 Like