Script command not working

I was trying to experiment with Trizbort as a mapping tool (auto-mapping) and I can not get scripting to work in Inform (using ver 6G60). I did a search of this forum and saw another mention of this, but no real reply if there was a problem or not.

I have tried script, script on, transcript, transcript on… and the reply from Inform is always the same:

“Attempt to begin transcript failed.”

I am using the Windows version of Inform, I mention that because in the other thread where this problem was mentioned I saw that someone said the script command worked for them on the Mac.

So is there a way to get the script function to work? Or do I have to wait and hope this problem will be fixed in the next Windows version?

Thanks for any help.

You can “Release for testing” and script from there, at least on my machines.

I just tried, and it does. I was trying to do it from within the Inform IDE for simplicities sake. Not having to switch back and forth between programs.

If I have to, I will. But it would be easier to do it all within Inform.

But thanks, at last now I can play with Trizbort and see how well it maps.

If you’re running a Glulx game, it ought to be possible to rig up your own transcript command using an external file and the window-echoing phrase wrappers in Flexible Windows. However, it may be that the Windows IDE disallows all external files, not just the SCRIPT command…?


Maybe, I am not sure. This was really my first attempt at creating an external file. And it is (so far at least) a z-code game. But as I learn more that might change. I just hadn’t gotten to a point where I needed to go to Glulx… and I would need to change a few things to get it to look right. For example, the changing of colors in the exit lister extension. I use a version of it in my status bar and the color coding makes it much easier to tell what rooms have been visited in the list of exits and in the compass rose. There may be a way to accomplish the same thing in Glulx, but I haven’t found it yet.

But like I said, still learning. :wink: