Room Description Control by Emily Short not working

I was going to try playing around with this extension (Room Description Control by Emily Short), and I got this message when trying to compile:

Translating the Source - Failed
The application ran your source text through the Inform 7 compiler, as usual, but the compiler unexpectedly failed. This should not happen even if your source text is gibberish, so you may have uncovered a bug in the program.

When a program like the I7 compiler fails, it typically returns an error number: this time, the number was 10, and that probably indicates that the compiler failed to manage its data structures properly. Perhaps you created a complicated situation on which it has not been fully tested.

The best option now is probably to reword whatever was last changed and to try again. Subsequent attempts will not be affected by the failure of this one, so there is nothing to be gained by restarting the application or the computer. A failed run should never damage the source text, so your work cannot be lost.

If you think it likely that the Inform 7 compiler is at fault, please check that you have the currently distributed build of the system: if you have, please consider taking the time to fill out a bug report at the Inform bug tracker ( If you think the fault may be due to a problem in an extension you’re using, then please contact the extension’s author directly.

Sorry for the inconvenience.

Has anyone else ever had this issue with this extension or others? If so, how did you solve it? Thanks in advance!

Do you have the current version of Room Description Control? If you go to the Extensions tab in the Inform application, you should be able to go the Public Library (look for the tab at the top) and look up Room Description Control under Commands–>Looking. If you have the current version, there will be a tan button saying “Installed.” If you don’t have the current version, there will be a blue button telling you to “Update.”

The details of the above are how it works on the Macintosh. It might be different on other operating systems. If your application doesn’t have a Public Library tab, you can check to make sure you have Version 12 of Room Description Control.

You may have got the extension from the site. This is actually largely a repository for outdated extensions that work with older versions of Inform–when Inform changed to the Public Library system the old versions were kept available there. Unfortunately that’s not very well labeled on the website so it’s easy to get caught with the wrong extension. Updated extensions are usually found in the Public Library or at Github sites somewhere (so one thing you can do is find an interesting-looking extension on the old site, look for it in the Public Library, and then search the web to see if an updated version is posted on Github).

Thanks, matt w. Also, thanks for telling me about GitHub; I had no idea that the extensions from the Inform site were outdated. As for Room Description Control, I did indeed have an outdated version of the extension (Version 10), and therefore updated it to Version 12. However, I still get the same error message. Is there something I’m missing?

This tends to mean that something has gone horribly horribly wrong deep in the hidden internals of Inform. Could you post your source text here?

I see the same thing.

Well, actually, if I try to use this extension I get:

“I can’t find the extension ‘Plurality by Emily Short’, which seems not to be installed, but was requested by: ‘Include version 4 of Plurality by Emily Short’”

Couldn’t find Plurality in the public library. Couldn’t find Plurality at the GitHub site. Found it at the main Inform site (which I’m usually told is outdated). Installed it.

When I do, I get the exact same translating problem with Room Description. Source text is:

Include Room Description Control by Emily Short.

Example Location is a room.

There is a message about “Compiler finished with code 11.”

I tried using the example from Single Paragraph Description by Emily Short.

[code]“Scene Setting”

Include Single Paragraph Description by Emily Short.

Amphitheater is a room. "The amphitheater [regarding nothing][are] currently empty of spectators, though [we] [can] see a magnificent view of the valley beyond the orchestra. ". A play script and a ball of wax are here.

A mask is here. "On the floor [regarding the mask][are] a mask. "

Test me with “look / get all / look / drop all / look”.


I tried compiling it both with and without “Include Room Description Control by Emily Short.” but still get that same error message.

Mmyeah, this looks like a problem with Room Description Control. Up-to-date extensions shouldn’t include Plurality, because the functionality of Plurality has been subsumed into the adaptive text features of version 6L02 and later. (You don’t need Plurality’s [it-they] anymore because [they] is built in, and so on.) Which means that the I6 inclusions in whatever version of Plurality you’re getting are probably causing the error.

(The reason this happens: If you run the Inform 7 compiler on properly syntaxed I7, it’s supposed to turn it into properly syntaxed I6, and if it doesn’t turn into properly syntaxed I6 the compiler gets very worried and gives you the unexpected failure message. But if your extension has some I6 inclusions that are improper–or, in this case, that depend on some code that was in the I6 code that’s built into the old version and not the new one–then you get the same failure message, because it seems to the I7 compiler that your good I7 has turned into bad I6. When what really happened is that the extension injected bad I6 in without consulting the I7 compiler.)

Anyway, I’m semi-officially monitoring the board for Emily now, so I’ll get in touch with her about this. There was another issue with one of her extensions that I can bring up too.

Thanks, matt w!

The latest version of Room Description Control is in the i7/extensions repository on Github, here.

Well, the Public Library should definitely have the version that works. I’ve e-mailed the extensions library maintainer to let them know about this.

And even nonsensical I6 shouldn’t make NI crash like that. (You should get a different message about how translation succeeded but compilation failed.) This indicates a bug of some sort.