Remedial Witchcraft

https://ifcomp.org/ballot#entry-2131

First IFComp 2019 game I tried and it is solid. I very much liked that the teleportation wand/rock were used in multiple puzzles in different ways.

I was slightly disappointed that count books after it told me there were too many books to count didn’t yield 69105. :stuck_out_tongue:

I didn’t love the ending and thought there might be another better ending, but a look at the walk-through suggests not.

Overall I’d say it set the bar pretty high. :smiley:

3 Likes

Especially given the references to Junior Arithmancer and Lime Ergot and Lewis Carroll and Douglas Adams. :stuck_out_tongue:

Yeah, that was disappointing. Otherwise it was nice, though fairly buggy. Nothing game-breaking, just annoying. But it looks like it has been updated. I’ll have to try that version.

Just got to the updated version myself (that is, the updated version of 8 Oct, which is the most recent update listed). It looks like the updated version introduces new bugs?

For instance, in the initial “get the crystal ball puzzle,” a step in the solution involves saying a magic word. Figuring out what to say isn’t hard; it’s the first lookup puzzle in the game. But the game doesn’t seem to understand any variation I can come up with on say nnai; say nnai and nnai and say “nnai” and speak nnai and a half-dozen other variations, including the simple say nnai in the provided walkthrough just result in the game replying “What does that mean?”

I’ve verified that it works in the original version, which I guess has bugs of its own. Am I just missing some obvious alternate phrasing here?

Your syntax is right. Does your character know the magic word yet? That message means (or should mean) that they might not have encountered it yet.

I got stuck that way in the original version as well, but couldn’t duplicate it. Oh, wait, maybe I can. I think if you look at your homework first, then try say nnai before looking it up in your Runecraft textbook which is in your backpack, then it gets stuck in that state. But the first time I encountered it, I kept trying things and eventually it worked: I’m not sure what I did…ah. Try x rune; look up rune. That seems to break out of it.

Otherwise I think it fixed everything I saw. Except one typo: when making the potion, it says “allow it cool”, not “allow it to cool”.

Hmm! Well, that’s all working as intended. I could just accept the magic word even if Lina doesn’t know what it is…

I made the name of the rune the same as the word to activate it in this case just for simplicity, but your character shouldn’t know that just from looking at the homework.

So I suppose I need to figure out where the breakdown is occurring; if you don’t mind me asking: is the homework not communicating that you don’t know the activation word yet and you need to keep looking, did you miss finding the backpack, or did you miss the use of the textbooks?

No, I’m pretty sure there’s an actual bug there. Start the game and try this sequence:

e
take all
w
drop stool
get on stool
get on table
take ball
x ball
x homework
say nnai
open backpack
look up nnai
say nnai

If you guess that say nnai might be useful and try it before opening your backpack and looking it up it seems to lock you into a state where it never works even after looking it up.

Once you get stuck, if you do x rune; look up rune it seems to break you out of it, so it’s fairly specific, but it does seem like a bug to me that look up rune by itself does not teach it to you; you have to x rune again first.

rune bug.txt (6.9 KB)

2 Likes

This was also one of the first I played from this ifcomp. And wasn’t disappointed, I really loved this game. It was funny, I liked the setting, the puzzles were not and not too easy nor too hard for my liking.

It was a bit short though. Agree with regard to the ending, well,… I hope there will be a sequel.

2 Likes

Good thing I played “For the Cats” after this game, else I would have played that one differently. Probably by looking for more bad endings.
I enjoyed the game. I looked once into the walkthrough which I shouldn’t have needed if I examined more carefully (couldn’t find the upper room, I interpreted the brooch as wanting me to go up from the “Divination Area” directly and I also just examined the house but not the roof).
One small logical problem I think I found was that the notebook lists the missing cabinet stuff before I got told in a cutscene what is missing.
I played the October 13th version.