Remebering login details?

Firefox / Linux remembers my details; Firefox / Windows requires me to relogin each time. (It does hold by username & password, when I get to the login page, though.) Any idea why?

Not sure, but FF on w2k works fine for me. Your post reminds me that I should upgrade to 2.0 though. :smiley:

Windows FireFox is working for me. Maybe it’s a bug in The only versions I have installed are 1.0.7,, 2.0 beta 2, and 2.0 released. Sounds like a cookie problem to me, like it’s not remembering the “automatically log me in” checkbox. You’re checking that box, right?


Well, you should try deleting the cookies that say If the url you’re coming in on is different, that might cause it (cookie is set for, so if you use or a different capitalization, that might cause it).

(update #1)

Yes, I have reproduced your problem. The cookie domain is, so if you use any domain other than that, it won’t work. The reason it remembers your username and password is because Firefox remembers (you might have clicked “remember password” the first time – which is what I did in testing this).

You can see it by typing this in your URL:


If you go to (or any variation of that doesn’t include the www, has different capitalization, etc), you’ll have the problem.

I can see about removing the domain entirely. It should be optional, and save for the current domain, but I’ll have to check.

(update #2)

I’ve changed the cookie domain to blank, so it should save for whatever domain you’ve entered into your browser. It should work now.

Looks like the upgrade opened this problem again; it remembers but not

I really should disable the domain, or have it auto-reroute at the server level. None of the setup is meant to work with that domain specifically.

It’s probably not a bug – the cookie domain is simply set to “” Maybe last time we changed it to blank or “/” slash or something. I don’t remember what it was set to before.

I’ll try to tweak the server settings so that it automatically removes the dash for any URL encountered, and see if that works.

(Edit #1)

Ah, I see in my prior post that I set the cookie domain to blank last time. I could do that again, I guess. But I’d rather force all domains into at the server level. It’s cleaner.

(Edit #2)

I’ve set up a permanent redirect on the server, so that the following URL’s automatically send you to the equivalent:

That should fix the problem you’re having. As a fallback, I can probably change the cookie domain to blank again, but I think redirection is a better long-term solution.

Seems to be working.

I’m having this problem now. (I think it started with the last upgrade, but I may be mistaken as I didn’t visit here that regularly before.)

Safari on Mac, in case it matters, and I visit and not any variation of it.

How often is it happening? Everybody had to log back in two or three days ago after my web host changed physical server hardware (moved to a new facility). If you haven’t been by in two or three days and it has only happened once, then that’s probably why.

Every time. I’ve tried clearing the cookies, but that made no difference.

This is a problem I’ve had quite often myself - only on Safari on my Mac. I have to log in fresh at least once a day.

iPhone works fine, as does my PC at work.