Relationships which are backwards

I spotted this while playing with the “ownership” relation:

[code]Ownership relates various things to one animal.
The verb to be owned by means the ownership relation.

Mr Socks is an animal.

The badge is a thing. It is owned by Mr Socks.
The scarf is a thing which is owned by Mr Socks.

The Garden of Confusing Relationships is a room.
All the animals are in the garden.[/code]

When you run this code, you see that Mr Socks and the scarf are in the garden: e.g. Inform thinks both of them are animals. And in fact you can confirm that the relationships have been parsed backwards:

>relationships Ownership relates various things to one animal: The badge >=> Mr Socks Mr Socks >=> the scarf

To me, the clause “which is owned by” should be grammatically equivalent to a new sentence starting “It is owned by.”
Is this a bug? Or a subtle feature I’m misunderstanding?

All the best,

This works:

The badge is a thing. It is owned by Mr Socks. The scarf is owned by Mr Socks.

So does

The badge is a thing. It is owned by Mr Socks. The scarf is a thing owned by Mr Socks.
Perhaps Inform is hanging up on more than one “is” in the same declaration? “is a thing which is”?

Thanks HanonO,

I think that makes it clear it’s a bug (as it’s symmetrical in the case you found, but not my similar one.)
I’ll raise a bug report on that shortly.

So… I’ve tried to raise a bug on the Mantis tracker, but the signup is broken.
Who should I get in contact about that?

[rant]On first signup attempt, it didn’t send a registration email.
I eventually tried a Password reset, got the email, but it says the account is disabled.

Second attempt, I tried with a backup email address. This time I got the email. All looks good.
But the account is marked as disabled.[/rant]

I’ve beeped the Inform team about this (I’m the semi-official person who lets them know about truly urgent issues on the forum).

Thanks matt w! I spotted that I was logging in with my email address rather than username (because so many sites allow/prefer that these days…) oh well…

Logged the bug as