Ramus files, if edited, don't run


This is weird.

When I run a Ramus file from the website, I have no problem. But if I load it and re-save it from Notepad++, it fails to run. I get the headers, but the story never begins.

This is true under Chrome and Explorer both, and true for “Starborn” and for the Ramus demo.

I notice Jim had a problem running Vorple locally, and I wonder if something similar might be going on here. Starborn tells me “This document requires JavaScript support.” --which, if I gist the file correctly, is a default message that JavaScript is supposed to replace with the beginning of the story. This happens correctly when I load an unedited file, but not an edited one. Why?


It’s probably either Notepad++ somehow mangling the files or something in your edits that make the files not work. Try looking in the JavaScript error console for errors. You can open the console in Chrome by pressing ctrl-alt-J (or cmd-alt-J on a Mac). Alternatively if you could upload the non-working file here we could take a look.

Ok, I’ve found a minimal pair. One version is error-producing, the other not. The problem was I tried starting with a blank slate, and there’s something required (I guess) in what appeared to be story text.

If the big commented block remains commented out, it runs; if not, it does not. This is peculiar, because it seems I’ve just commented out the game, and spliced in a stub. The stub works; but the rest of it also has to be there.

Iexplorer will run the uncommented-out version, but it requires me to click to “allow blocked content”. OTOH, with it commented out, I do not get the “allow blocked content” button and do not get past the intro text box.



Starborn html { Background-color: #003366; } body { Opacity: 0.95; Font-size: 1.1em; Width: 80ex; Margin: 5ex auto; Padding: 5ex; Background-color: white; Color: black; Border: 1px solid black; Border-right-width: 2px; Border-bottom-width: 2px; -webkit-box-shadow: 3px 3px 3px #336699; -moz-box-shadow: 3px 3px 3px #336699; Box-shadow: 3px 3px 3px #336699; Font-family: sans-serif; Position: relative; } a { Color: #006699; } a.external { Font-variant: small-caps; } a.external:visited { Color: #990066; } h1, h2, h3, h4, h5, h6 { Font-weight: bold; Font-family: sans-serif; } h1 { Font-size: 1.6em; Border-bottom: 1px solid black; Text-align: center; } h2 { Font-size: 1.5em; } h3 { Font-size: 1.4em; } h4 { Font-size: 1.3em; } h5 { Font-size: 1.2em; } h6 { Font-size: 1.1em; } #transcript table { Margin: 1em auto; } #transcript th, #transcript td { Margin: 0; Padding: 0.5em; Border: 1px solid #808080; Border-collapse: collapse; } #transcript th { Color: #ffffff; Background-color: #808080; Font-family: sans-serif; } #transcript hr { Color: #808080; } address { Font-size: 0.9em; Text-align: center; } dt { Font-weight: bold; }


by Juhana Leinonen
Ramus edition by Felix Pleșoianu
[?do passport_found = false; passport_taken = false; have_ticket = false; ?]

A small edit. A long day of travel and weightlessness has exhausted him.

As you ponder weightlessness, your mind drifts, as it so often does, to easycheese. Mmm, easycheese...

This document requires Javascript support.

It’s simply that you have one div you haven’t closed. Move the --> one line higher so that you have a matching number of

s and
s and it’ll work.

Internet Explorer will block scripts on the local computer by default, so that’s expected.

Yes, that worked! Thank you, Juhana.