.qut save files in Zoom and Frotz on ipad?

Has anyone been able to swap saved game files between Frotz on iPad and Zoom on Mac? I’m attempting this and I get interpreter errors when I take a Zoom saved file over to iPad Frotz (via Dropbox).

I see that Zoom on the Mac is using a packaged storage for saves, but I see a .qut file right in the package which I assumed was a quetzal file. Is that not correct?

I don’t know the answer, but based on what you said, if Zoom encloses a .qut file in a package, there is probably a reason involving other information that is also stored in that package: I mean information extraneous to the actual save, like window size and font selection, I’m guessing?

What I would try is saving the game in Zoom, and then opening the package and replacing the .qut file with the .qut file from the other source, but leaving the rest of the package as is: if you have not tried this already.


When you say “interpreter errors”, what are they?

Argh I misread the direction you are trying to go in (Zoom to Frotz) — sorry about that.

My steps:

Saved a game in Zoom, dug into the package and pulled out the .qut file, copied it over to dropbox so that it could be picked up by ipad frotz.

Ran the game in frotz on ipad, ‘restore’ the file and get:

@Attempt to address illegal object 13553. This is normally fatal. Fatal error: Illegal object

Okay. So iOS Frotz recognizes the file and accepts it, but it winds up loaded into the VM incorrectly.

I just tried saving a game in Mac Zoom, and then restoring the save.qut file into command-line frotz (actually nfrotz). This worked fine. So what you’re doing should work; it sounds like an iOS Frotz bug.

(Another possibility is that you’re trying to move a save file between different releases of the game file. However, the interpreter is supposed to detect this – the save file contains a fingerprint of the game file it belongs to – so it’s still a bug.)

You should contact the iOS maintainer and ask about this.