Quixe and graphic window background color

Hello, and sorry if this has been asked before…

I’m tinkering a bit with quixe (and Inform 6)… everything is going more or less fine, but I cannot find a way to change the color of a graphic window.
I’ve already tried to modify glkote.css adding a .GraphicWindow or a .WindowRock_210 entry, and obviously I’ve tried glk_window_set_background_color. My graphic window background is still completely white.
With a 'terp everything works fine.

How can I do that?

Thanks in advance


github.com/erkyrath/glk-dev/blo … intest.inf is an I6 test that covers this sort of thing.

You probably want to call glk_window_set_background_color followed by glk_window_clear.

First of all, thanks a lot.

Then I checked your file (which works well) and - if I haven’t done something wrong - I found a bizarre behaviour: if I set the color and immediately clear the window, quixe doesn’t set the color (and that was my problem).
I’ve modified your file adding a ‘recolor’ verb which does the setcolor+erase: on gargoyle it works well, but on quixe ‘recolor’ works exactly as ‘clear’.

[code][ ReColorSub;
if (~~gg_graphwin)
print_ret “There is no graphics window.”;

glk_window_set_background_color(gg_graphwin, parsed_number);
print_ret "Set default window color to ", (Hex6) parsed_number, ", then erased.";


I still have to check what should I do between setting background and clearing window to make it work.

Thanks again


I’ll take a look – probably a quixe bug.

Ok. Thanks a lot.


Yes, it was a bug. Thanks for catching that.

Quixe 2.1.2 (including this fix) can be downloaded at eblong.com/zarf/glulx/quixe/ .

Ok. Works perfectly.
Thanks a lot for the quick fix.