Question About Tables [Solved]

Hello! Hope you all are having a great 2014.

I am attempting to create a table so when the player does “ASK character ABOUT something” it would pull from the table I have created. Here is what I got:

Section 1 - Tommy Bartow 

[this should cover all the actions of Tommy Bartow and give the player someone to talk too.]

After asking the Bartow about a topic listed in the Table of Bartow Knowledge:
	say "[answer]."

[this is the table of knowledge of Bartow.]

Table of Bartow Knowledge
topic	answer
"Hades Team/Hades"	"We're the best of the best, buddy, you know that!"
"Station X-1/Station"	"Don't know much about it except what we heard in the briefing."
"Bartow/himself"	"Me? We've been hanging out since we met in Basic Training."

When I attempt to compile it, I get this result.

Problem. You wrote 'say "[answer]."'  , and in particular 'answer': but this asked to say something of a kind which can't be said, or rather, printed. Although this problem can arise when you use complicated text substitutions which come in variant forms depending on the kinds of value used, far more often what this means is just that you tried to use a substituted value (e.g., in 'say "The dial reads [V]."') of a kind which could not be printed out. For instance, if V is a number or a piece of text, there is no problem: but if V is a parsing topic, say an entry in a 'topic' column of a table, then this problem will arise.

I was trying to match one of these phrases:

1. say "answer - text" 

2. say "[answer - number]" 

3. say "[answer - unicode character]" 

4. say "[answer - sayable value]" 

5. say ""." - text" 

This was what I found out:

answer = a texts valued table column

You forgot one word (I hate it when that happens!)

It really should be [answer entry]

The “entry” part makes inform know that you’re referring to a table entry that has been chosen by code such as “a topic listed in”.

Ohhhhh. that explains it. Thanks! It’s compiled.

One note: be careful with slashes in topic entries. They only replace one word. So “Hades Team/Hades” will match “Hades Team” or “Hades Hades” but not “Hades” on its own. You should use the syntax “Hades Team” or “Hades” (with the word “or” in there) in this case.


Thank you! That explains why another part of the code wasn’t working. I was trying to figure it out.