problems with zoom

I’ve been playing IF with zoom (v 1.1.5) for a couple months now. Eventually I begin playing the exciting adventure Spider and Web by Andrew Plotkin. After I get a decent way through it, suddenly the game won’t respond to the keyboard. I can’t type, I see the “>” but there is no blinking vertical line, and neither clicking nor pressing enter causes anything. I close and reopen the game, but I can only type one command before the lockup occurs again.

Next I discover that the Andrew Plotkin games I have (like Shade, Hunter in darkness, Dreamhold) suffer from this. While others (Adventure, Zork, Taco fiction) work fine. After restarting the computer, reinstalling zoom and the games with no luck, I give up for a while.

The next day I give it another try and the games work fine. Several hours later the lockup starts again. After more futile restart/reinstall, I sit to type this request for help. Checking now the games work fine, I suspect the problem will be back eventually. What really bothers me is that it doesn’t seem to be connected to anything I’m doing. Either I’m just typing along, and it craps out, or I open the story six hours later and it’s fine.

Anyone have any clues to this mysterious problem?

Not specifically. But I have had compatibility trouble with Zoom on many games — often enough that I have started to just launch things in Gargoyle to begin with, since that’s where I frequently end up, anyway.

I’m quite sure there’s no shared Inform code between those games of mine that would be causing this.

It sounds like an application flaky error rather than a bug in the Z-code interpreter engine. But knowing that doesn’t help, I’m afraid.

I suppose I’ll just switch to Gargoyle. It’s a shame since Zoom is rather pretty.

I don’t find Zoom prettier ever since I figured out how to change the font style in Gargoyle (I hate reading serif fonts on a computer) and increase the font size. The default choices for these things in Gargoyle are poor; and you have to edit a config text file to change them which is not the friendliest thing in the world, but once I did it I had no reasons remaining to try to launch things in Zoom.

(BTW you can resize the Gargoyle window from the bottom right corner even though there is no standard grabby little triangle there.)


Alrighty. :slight_smile: Thanks for the tips. Now I may continue enjoying these magical books that speak back to you.

similar problems here:


Good to know there are others with the same problem. Click the link that stadtgorilla provided to see lots of further info/debug that I provided on that other thread.

I’ve now emailed the author, Andrew Hunter, and will report back as and when I hear anything.

Old topic I know, but I just wanted to note that I just had this exact problem. I’d played a few other games without incident (on a Mac running OSX 7.5), but lately I was playing Emily Short’s Bronze. I’d been playing on and off for a few days, getting pretty far, when suddenly, bam, the game just stops accepting input. I restart it and find that it actually DOES accept input for your FIRST command upon loading–in this case, it allows you to answer the question “Have you played interactive fiction before?” But whether you enter yes, no, or irrelevant gibberish, the result is the same: the game once again locks down. I’ve tested a number of other games, and they all seem to work fine. But Bronze is DONE: I’ve tried restarting the computer, re-downloading Zoom, re-downloading Bronze, downloading an earlier version of Zoom, changing the name of the Zoom file, changing the name of the Bronze file–nothin,’ and it’s really quite maddening. I suppose there must be some hidden file somewhere that’s causing the problem, but I’m not technically oriented enough to find it. I tried downloading Gargoyle, and the game works there, but I like Zoom better, and in any case, my save files are of course incompatible. Blah.

You can actually extract a save file from Zoom that will work in Gargoyle, but it’s a bit of work. More here (and if you have any questions, ask).

Thank you! I do have a question re extracting save data: when I choose “show package contents” for the Bronze save file, it gives me five files: “info.plist,” “save.qut,” “Skein.skein,” “ZoomPreview.dat,” and “ZoomStatus.dat.” I assume save.gut is the one I need, but I’ve taken it out and tried renaming it, and Gargoyle doesn’t seem to recognize it as a valid save file no matter what I do. Any tips? Thanks again.

This wound up being more trickier than I thought – to begin with, to try to reproduce your problem I fired up Bronze in Zoom and it wouldn’t let me enter anything at the prompt! So no Bronze save files for me. But I got another z-machine save file and this is what worked:

Option-drag save.qut to where you want it to go. (If you just drag it instead, your Zoom save file will be permanently borked.)

Open up the file info for save.qut using command-I. Rename it to “Your filename here.sav”. The .sav is the important part – you should get a popup warning asking you if you’re sure you want to change the extension to .sav. What gave me trouble here is that I tried renaming it in the finder, and it changed it to “Your filename here.sav.qut”, which was no good. If it doesn’t try to warn you off, you need to try again.

Once you’ve changed it to a .sav, you should be able to open it in Gargoyle.

Hope this helps!

Perfect; thanks. I was doing exactly what you say–inadvertently renaming it to save.sav.qut.

I just realized that I had this exact problem with Calm, too, so I should really get back to that game… in Gargoyle.

EDIT: Actually I might have a different problem with Calm, which is a bug in Calm rather than Zoom:

“take tyre iron” causes the game to hang (but “take iron” works)

I suspect the problem is actually a memory handling error, and Zoom’s failure depends solely on chance and the vagaries of how memory is allocated in any particular moment.

I’m seeing the exact same problems in a number of games with Zoom. It’s a shame - I love the built-in access to the IFDB, and will miss it (but, not more than I miss being able to actually play the games.)

I’m informed that the authors have now fixed this for the next release.

Yeah, I forgot to mention that I notified an author and he said that they had figured out the problem.