Problems with the Parchment for Inform 7 template

Thanks for making such a useful tool! For some reason I am not able to get this running properly unfortunately. When the script did its job and the game launches, Parchment throws an error. I thought I am alone in this but asked fellow writers on the PunyInform Discord server and as it turns out they have the same problem. I am building in Windows currently. Haven’t had time yet to try it from my Linux environment where I actually have all my IF tools installed. Any ideas what’s the issue here?

Sorry about that, I had made an update to Parchment yesterday but didn’t test the Inform 7 template. I’ve reverted the change. If you download the template again it should work now. I’ll be more careful in the future!

1 Like

Very helpful tool, thanks.

I was having the same issue as 8bit_era. @Dannii I downloaded the template again, and it solves that error (thanks!) but now I’m having a different issue: the text entry box is positioned over the statusline for some reason?

Maybe this can be fixed with CSS, but thought I should highlight it!

Is this a z3 or a z5 game?

It’s a z3 game.

Then the library isn’t involved in printing the statusline, so I would assume this breaks in the same way for all z3 games.

That’s very odd. Other z3 games do work, both Infocom, modern ZIL, and older Inform.

Does it do the same thing in Lectrote? Anything in the browser console? Just to pin down what’s wrong.

The only thing I can think of that PunyInform does differently regarding reading user input is that input starts in the third column. (The prompt is two characters: "> ") Could that matter?

Probably not, GlkOte has been tested with various prompts before. Can you reproduce it with your Puny games?

No, I haven’t tried this script.

You could try it with another PunyInform game, like Alien Research Centre 3: Footprints In The Snow - Details

I just tried with Alien Research Centre 3 (as linked), and it does the same thing. Then tried a non-Puny z3 game (advent.z3) and it also does it. So doesn’t appear to be a PunyInform issue.

Also tried in multiple browsers, same thing, so not a browser issue.

Maybe worth someone else trying the script, just in case I’m doing something stupid!

1 Like

I have tried it now with Hibernated 1 Director’s Cut and I notably used the Z5 version. I have exactly the same issue @CompDelta noticed. The prompt is inside the status bar and the game actually is not playable. Not sure if that is a bug somehow related to @zarf’s code or if that is another problem with parchment. EDIT: the game IS playable if you’re fine with abusing the status bar as the game prompt.

1 Like

Just to mention, I messed with the CSS and found that if you turn off absolute positioning on the text input bar, then it moves back where it’s supposed to be, revealing the statusline.

However, I can’t find the entry for the text input bar within any of the included CSS files, so I don’t know how to correct it permanently.

EDIT: I know I could add an entry for it in style.css, but apparently the relevant styling is inline, so it gets overwritten from there.

When you do find a game that doesn’t work in the Parchment template, please do check if it works properly in Lectrote. I will investigate these issues soon, but if you can check that would be valuable information.

Edit: Oh, I think I see the problem.

Lectrote confirmed working!

I’ve fixed the error with the Parchment template. Very sorry for that - it actually hasn’t worked since Oct last year, but I guess no one has tried it until now. I really need to get some automated browser testing going.

I’ll split off these posts now.


Thank you so much @Dannii, I confirm it works now like a charm!