Problem with "The Pawn" (interpreter hangs)

The last few weeks, I’ve been playing Magnetic Scroll’s “The Pawn”.

I’m using the GtkMagnetic interpreter (v2.3, on Ubuntu Linux) and the game-file (both) downloaded from “The Magnetic Scrolls Memorial”, specifically the following:

Interpreter: … 7_i386.deb

Game file: …

The problem is that, at a specific point, the game hangs (freezes). I don’t know if it’s an interpreter problem, or a game-file problem, or something else…

I have also tried with a different version of Magnetic (GlkMagnetic, v2.2, from … with the same results (game freezes).

The specific point where the freeze occurs is (if you are familiar with the game) in the “Tree Trunk Room” when I give the command “pull boards” (“push boards” and “lift boards” have the same effect).

Has anybody played the game recently? What interpreter and what game-file were you using?

I attach a save-file, in case somebody wants to try and verify the problem. To replicate do:

$ unzip
$ gtkmagnetic pawn.mag

then when the game starts

Please enter filename : p09.sav
Are you sure (y/n)? y
>move boards
**game freezes**

Apologies, in advance, if this is not the right place to ask this question. I tried to locate a more suitable place—where Magnetic (the interpreter) maintenance issues are discussed, but I couldn’t find anything.

Any help or suggestions will be appreciated.

Thanks (3.63 KB)

Ooops! I typed this a bit hastily! The “pull boards” command, does not result in a freeze. But “push boards”, “move boards”, and “lift boards” do (result in a freeze)!

There certainly could well be bugs left in the Magnetic interpreter, though equally during development of Magnetic we turned up various bugs in the games themselves, and The Pawn was, as I recall, had more than its fair share of bugs. It would be interesting to know what happens in the game with these commands in an original release, running under an emulator.

The Magnetic sources do include scripts that were used to check the interpreter: these allow all the games to play through to completion. Looking at the script for The Pawn, its notable that the command used in the tree trunk room is “move planks” - does that work for you?

“move planks” also freezes the game.

I can also reproduce your freeze with Magnetic, even though the command works in the test script. Hmmm … I will make a note to look into this, but I can’t promise when.

It seems that the problem is with the save-file; some kind of corruption, or… I don’t know.

On a hunch, I starter playing the game today from the beginning (without restoring from a previously saved file). So far I have not been able to reproduce the problem. Even when I save and restore (I tried at several places), it still works fine.

The problem appears ONLY when I restore from one of my “old” save-files—from ANY one of them. It seems that the very first file I saved, just a few moves into the game, got corrupted (somehow) and then the corruption was passed-on, by subsequent saves, to the rest of the files.

Ooooh, what a nightmare… Glad that got sorted out.

Just think, “Avon” does that sort of thing on purpose if you save at key points. Gar.

This is good news!

I dimly recall that The Pawn does call the random number generator when it is first started, so it may be that your save file contains some state involving ‘unlucky’ random numbers that tickle a bug either in the Magnetic interpreter or the game, or there may be some other bug in the interpreter that led to save state corruption.

At some point I will have a look at the problematic save file - if the game gets jammed in a relatively small infinite loop somewhere it might be possible to diagnose the problem. Maybe :slight_smile: