Problem starting up Inform7

I have an issue when sarting up Inform7.
Every time I close the program and reopen it later, it gives me this message: “The program can’t start because ScaleGfx.dll is missing from your computer. Try reinstalling the program to fix this problem.”
The thing is, I have reinstalled the program, and it still gives me the same error message.
Is there anything I can do about this, or am I going to have to reinstall it every time I want to open it?

What is your computer operating system? What version of the Inform IDE are you using?

I’m using Windows 10, but I don’t exactly know what the IDE is and which I’m using… Do you know where I can find that?

Here’s the link to the current IDE (the integrated development environment for Inform 7). Updating may correct stuff.

That’s definitely odd behaviour - that should not be happening. It would suggest that somehow the file ScaleGfx.dll, which is part of the Inform 7 installation, is getting deleted or corrupted. Restart Inform 7 so that the problem occurs, then use Windows Explorer to look in the installation directory, which is usually “C:\Program Files (x86)\Inform 7” - it should be there (screen shot from a Windows 7 box, but you get the idea):

If the file isn’t there, something must be removing it. What anti-virus, if any, do you run? If you have anti-virus, does it have some sort of ‘quarantine’ facility? If so, see if the DLL is in there.

(By the way, when people talk about the “IDE”, they just mean the program that runs when you start “Inform 7” that provides the overall game editing and running. When you run it you can see which version you’ve got from the Help/About menu.)

Yeah, the file is there, I just checked. I don’t think I’m using any anti-virus right now.

EDIT: Wait a minute, I just tried opening the program from the location on the C drive and that did work. Maybe something’s wrong with my desktop shortcut?

EDIT again: Okay, turns out the shortcut on my desktop wasn’t a shortcut after all… I made a new one and now it works, so I think I’ve fixed the problem. Thanks for all your help!